]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- no point in requiring perl(threads) in noarch modules
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple - basic utilities for writing tests
9 Summary(pl):    Test::Simple - podstawowe narzêdzia do pisania testów
10 Name:           perl-Test-Simple
11 Version:        0.64
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e22dcd4f06eed7b389f2bd0d17ed4dc1
18 URL:            http://search.cpan.org/dist/Test-Simple/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Provides:       perl-Test-Builder-Tester = 1.04
22 Obsoletes:      perl-Test-Builder-Tester = 0:1.01
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
27
28 %description
29 AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
30 me to Detroit, but don't make me write tests!
31    -- perldoc Test::Tutorial
32
33 Test::Simple is an extremely simple, extremely basic module for
34 writing tests suitable for CPAN modules and other pursuits. If you
35 wish to do more complicated testing, use the Test::More module (a
36 drop-in replacement for this one).
37
38 The purpose of Test::More is to provide a wide range of testing
39 utilities. Various ways to say "ok" with better diagnostics,
40 facilities to skip tests, test future features and compare complicated
41 data structures. While you can do almost anything with a simple "ok()"
42 function, it doesn't provide good diagnostic output.
43
44 %description -l pl
45 AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
46 mnie, biczujcie mnie, wy¶lijcie do Detroit, ale nie ka¿cie pisaæ
47 testów!
48    -- perldoc Test::Tutorial
49
50 Test::Simple jest bardzo prostym, bardzo podstawowym modu³em do
51 pisania testów pasuj±cych do modu³ów CPAN i innych. Do bardziej
52 skomplikowanych testów lepiej u¿ywaæ modu³u Test::More (zastêpuj±cego
53 ten).
54
55 Celem Test::More jest dostarczenie szerokiego zakresu narzêdzi do
56 testowania. Ró¿ne sposoby powiedzenia "ok" z lepsz± diagnostyk±,
57 u³atwienia przy pomijaniu testów, testowaniu przysz³ych mo¿liwo¶ci i
58 porównywaniu skomplikowanych struktur danych. O ile mo¿na zrobiæ
59 prawie wszystko prost± funkcj± "ok()", nie daje ona dobrego wyj¶cia
60 diagnostycznego.
61
62 %prep
63 %setup -q -n %{pdir}-%{pnam}-%{version}
64 rm -f t/00signature.t
65 %{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
66
67 %build
68 %{__perl} Makefile.PL \
69         INSTALLDIRS=vendor
70 %{__make}
71
72 %{?with_tests:%{__make} test}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc Changes README TODO
88 %{perl_vendorlib}/Test/*.pm
89 %{perl_vendorlib}/Test/Builder
90 %{_mandir}/man3/*
This page took 0.030875 seconds and 4 git commands to generate.