]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- obsolete only standalone versions of perl-Test-Builder-Tester and perl-Test-Tester...
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple - basic utilities for writing tests
9 Summary(pl.UTF-8):      Test::Simple - podstawowe narzędzia do pisania testów
10 Name:           perl-Test-Simple
11 Version:        1.302062
12 %define fver    %(echo %{version} | tr -d _)
13 Release:        2
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{fver}.tar.gz
18 # Source0-md5:  d869f6754eccc38484da7e21e9c7bbcc
19 URL:            http://search.cpan.org/dist/Test-Simple/
20 %{?with_tests:BuildRequires:    perl-Test-Harness >= 2.03}
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 # see lib/Test/Builder/Tester.pm /VERSION
24 Provides:       perl-Test-Builder-Tester = %{version}
25 # see lib/Test/Tester.pm /VERSION
26 Provides:       perl-Test-Tester = %{version}
27 # obsolete only versions up to last standalone (Test::Builder::Tester 1.01, Test::Tester 0.109) to avoid obsoleting perl-modules
28 Obsoletes:      perl-Test-Builder-Tester < 1.02
29 Obsoletes:      perl-Test-Tester < 0.110
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
34
35 %description
36 AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
37 me to Detroit, but don't make me write tests!
38    -- perldoc Test::Tutorial
39
40 Test::Simple is an extremely simple, extremely basic module for
41 writing tests suitable for CPAN modules and other pursuits. If you
42 wish to do more complicated testing, use the Test::More module (a
43 drop-in replacement for this one).
44
45 The purpose of Test::More is to provide a wide range of testing
46 utilities. Various ways to say "ok" with better diagnostics,
47 facilities to skip tests, test future features and compare complicated
48 data structures. While you can do almost anything with a simple "ok()"
49 function, it doesn't provide good diagnostic output.
50
51 %description -l pl.UTF-8
52 AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
53 mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
54 testów!
55    -- perldoc Test::Tutorial
56
57 Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
58 pisania testów pasujących do modułów CPAN i innych. Do bardziej
59 skomplikowanych testów lepiej używać modułu Test::More (zastępującego
60 ten).
61
62 Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
63 testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
64 ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
65 porównywaniu skomplikowanych struktur danych. O ile można zrobić
66 prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
67 diagnostycznego.
68
69 %prep
70 %setup -q -n %{pdir}-%{pnam}-%{fver}
71 %{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
72
73 %build
74 %{__perl} Makefile.PL \
75         INSTALLDIRS=vendor
76 %{__make}
77
78 %{?with_tests:%{__make} test}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc Changes README
94 %{perl_vendorlib}/ok.pm
95 %{perl_vendorlib}/Test/Builder
96 %{perl_vendorlib}/Test/Builder.pm
97 %{perl_vendorlib}/Test/More.pm
98 %{perl_vendorlib}/Test/Simple.pm
99 %{perl_vendorlib}/Test/Tester
100 %{perl_vendorlib}/Test/Tester.pm
101 %{perl_vendorlib}/Test/use
102 %{perl_vendorlib}/Test2.pm
103 %{perl_vendorlib}/Test2
104 %{_mandir}/man3/Test::Builder*.3pm*
105 %{_mandir}/man3/Test::More.3pm*
106 %{_mandir}/man3/Test::Simple.3pm*
107 %{_mandir}/man3/Test::Tester*.3pm*
108 %{_mandir}/man3/Test::Tutorial.3pm*
109 %{_mandir}/man3/Test::use::ok.3pm*
110 %{_mandir}/man3/Test2*.3pm*
111 %{_mandir}/man3/ok.3pm*
This page took 0.067206 seconds and 4 git commands to generate.