]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- version 0.70
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple - basic utilities for writing tests
9 Summary(pl.UTF-8):      Test::Simple - podstawowe narzędzia do pisania testów
10 Name:           perl-Test-Simple
11 Version:        0.70
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8fc54e4c018e7a6fda7b916effd27824
18 URL:            http://search.cpan.org/dist/Test-Simple/
19 %{?with_tests:BuildRequires:    perl-Test-Harness >= 2.03}
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 Provides:       perl-Test-Builder-Tester = 1.07
23 Obsoletes:      perl-Test-Builder-Tester = 0:1.01
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
28
29 %description
30 AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
31 me to Detroit, but don't make me write tests!
32    -- perldoc Test::Tutorial
33
34 Test::Simple is an extremely simple, extremely basic module for
35 writing tests suitable for CPAN modules and other pursuits. If you
36 wish to do more complicated testing, use the Test::More module (a
37 drop-in replacement for this one).
38
39 The purpose of Test::More is to provide a wide range of testing
40 utilities. Various ways to say "ok" with better diagnostics,
41 facilities to skip tests, test future features and compare complicated
42 data structures. While you can do almost anything with a simple "ok()"
43 function, it doesn't provide good diagnostic output.
44
45 %description -l pl.UTF-8
46 AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
47 mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
48 testów!
49    -- perldoc Test::Tutorial
50
51 Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
52 pisania testów pasujących do modułów CPAN i innych. Do bardziej
53 skomplikowanych testów lepiej używać modułu Test::More (zastępującego
54 ten).
55
56 Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
57 testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
58 ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
59 porównywaniu skomplikowanych struktur danych. O ile można zrobić
60 prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
61 diagnostycznego.
62
63 %prep
64 %setup -q -n %{pdir}-%{pnam}-%{version}
65 rm -f t/00signature.t
66 %{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
67
68 %build
69 %{__perl} Makefile.PL \
70         INSTALLDIRS=vendor
71 %{__make}
72
73 %{?with_tests:%{__make} test}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc Changes README TODO
89 %{perl_vendorlib}/Test/*.pm
90 %{perl_vendorlib}/Test/Builder
91 %{_mandir}/man3/*
This page took 0.030044 seconds and 4 git commands to generate.