]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
9dca682c40a007f514dcb63c28b189f20c500c56
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple - basic utilities for writing tests
9 Summary(pl.UTF-8):      Test::Simple - podstawowe narzędzia do pisania testów
10 Name:           perl-Test-Simple
11 Version:        1.001_006
12 %define fver    %(echo %{version} | tr -d _)
13 Release:        1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{fver}.tar.gz
18 # Source0-md5:  581ac4d2d7ace1f56409bc112e8ad02c
19 URL:            http://search.cpan.org/dist/Test-Simple/
20 %{?with_tests:BuildRequires:    perl-Test-Harness >= 2.03}
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Provides:       perl-Test-Builder-Tester = 1.24
24 Obsoletes:      perl-Test-Builder-Tester = 0:1.01
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
29
30 %description
31 AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
32 me to Detroit, but don't make me write tests!
33    -- perldoc Test::Tutorial
34
35 Test::Simple is an extremely simple, extremely basic module for
36 writing tests suitable for CPAN modules and other pursuits. If you
37 wish to do more complicated testing, use the Test::More module (a
38 drop-in replacement for this one).
39
40 The purpose of Test::More is to provide a wide range of testing
41 utilities. Various ways to say "ok" with better diagnostics,
42 facilities to skip tests, test future features and compare complicated
43 data structures. While you can do almost anything with a simple "ok()"
44 function, it doesn't provide good diagnostic output.
45
46 %description -l pl.UTF-8
47 AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
48 mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
49 testów!
50    -- perldoc Test::Tutorial
51
52 Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
53 pisania testów pasujących do modułów CPAN i innych. Do bardziej
54 skomplikowanych testów lepiej używać modułu Test::More (zastępującego
55 ten).
56
57 Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
58 testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
59 ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
60 porównywaniu skomplikowanych struktur danych. O ile można zrobić
61 prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
62 diagnostycznego.
63
64 %prep
65 %setup -q -n %{pdir}-%{pnam}-%{fver}
66 %{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
67
68 %build
69 %{__perl} Makefile.PL \
70         INSTALLDIRS=vendor
71 %{__make}
72
73 %{?with_tests:%{__make} test}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc Changes README TODO
89 %{perl_vendorlib}/Test/Builder
90 %{perl_vendorlib}/Test/Builder.pm
91 %{perl_vendorlib}/Test/More.pm
92 %{perl_vendorlib}/Test/Simple.pm
93 %{_mandir}/man3/Test::Builder*.3pm*
94 %{_mandir}/man3/Test::More.3pm*
95 %{_mandir}/man3/Test::Simple.3pm*
96 %{_mandir}/man3/Test::Tutorial.3pm*
This page took 0.063468 seconds and 2 git commands to generate.