]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blob - perl-Test-Simple.spec
- check-files cleanup, adapterized
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Simple
8 Summary:        Test::Simple - basic utilities for writing tests
9 Summary(pl):    Test::Simple - podstawowe narzêdzia do pisania testów
10 Name:           perl-Test-Simple
11 Version:        0.64
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e22dcd4f06eed7b389f2bd0d17ed4dc1
18 URL:            http://search.cpan.org/dist/Test-Simple/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Provides:       perl-Test-Builder-Tester = 1.04
22 Obsoletes:      perl-Test-Builder-Tester = 0:1.01
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # false requires found by rpm 4.0.2
27 %if "%(perl -MConfig -e 'print $Config{useithreads};')" != "define"
28 %define         _noautoreq      'perl(threads)' 'perl(threads::shared)'
29 %else
30 Requires:       perl(threads)
31 Requires:       perl(threads::shared)
32 %endif
33
34 %description
35 AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
36 me to Detroit, but don't make me write tests!
37  - -- perldoc Test::Tutorial
38
39 Test::Simple is an extremely simple, extremely basic module for
40 writing tests suitable for CPAN modules and other pursuits. If you
41 wish to do more complicated testing, use the Test::More module (a
42 drop-in replacement for this one).
43
44 The purpose of Test::More is to provide a wide range of testing
45 utilities. Various ways to say "ok" with better diagnostics,
46 facilities to skip tests, test future features and compare complicated
47 data structures. While you can do almost anything with a simple "ok()"
48 function, it doesn't provide good diagnostic output.
49
50 %description -l pl
51 AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
52 mnie, biczujcie mnie, wy¶lijcie do Detroit, ale nie ka¿cie pisaæ
53 testów!
54  - -- perldoc Test::Tutorial
55
56 Test::Simple jest bardzo prostym, bardzo podstawowym modu³em do
57 pisania testów pasuj±cych do modu³ów CPAN i innych. Do bardziej
58 skomplikowanych testów lepiej u¿ywaæ modu³u Test::More (zastêpuj±cego
59 ten).
60
61 Celem Test::More jest dostarczenie szerokiego zakresu narzêdzi do
62 testowania. Ró¿ne sposoby powiedzenia "ok" z lepsz± diagnostyk±,
63 u³atwienia przy pomijaniu testów, testowaniu przysz³ych mo¿liwo¶ci i
64 porównywaniu skomplikowanych struktur danych. O ile mo¿na zrobiæ
65 prawie wszystko prost± funkcj± "ok()", nie daje ona dobrego wyj¶cia
66 diagnostycznego.
67
68 %prep
69 %setup -q -n %{pdir}-%{pnam}-%{version}
70 rm -f t/00signature.t
71 %{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
72
73 %build
74 %{__perl} Makefile.PL \
75         INSTALLDIRS=vendor
76 %{__make}
77
78 %{?with_tests:%{__make} test}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc Changes README TODO
94 %{perl_vendorlib}/Test/*.pm
95 %{perl_vendorlib}/Test/Builder
96 %{_mandir}/man3/*
This page took 0.028585 seconds and 3 git commands to generate.