]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blame_incremental - perl-Test-Simple.spec
- updated to 1.001006 (as 1.001_006 for rpm version comparator compatibility)
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Test
7%define pnam Simple
8Summary: Test::Simple - basic utilities for writing tests
9Summary(pl.UTF-8): Test::Simple - podstawowe narzędzia do pisania testów
10Name: perl-Test-Simple
11Version: 1.001_006
12%define fver %(echo %{version} | tr -d _)
13Release: 1
14# same as perl
15License: GPL v1+ or Artistic
16Group: Development/Languages/Perl
17Source0: http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{fver}.tar.gz
18# Source0-md5: 581ac4d2d7ace1f56409bc112e8ad02c
19URL: http://search.cpan.org/dist/Test-Simple/
20%{?with_tests:BuildRequires: perl-Test-Harness >= 2.03}
21BuildRequires: perl-devel >= 1:5.8.0
22BuildRequires: rpm-perlprov >= 4.1-13
23Provides: perl-Test-Builder-Tester = 1.24
24Obsoletes: perl-Test-Builder-Tester = 0:1.01
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%define _noautoreq 'perl(threads)' 'perl(threads::shared)'
29
30%description
31AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
32me to Detroit, but don't make me write tests!
33 -- perldoc Test::Tutorial
34
35Test::Simple is an extremely simple, extremely basic module for
36writing tests suitable for CPAN modules and other pursuits. If you
37wish to do more complicated testing, use the Test::More module (a
38drop-in replacement for this one).
39
40The purpose of Test::More is to provide a wide range of testing
41utilities. Various ways to say "ok" with better diagnostics,
42facilities to skip tests, test future features and compare complicated
43data structures. While you can do almost anything with a simple "ok()"
44function, it doesn't provide good diagnostic output.
45
46%description -l pl.UTF-8
47AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
48mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
49testów!
50 -- perldoc Test::Tutorial
51
52Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
53pisania testów pasujących do modułów CPAN i innych. Do bardziej
54skomplikowanych testów lepiej używać modułu Test::More (zastępującego
55ten).
56
57Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
58testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
59ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
60porównywaniu skomplikowanych struktur danych. O ile można zrobić
61prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
62diagnostycznego.
63
64%prep
65%setup -q -n %{pdir}-%{pnam}-%{fver}
66%{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
67
68%build
69%{__perl} Makefile.PL \
70 INSTALLDIRS=vendor
71%{__make}
72
73%{?with_tests:%{__make} test}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78%{__make} install \
79 DESTDIR=$RPM_BUILD_ROOT
80
81%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%files
87%defattr(644,root,root,755)
88%doc Changes README TODO
89%{perl_vendorlib}/Test/Builder
90%{perl_vendorlib}/Test/Builder.pm
91%{perl_vendorlib}/Test/More.pm
92%{perl_vendorlib}/Test/Simple.pm
93%{_mandir}/man3/Test::Builder*.3pm*
94%{_mandir}/man3/Test::More.3pm*
95%{_mandir}/man3/Test::Simple.3pm*
96%{_mandir}/man3/Test::Tutorial.3pm*
This page took 0.065229 seconds and 4 git commands to generate.