]> git.pld-linux.org Git - packages/perl-Plack.git/blob - perl-Plack.spec
- up to 1.0044
[packages/perl-Plack.git] / perl-Plack.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Plack
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Plack - Perl Superglue for Web frameworks and Web Servers (PSGI toolkit)
8 #Summary(pl.UTF-8):
9 Name:           perl-Plack
10 Version:        1.0044
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Plack/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  ecca999f0034f04c8dbcf230ac8c3241
17 URL:            http://search.cpan.org/dist/Plack/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Devel::StackTrace::AsHTML) >= 0.11
22 BuildRequires:  perl(Filesys::Notify::Simple)
23 BuildRequires:  perl(HTTP::Body) >= 1.06
24 BuildRequires:  perl(Hash::MultiValue) >= 0.05
25 BuildRequires:  perl(Test::Requires)
26 BuildRequires:  perl(Test::TCP) >= 0.11
27 BuildRequires:  perl-Apache-LogFormat-Compiler
28 BuildRequires:  perl-Devel-StackTrace >= 1.23
29 BuildRequires:  perl-File-ShareDir >= 1.00
30 BuildRequires:  perl-File-ShareDir-Install
31 BuildRequires:  perl-HTTP-Entity-Parser
32 BuildRequires:  perl-HTTP-Request-AsCGI
33 BuildRequires:  perl-Stream-Buffered
34 BuildRequires:  perl-Try-Tiny
35 BuildRequires:  perl-URI >= 1.36
36 BuildRequires:  perl-libwww >= 5.814
37 %endif
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _noautoreq_perl 'Apache::Constants' 'Apache::Request'
42
43 %description
44 Plack is a set of tools for using the PSGI stack. It contains
45 middleware components, a reference server and utilities for Web
46 application frameworks. Plack is like Ruby's Rack or Python's Paste
47 for WSGI.
48
49 See PSGI for the PSGI specification and PSGI::FAQ to know what PSGI
50 and Plack are and why we need them.
51
52
53
54 # %description -l pl.UTF-8 # TODO
55
56 %prep
57 %setup -q -n %{pdir}-%{version}
58
59 %build
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 %{__make}
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} pure_install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc Changes README
81 %{perl_vendorlib}/*.pm
82 %{perl_vendorlib}/Plack/
83 %{_mandir}/man1/*
84 %{_mandir}/man3/*
85 %{_examplesdir}/%{name}-%{version}
86 %attr(755,root,root) %{_bindir}/plackup
87 %{perl_vendorlib}/HTTP/Message/PSGI.pm
88 %{perl_vendorlib}/HTTP/Server/PSGI.pm
89 %{perl_vendorlib}/auto/share/dist/Plack
This page took 0.056975 seconds and 3 git commands to generate.