]> git.pld-linux.org Git - packages/perl-Plack.git/blame - perl-Plack.spec
- rpm5 noautoreq
[packages/perl-Plack.git] / perl-Plack.spec
CommitLineData
01cccd88 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Plack
6%include /usr/lib/rpm/macros.perl
7Summary: Plack - Perl Superglue for Web frameworks and Web Servers (PSGI toolkit)
8#Summary(pl.UTF-8):
9Name: perl-Plack
2192d03c 10Version: 0.9986
34dedfd0 11Release: 2
01cccd88 12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Plack/%{pdir}-%{version}.tar.gz
2192d03c 16# Source0-md5: 90d63ab0dc479136906db43ab9a99df1
01cccd88 17URL: http://search.cpan.org/dist/Plack/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl(Devel::StackTrace::AsHTML) >= 0.11
22BuildRequires: perl(Filesys::Notify::Simple)
23BuildRequires: perl(HTTP::Body) >= 1.06
24BuildRequires: perl(Hash::MultiValue) >= 0.05
25BuildRequires: perl(Test::Requires)
26BuildRequires: perl(Test::TCP) >= 0.11
27BuildRequires: perl-Devel-StackTrace >= 1.23
28BuildRequires: perl-File-ShareDir >= 1.00
29BuildRequires: perl-HTTP-Request-AsCGI
30BuildRequires: perl-Try-Tiny
31BuildRequires: perl-URI >= 1.36
32BuildRequires: perl-libwww >= 5.814
33%endif
34BuildArch: noarch
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
34dedfd0 37%define _noautoreq_perl 'Apache::Constants' 'Apache::Request'
01cccd88 38
39%description
40Plack is a set of tools for using the PSGI stack. It contains
41middleware components, a reference server and utilities for Web
42application frameworks. Plack is like Ruby's Rack or Python's Paste
43for WSGI.
44
45See PSGI for the PSGI specification and PSGI::FAQ to know what PSGI
46and Plack are and why we need them.
47
48
49
50# %description -l pl.UTF-8 # TODO
51
52%prep
53%setup -q -n %{pdir}-%{version}
01cccd88 54
55%build
56%{__perl} Makefile.PL \
57 INSTALLDIRS=vendor
58%{__make}
59
60%{?with_tests:%{__make} test}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64
65%{__make} pure_install \
66 DESTDIR=$RPM_BUILD_ROOT
67
68install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%files
75%defattr(644,root,root,755)
76%doc Changes README
77%{perl_vendorlib}/*.pm
78%{perl_vendorlib}/Plack/
79%{_mandir}/man1/*
80%{_mandir}/man3/*
81%{_examplesdir}/%{name}-%{version}
82%attr(755,root,root) %{_bindir}/plackup
83%{perl_vendorlib}/HTTP/Message/PSGI.pm
84%{perl_vendorlib}/HTTP/Server/PSGI.pm
85%{perl_vendorlib}/auto/share/dist/Plack
This page took 0.082051 seconds and 4 git commands to generate.