]> git.pld-linux.org Git - packages/perl-Nagios-Plugin.git/blame - perl-Nagios-Plugin.spec
- use base ... not catched by perl autodeps
[packages/perl-Nagios-Plugin.git] / perl-Nagios-Plugin.spec
CommitLineData
93559fee
ER
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Nagios
7%define pnam Plugin
8Summary: Nagios::Plugin - A family of perl modules to streamline writing Nagios plugins
9Name: perl-Nagios-Plugin
10Version: 0.23
9f2c46e5 11Release: 2
93559fee
ER
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-authors/id/T/TO/TONVOON/Nagios-Plugin-%{version}.tar.gz
16# Source0-md5: 7eb466f122ea83788506d78d7bf2c402
17URL: http://search.cpan.org/dist/Nagios-Plugin/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl(Class::Accessor)
22BuildRequires: perl(Config::Tiny)
23BuildRequires: perl(Math::Calc::Units)
24BuildRequires: perl(Params::Validate)
25BuildRequires: perl(Test::More) >= 0.62
26%endif
9f2c46e5
ER
27# Not catched by `use base qw(Class::Accessor::Fast)'; construct
28Requires: perl-Class-Accessor
29Requires: perl-Config-Tiny
93559fee
ER
30BuildArch: noarch
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Nagios::Plugin and its associated Nagios::Plugin::* modules are a
35family of Perl modules to streamline writing Nagios plugins. The main
36end user modules are Nagios::Plugin, providing an object-oriented
37interface to the entire Nagios::Plugin::* collection, and
38Nagios::Plugin::Functions, providing a simpler functional interface to
39a useful subset of the available functionality.
40
41The purpose of the collection is to make it as simple as possible for
42developers to create plugins that conform the Nagios Plugin guidelines
43<http://nagiosplug.sourceforge.net/developer-guidelines.html>.
44
45%prep
46%setup -q -n %{pdir}-%{pnam}-%{version}
47
48%build
49%{__perl} Makefile.PL \
50 INSTALLDIRS=vendor
51%{__make}
52
53%{?with_tests:%{__make} test}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58%{__make} install \
59 DESTDIR=$RPM_BUILD_ROOT
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
66%doc Changes README
215da35a 67%dir %{perl_vendorlib}/Nagios
93559fee
ER
68%{perl_vendorlib}/Nagios/*.pm
69%{perl_vendorlib}/Nagios/Plugin
70%{_mandir}/man3/*
This page took 0.191675 seconds and 4 git commands to generate.