]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blobdiff - perl-IO-Socket-SSL.spec
up to 2.069
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
index ba2aab2cb64495a531763a799d1812df5ed7b7f9..f6b5ac57389092b2d681cbde19a396d556c12a29 100644 (file)
@@ -1,59 +1,80 @@
 #
 # Conditional build:
-# _without_tests - do not perform "make test"
-%include       /usr/lib/rpm/macros.perl
-%define        pdir    IO
-%define        pnam    Socket-SSL
-Summary:       IO::Socket::SSL -- Nearly transparent SSL encapsulation for IO::Socket::INET.
-#Summary(pl):  IO::Socket::SSL -- 
+%bcond_with    tests   # perform "make test" - needs network connection
+#
+%define                pdir    IO
+%define                pnam    Socket-SSL
+Summary:       IO::Socket::SSL - nearly transparent SSL encapsulation for IO::Socket::INET
+Summary(pl.UTF-8):     IO::Socket::SSL - prawie przezroczysta obudowa SSL dla IO::Socket::INET
 Name:          perl-IO-Socket-SSL
-Version:       0.901
+Version:       2.069
 Release:       1
-License:       GPL
+Epoch:         1
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-BuildRequires: perl >= 5.6
-BuildRequires: rpm-perlprov >= 3.0.3-18
-%if %{?_without_tests:0}%{!?_without_tests:1}
-BuildRequires: perl-Net-SSLeay
+Source0:       http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 237cc3ecf6ea470225ee5e652b0c046c
+URL:           http://search.cpan.org/dist/IO-Socket-SSL/
+%if %{with tests}
+BuildRequires: perl-Net-SSLeay >= 1.46
+BuildRequires: perl-Scalar-List-Utils
 %endif
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.745
+# actually Net::SSLeay using openssl >= 0.9.8
+Requires:      openssl >= 0.9.8
+Suggests:      perl-Net-IDN-Encode
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-This module is a true drop-in replacement for IO::Socket::INET that uses
-SSL to encrypt data before it is transferred to a remote server or client.
-IO::Socket::SSL supports all the extra features that one needs to write
-a full-featured SSL client or server application: multiple SSL contexts,
-cipher selection, certificate verification, and SSL version selection.
-As an extra bonus, it works perfectly with mod_perl.
+This module is a true drop-in replacement for IO::Socket::INET that
+uses SSL to encrypt data before it is transferred to a remote server
+or client. IO::Socket::SSL supports all the extra features that one
+needs to write a full-featured SSL client or server application:
+multiple SSL contexts, cipher selection, certificate verification, and
+SSL version selection. As an extra bonus, it works perfectly with
+mod_perl.
 
-# %description -l pl
-# TODO
+%description -l pl.UTF-8
+Ten moduł jest prawdziwym zamiennikiem dla IO::Socket::INET,
+używającym SSL do kodowania danych przed przesyłaniem do zdalnego
+serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
+rzeczy potrzebne do napisania w pełni funkcjonalnego klienta lub
+serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
+certyfikatu, wybór wersji SSL. Ponadto wspaniale działa z mod_perlem.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-perl Makefile.PL
+echo "n" | \
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
 
-%{!?_without_tests:%{__make} test}
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-install example/* util/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/IO/Socket/SSL.pod
+
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+install example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README docs/*
-%{perl_sitelib}/IO/Socket/SSL.pm
-%{_mandir}/man3/*
+%doc Changes README docs/*
+%{perl_vendorlib}/IO/Socket/SSL.pm
+%{perl_vendorlib}/IO/Socket/SSL
+%{_mandir}/man3/IO::Socket::SSL*.3pm*
 %{_examplesdir}/%{name}-%{version}
This page took 0.106127 seconds and 4 git commands to generate.