]> git.pld-linux.org Git - packages/performous.git/commitdiff
- fix building with ffmpeg 3 auto/th/performous-1.0-3
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 30 Mar 2016 14:53:41 +0000 (23:53 +0900)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 30 Mar 2016 14:53:41 +0000 (23:53 +0900)
- rel 3

ffmpeg3.patch [new file with mode: 0644]
performous.spec

diff --git a/ffmpeg3.patch b/ffmpeg3.patch
new file mode 100644 (file)
index 0000000..f0f5232
--- /dev/null
@@ -0,0 +1,22 @@
+diff -ur performous-1.0.orig/game/ffmpeg.cc performous-1.0/game/ffmpeg.cc
+--- performous-1.0.orig/game/ffmpeg.cc 2014-10-29 08:11:45.000000000 +0900
++++ performous-1.0/game/ffmpeg.cc      2016-03-30 23:49:22.449629159 +0900
+@@ -116,7 +116,7 @@
+               height = cc->height;
+               m_swsContext = sws_getContext(
+                 cc->width, cc->height, cc->pix_fmt,
+-                width, height, PIX_FMT_RGB24,
++                width, height, AV_PIX_FMT_RGB24,
+                 SWS_POINT, nullptr, nullptr, nullptr);
+               break;
+       default:  // Should never be reached but avoids compile warnings
+@@ -187,7 +187,7 @@
+               if (packetSize < 0) throw std::logic_error("negative packet size?!");
+               if (m_quit || m_seekTarget == m_seekTarget) return;
+               if (packet.stream_index != m_streamId) return;
+-              boost::shared_ptr<AVFrame> frame(avcodec_alloc_frame(), &av_free);
++              boost::shared_ptr<AVFrame> frame(av_frame_alloc(), &av_free);
+               int frameFinished = 0;
+               int decodeSize = (m_mediaType == AVMEDIA_TYPE_VIDEO ?
+                 avcodec_decode_video2(m_codecContext, frame.get(), &frameFinished, &packet) :
+Only in performous-1.0/game: ffmpeg.cc~
index 15b2432c70ee7240aa51dee880d17afbc3cb82e1..7844c06761dfee67b5490586fd3632c2bbaf9a3f 100644 (file)
@@ -2,15 +2,16 @@ Summary:      Performous - The All-in-One Music Game
 Summary(pl.UTF-8):     Performous - wiele gier muzycznych w jednej
 Name:          performous
 Version:       1.0
-Release:       2
+Release:       3
 License:       GPL v2+
 Group:         Applications
 Source0:       https://github.com/performous/performous/archive/1.0/%{name}-%{version}.tar.gz
 # Source0-md5: cbeec2f0c0114cc499746c1e33f56055
-Patch1:                bool_cast.patch
+Patch0:                bool_cast.patch
+Patch1:                ffmpeg3.patch
 URL:           http://performous.org/
 BuildRequires: ImageMagick-c++-devel
-BuildRequires: SDL-devel
+BuildRequires: SDL2-devel
 BuildRequires: alsa-lib-devel
 BuildRequires: boost-devel
 BuildRequires: cmake >= 2.6
@@ -23,7 +24,7 @@ BuildRequires:        jack-audio-connection-kit-devel
 BuildRequires: libpng-devel
 BuildRequires: librsvg-devel
 BuildRequires: libsigc++-devel
-BuildRequires: libxml++-devel
+BuildRequires: libxml++2-devel
 BuildRequires: opencv-devel
 BuildRequires: pango-devel
 BuildRequires: pkgconfig
@@ -57,6 +58,7 @@ Zestaw narzędzi do konwersji danych dla programu Performous.
 
 %prep
 %setup -q
+%patch0 -p1
 %patch1 -p1
 
 mkdir build
This page took 0.178403 seconds and 4 git commands to generate.