]> git.pld-linux.org Git - packages/performous.git/commitdiff
- updated to 1.1 auto/th/performous-1.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 8 May 2019 16:34:19 +0000 (18:34 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 8 May 2019 16:34:19 +0000 (18:34 +0200)
- removed obsolete bool_cast,ffmpeg3 patches
- added boost patch

bool_cast.patch [deleted file]
ffmpeg3.patch [deleted file]
performous-boost.patch [new file with mode: 0644]
performous.spec

diff --git a/bool_cast.patch b/bool_cast.patch
deleted file mode 100644 (file)
index c9dad85..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- performous-1.0/game/songparser.hh~ 2015-12-05 14:07:56.354059559 +0100
-+++ performous-1.0/game/songparser.hh  2015-12-05 14:08:12.647545320 +0100
-@@ -33,7 +33,7 @@
-       Song& m_song;
-       std::stringstream m_ss;
-       unsigned int m_linenum;
--      bool getline(std::string& line) { ++m_linenum; return std::getline(m_ss, line);}
-+      bool getline(std::string& line) { ++m_linenum; return static_cast<bool>(std::getline(m_ss, line));}
-       bool m_relative;
-       double m_gap;
-       double m_bpm;
diff --git a/ffmpeg3.patch b/ffmpeg3.patch
deleted file mode 100644 (file)
index f0f5232..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -ur performous-1.0.orig/game/ffmpeg.cc performous-1.0/game/ffmpeg.cc
---- performous-1.0.orig/game/ffmpeg.cc 2014-10-29 08:11:45.000000000 +0900
-+++ performous-1.0/game/ffmpeg.cc      2016-03-30 23:49:22.449629159 +0900
-@@ -116,7 +116,7 @@
-               height = cc->height;
-               m_swsContext = sws_getContext(
-                 cc->width, cc->height, cc->pix_fmt,
--                width, height, PIX_FMT_RGB24,
-+                width, height, AV_PIX_FMT_RGB24,
-                 SWS_POINT, nullptr, nullptr, nullptr);
-               break;
-       default:  // Should never be reached but avoids compile warnings
-@@ -187,7 +187,7 @@
-               if (packetSize < 0) throw std::logic_error("negative packet size?!");
-               if (m_quit || m_seekTarget == m_seekTarget) return;
-               if (packet.stream_index != m_streamId) return;
--              boost::shared_ptr<AVFrame> frame(avcodec_alloc_frame(), &av_free);
-+              boost::shared_ptr<AVFrame> frame(av_frame_alloc(), &av_free);
-               int frameFinished = 0;
-               int decodeSize = (m_mediaType == AVMEDIA_TYPE_VIDEO ?
-                 avcodec_decode_video2(m_codecContext, frame.get(), &frameFinished, &packet) :
-Only in performous-1.0/game: ffmpeg.cc~
diff --git a/performous-boost.patch b/performous-boost.patch
new file mode 100644 (file)
index 0000000..024b0f6
--- /dev/null
@@ -0,0 +1,50 @@
+--- performous-1.1/game/backgrounds.hh.orig    2016-01-23 11:40:01.000000000 +0100
++++ performous-1.1/game/backgrounds.hh 2019-05-08 16:01:24.991915179 +0200
+@@ -3,6 +3,7 @@
+ //#include "animvalue.hh"
+ #include "fs.hh"
+ //#include "song.hh"
++#include <boost/noncopyable.hpp>
+ #include <boost/shared_ptr.hpp>
+ #include <boost/scoped_ptr.hpp>
+ #include <boost/thread/mutex.hpp>
+--- performous-1.1/game/audio.cc.orig  2019-05-08 17:34:23.030331012 +0200
++++ performous-1.1/game/audio.cc       2019-05-08 17:34:26.247165898 +0200
+@@ -77,7 +77,7 @@
+       static ptime getTime() { return microsec_clock::universal_time(); }
+       // Conversion helpers
+       static double getSeconds(time_duration t) { return 1e-6 * t.total_microseconds(); }
+-      static time_duration getDuration(double seconds) { return microseconds(1e6 * seconds); }
++      static time_duration getDuration(double seconds) { return microseconds(static_cast<long>(1e6 * seconds)); }
+       mutable boost::mutex m_mutex;
+       ptime m_baseTime; ///< A reference time (corresponds to m_basePos)
+@@ -149,7 +149,7 @@
+       int64_t m_pos; ///< Current sample position
+       bool m_preview;
+       AudioClock m_clock;
+-      time_duration durationOf(int64_t samples) const { return microseconds(1e6 * samples / srate / 2.0); }
++      time_duration durationOf(int64_t samples) const { return microseconds(static_cast<long>(1e6 * samples / srate / 2.0)); }
+ public:
+       bool suppressCenterChannel;
+       double fadeLevel;
+--- performous-1.1/game/songs.hh.orig  2016-01-23 11:40:01.000000000 +0100
++++ performous-1.1/game/songs.hh       2019-05-08 17:34:44.194771102 +0200
+@@ -2,6 +2,7 @@
+ #include "animvalue.hh"
+ #include "fs.hh"
++#include <boost/noncopyable.hpp>
+ #include <boost/shared_ptr.hpp>
+ #include <boost/scoped_ptr.hpp>
+ #include <boost/thread/mutex.hpp>
+--- performous-1.1/game/svg.cc.orig    2016-01-23 11:40:01.000000000 +0100
++++ performous-1.1/game/svg.cc 2019-05-08 17:49:07.689926184 +0200
+@@ -4,6 +4,7 @@
+ #include "configuration.hh"
+ #include "../common/image.hh"
++#include <boost/shared_ptr.hpp>
+ #include <librsvg/rsvg.h>
+ #include <iostream>
index 1a51f7f0d476d6d15413308886e47fe8332872a5..65d921db868c167a54c086ea1524f444c4f5423f 100644 (file)
@@ -1,34 +1,41 @@
 Summary:       Performous - The All-in-One Music Game
 Summary(pl.UTF-8):     Performous - wiele gier muzycznych w jednej
 Name:          performous
-Version:       1.0
-Release:       8
+Version:       1.1
+Release:       1
 License:       GPL v2+
-Group:         Applications
-Source0:       https://github.com/performous/performous/archive/1.0/%{name}-%{version}.tar.gz
-# Source0-md5: cbeec2f0c0114cc499746c1e33f56055
-Patch0:                bool_cast.patch
-Patch1:                ffmpeg3.patch
+Group:         Applications/Sound
+#Source0Download: https://github.com/performous/performous/releases
+Source0:       https://github.com/performous/performous/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: cf31d0973cd88b3cd626d312d6d3f5b2
+Patch0:                %{name}-boost.patch
 URL:           http://performous.org/
 BuildRequires: ImageMagick-c++-devel
-BuildRequires: SDL2-devel
-BuildRequires: alsa-lib-devel
-BuildRequires: boost-devel
-BuildRequires: cmake >= 2.6
+BuildRequires: SDL2-devel >= 2
+BuildRequires: boost-devel >= 1.36
+BuildRequires: cmake >= 2.8
+# avformat avresample swscale
 BuildRequires: ffmpeg-devel
+BuildRequires: fontconfig-devel
 BuildRequires: gettext-tools
 BuildRequires: glew-devel
 BuildRequires: glibmm-devel
 BuildRequires: help2man
-BuildRequires: jack-audio-connection-kit-devel
+BuildRequires: libepoxy-devel >= 1.2
+BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: librsvg-devel
 BuildRequires: libsigc++-devel
-BuildRequires: libxml++2-devel
+BuildRequires: libstdc++-devel >= 6:4.6
+BuildRequires: libxml2-devel >= 2.0
+BuildRequires: libxml++2-devel >= 2.6
 BuildRequires: opencv-devel
-BuildRequires: pango-devel
+BuildRequires: pango-devel >= 1:1.12
 BuildRequires: pkgconfig
 BuildRequires: portaudio-devel
+BuildRequires: portmidi-devel
+BuildRequires: rpmbuild(macros) >= 1.605
+BuildRequires: zlib-devel
 Suggests:      %{name}-tools = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -48,7 +55,7 @@ wykrywane.
 %package tools
 Summary:       Performous tools
 Summary(pl.UTF-8):     Narzędzia do programu Performous
-Group:         Applications
+Group:         Applications/Sound
 
 %description tools
 Several utilities for converting data files for Performous.
@@ -59,25 +66,16 @@ Zestaw narzędzi do konwersji danych dla programu Performous.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-
-mkdir build
 
 %build
+install -d build
 cd build
 %cmake .. \
        -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
        -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags} -std=gnu++11" \
        -DCMAKE_DEBUG_FLAGS_RELEASE="%{debugcflags}" \
-       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
        -DMagick_LIBRARY="$(echo %{_libdir}/libMagickCore-*.so)" \
-       -DMagick++_LIBRARY="$(echo %{_libdir}/libMagick++-*.so)" \
-%if "%{_lib}" == "lib64"
-       -DLIB_SUFFIX=64
-%endif
-%if "%{_lib}" == "libx32"
-       -DLIB_SUFFIX=x32
-%endif
+       -DMagick++_LIBRARY="$(echo %{_libdir}/libMagick++-*.so)"
 
 %{__make}
 
This page took 0.133224 seconds and 4 git commands to generate.