]> git.pld-linux.org Git - packages/performous.git/blobdiff - performous.spec
Fix sound output when using new ffmpeg
[packages/performous.git] / performous.spec
index 0869806ca4ecd8c4105167239a0fd05a17cc41e2..9bfed67c59694a17a6f457affff82f3c5786f036 100644 (file)
@@ -1,17 +1,25 @@
-Summary:       Performous - a free cross-platform singing game
+#
+# TODO:
+#      - update Polish description, current is outdated (it is not only a
+#      karaoke game any more)
+Summary:       Performous - The All-in-One Music Game
+Summary(pl.UTF-8):     Performous - wiele gier muzycznych w jednej
 Name:          performous
-Version:       0.6.1
-Release:       2
+Version:       0.7.0
+Release:       4
 License:       GPL v2+
 Group:         Applications
-Source0:       http://dl.sourceforge.net/performous/Performous-%{version}-Source.tar.bz2
-# Source0-md5: 451a759de77984b5a699e91107fe52e2
+Source0:       http://downloads.sourceforge.net/performous/performous-%{version}.tar.bz2
+# Source0-md5: 60f3f72b51a630a4aa996484aedb9526
+Patch1:                %{name}-libpng15.patch
+Patch2:                cmake.patch
+Patch3:                %{name}-ffmpeg.patch
 URL:           http://performous.org/
 BuildRequires: ImageMagick-c++-devel
 BuildRequires: SDL-devel
 BuildRequires: alsa-lib-devel
 BuildRequires: boost-devel
-BuildRequires: cmake
+BuildRequires: cmake >= 2.6
 BuildRequires: ffmpeg-devel
 BuildRequires: gettext-devel
 BuildRequires: glew-devel
@@ -22,43 +30,58 @@ BuildRequires:      libpng-devel
 BuildRequires: librsvg-devel
 BuildRequires: libsigc++-devel
 BuildRequires: libxml++-devel
+BuildRequires: opencv-devel
 BuildRequires: pango-devel
 BuildRequires: pkgconfig
-BuildRequires: pulseaudio-devel
-Suggests:      %{name}-tools
+BuildRequires: portaudio-devel
+Suggests:      %{name}-tools = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-While Performous might be classified as a karaoke program, it is
-actually much more than that. Instead of just displaying the lyrics,
-notes are also displayed and the performance is scored based on how
-well you actually hit the notes. Unlike in most other games in this
-genre, you will also see the precise pitch that you are singing, so
-that you can see what you are doing wrong and easily (well, everything
-is relative) correct your pitch.
+An open-source karaoke, band and dancing game where one or more
+players perform a song and the game scores their perform ances.
+Supports songs in UltraStar, Frets on Fire and StepMania formats.
+Microphones and instruments from SingStar, Guit ar Hero and Rock Band
+as well as some dance pads are autodetected.
 
-Most of the songs available also contain the original vocals and
-actual karaoke versions are rare.
+%description -l pl.UTF-8
+O ile Performous można zaklasyfikować jako program do karaoke, to jest
+czymś o wiele więcej. Zamiast tylko wyświetlać tekst, wyświetlane są
+także nuty, a wykonanie jest oceniane w oparciu o to, jak dobrze
+pasuje do nut. W przeciwieństwie do innych gier tego gatunku podawana
+jest także dokładna wysokość śpiewanych tonów, więc można zobaczyć, co
+wykonuje się źle i (względnie) łatwo się poprawić.
 
-For those who sing rather than well, a karaoke mode is provided. In
-this mode only lyrics are displayed and there are no notes or scoring.
+Większość dostępnych piosenek zawiera także oryginalne wokale, zaś
+wersje karaoke są dość rzadkie.
+
+Dla śpiewających niezbyt dobrze dostępny jest tryb karaoke. W tyb
+trybie wyświetlane są tylko słowa i nie ma nut ani oceniania.
 
 %package tools
 Summary:       Performous tools
+Summary(pl.UTF-8):     Narzędzia do programu Performous
 Group:         Applications
 
 %description tools
-Provides several utilities for converting data files for Performous.
+Several utilities for converting data files for Performous.
+
+%description tools -l pl.UTF-8
+Zestaw narzędzi do konwersji danych dla programu Performous.
 
 %prep
-%setup -qn Performous-%{version}-Source
-%{__sed} -i 's:png12:png14:g' cmake/Modules/FindPng.cmake
+%setup -q
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+mkdir build
 
 %build
-mkdir build
 cd build
 %cmake .. \
        -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
+       -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags}" \
+       -DCMAKE_DEBUG_FLAGS_RELEASE="%{debugcflags}" \
        -DCMAKE_INSTALL_PREFIX=%{_prefix} \
 %if "%{_lib}" == "lib64"
        -DLIB_SUFFIX=64
@@ -73,7 +96,9 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man1
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
+install docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
+
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_CN}
 
 %find_lang %{name} --all-name
 
@@ -82,16 +107,17 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc docs/*.txt
+%doc docs/{Authors,TODO,instruments}.txt
 %attr(755,root,root) %{_bindir}/performous
 %{_datadir}/games/%{name}
-%{_mandir}/man6/*
-%{_pixmapsdir}/*
-%{_desktopdir}/*
+%{_mandir}/man6/performous.6*
+%{_desktopdir}/performous.desktop
+%{_pixmapsdir}/performous.xpm
 
 %files tools
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/gh_*
+%attr(755,root,root) %{_bindir}/gh_*_decrypt
 %attr(755,root,root) %{_bindir}/itg_pck
 %attr(755,root,root) %{_bindir}/ss_*
-%{_mandir}/man1/*
+%{_mandir}/man1/gh_*_decrypt.1*
+%{_mandir}/man1/ss_*.1*
This page took 0.100549 seconds and 4 git commands to generate.