]> git.pld-linux.org Git - packages/performous.git/blob - performous.spec
- disable Werror to prevent benign warning breaking build on non x86_64 archs
[packages/performous.git] / performous.spec
1 Summary:        Performous - The All-in-One Music Game
2 Summary(pl.UTF-8):      Performous - wiele gier muzycznych w jednej
3 Name:           performous
4 Version:        1.3.0
5 Release:        1
6 License:        GPL v2+
7 Group:          Applications/Sound
8 #Source0Download: https://github.com/performous/performous/releases
9 Source0:        https://github.com/performous/performous/archive/refs/tags/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  1579905ea88e09611e90b737e9417895
11 Source1:        compact_enc_det.tar.xz
12 # Source1-md5:  c4af58e784fe054b787254acf5c1af12
13 Patch0:         ced-no-forced-cxx11.patch
14 Patch1:         find-ced.patch
15 Patch2:         no-Werror.patch
16 URL:            http://performous.org/
17 BuildRequires:  ImageMagick-c++-devel
18 BuildRequires:  SDL2-devel >= 2
19 BuildRequires:  aubio-devel
20 BuildRequires:  boost-devel >= 1.36
21 BuildRequires:  cmake >= 2.8
22 # avformat avresample swscale
23 BuildRequires:  ffmpeg-devel
24 BuildRequires:  fontconfig-devel
25 BuildRequires:  gettext-tools
26 BuildRequires:  glew-devel
27 BuildRequires:  glibmm-devel
28 BuildRequires:  gmock-devel
29 BuildRequires:  help2man
30 BuildRequires:  libepoxy-devel >= 1.2
31 BuildRequires:  libfmt-devel
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  libpng-devel
34 BuildRequires:  librsvg-devel
35 BuildRequires:  libsigc++-devel
36 BuildRequires:  libstdc++-devel >= 6:4.6
37 BuildRequires:  libxml2-devel >= 2.0
38 BuildRequires:  libxml++2-devel >= 2.6
39 BuildRequires:  nlohmann-json-devel >= 3.10.5
40 BuildRequires:  opencv-devel
41 BuildRequires:  pango-devel >= 1:1.12
42 BuildRequires:  pkgconfig
43 BuildRequires:  portaudio-devel
44 BuildRequires:  portmidi-devel
45 BuildRequires:  rpmbuild(macros) >= 1.605
46 BuildRequires:  zlib-devel
47 Obsoletes:      %{name}-tools < 1.3.0
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 An open-source karaoke, band and dancing game where one or more
52 players perform a song and the game scores their perform ances.
53 Supports songs in UltraStar, Frets on Fire and StepMania formats.
54 Microphones and instruments from SingStar, Guit ar Hero and Rock Band
55 as well as some dance pads are autodetected.
56
57 %description -l pl.UTF-8
58 Karaoke, gitara i taniec w jednej grze. Obsługuje utwory w formatach
59 UltraStar, Frets on Fire i StepManii. Mikrofony i kontrolery z gier
60 SingStar, Guitar Hero i Rock Band oraz maty do tańca są automatycznie
61 wykrywane.
62
63 %prep
64 %setup -q -a1
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68
69 %build
70 cd compact_enc_det
71 install -d build
72 cd build
73 %cmake .. \
74         -DBUILD_SHARED_LIBS=OFF
75 %{__make} ced
76 cp -p lib/libced.a ../compact_enc_det
77 cd ../..
78
79 SRC=$(pwd)
80 install -d build/game
81 cd build
82 %cmake .. \
83         -DCMAKE_INSTALL_MANDIR=%{_mandir}/man6 \
84         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
85         -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags}" \
86         -DCMAKE_DEBUG_FLAGS_RELEASE="%{debugcflags}" \
87         -DMagick_LIBRARY="$(echo %{_libdir}/libMagickCore-*.so)" \
88         -DMagick++_LIBRARY="$(echo %{_libdir}/libMagick++-*.so)" \
89         -DSELF_BUILT_CED=NEVER \
90         -DCed_INCLUDE_DIRS="$SRC/compact_enc_det" \
91         -DCed_LIBRARIES="-L$SRC/compact_enc_det/compact_enc_det $SRC/compact_enc_det/compact_enc_det/libced.a"
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{_mandir}/man1
98
99 %{__make} -C build install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_CN}
103
104 %find_lang %{name} --all-name
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files -f %{name}.lang
110 %defattr(644,root,root,755)
111 %doc README.md docs/{Authors,instruments}.txt
112 %attr(755,root,root) %{_bindir}/performous
113 %{_datadir}/games/%{name}
114 %{_mandir}/man6/performous.6*
115 %{_desktopdir}/performous.desktop
116 %{_pixmapsdir}/performous.svg
This page took 0.069916 seconds and 4 git commands to generate.