]> git.pld-linux.org Git - packages/pdns.git/commitdiff
upstream patch for fixing build with gcc 11
authorJan Palus <atler@pld-linux.org>
Mon, 16 Aug 2021 19:16:38 +0000 (21:16 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 16 Aug 2021 19:16:38 +0000 (21:16 +0200)
gcc11.patch [new file with mode: 0644]
pdns.spec

diff --git a/gcc11.patch b/gcc11.patch
new file mode 100644 (file)
index 0000000..861b74d
--- /dev/null
@@ -0,0 +1,18 @@
+From 2c010a9f0ff0e292d31b949065e1d5c245dc084e Mon Sep 17 00:00:00 2001
+From: Morten Stevens <mstevens@fedoraproject.org>
+Date: Mon, 21 Dec 2020 12:11:01 +0100
+Subject: [PATCH] Fix missing #include for gcc-11
+
+---
+ pdns/lua-record.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pdns/lua-record.cc b/pdns/lua-record.cc
+index 682759432ad..8d51c7937ed 100644
+--- a/pdns/lua-record.cc
++++ b/pdns/lua-record.cc
+@@ -1,3 +1,4 @@
++#include <thread>
+ #include <future>
+ #include <mutex>
+ #include <boost/format.hpp>
index ac775ac4d5f158ae431a85ac3a01d2fd29ee2869..a132811a3874525128872ce631708336176240a1 100644 (file)
--- a/pdns.spec
+++ b/pdns.spec
@@ -19,6 +19,7 @@ Source4:      %{name}.conf
 Source5:       %{name}.sysconfig
 Patch0:                %{name}-boost.patch
 Patch1:                %{name}-openldap-2.3.patch
+Patch2:                gcc11.patch
 URL:           https://www.powerdns.com/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake >= 1:1.11
@@ -140,6 +141,7 @@ LDAP.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 cp -p %{SOURCE1} .
 cp -p %{SOURCE2} .
 cp -p %{SOURCE4} .
This page took 0.193966 seconds and 4 git commands to generate.