]> git.pld-linux.org Git - packages/pdns.git/commitdiff
- added boost patch, release 2 (boost 1.73) auto/th/pdns-4.3.0-2
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 31 Jul 2020 20:49:50 +0000 (22:49 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 31 Jul 2020 20:49:50 +0000 (22:49 +0200)
pdns-boost.patch [new file with mode: 0644]
pdns.spec

diff --git a/pdns-boost.patch b/pdns-boost.patch
new file mode 100644 (file)
index 0000000..e3e7cdc
--- /dev/null
@@ -0,0 +1,42 @@
+--- pdns-4.3.0/pdns/webserver.cc.orig  2020-02-25 07:57:13.000000000 +0100
++++ pdns-4.3.0/pdns/webserver.cc       2020-07-31 22:22:55.140035772 +0200
+@@ -107,7 +107,7 @@
+ void WebServer::registerBareHandler(const string& url, HandlerFunction handler)
+ {
+-  YaHTTP::THandlerFunction f = boost::bind(&bareHandlerWrapper, handler, _1, _2);
++  YaHTTP::THandlerFunction f = boost::bind(&bareHandlerWrapper, handler, boost::placeholders::_1, boost::placeholders::_2);
+   YaHTTP::Router::Any(url, f);
+ }
+@@ -179,7 +179,7 @@
+ }
+ void WebServer::registerApiHandler(const string& url, HandlerFunction handler, bool allowPassword) {
+-  HandlerFunction f = boost::bind(&WebServer::apiWrapper, this, handler, _1, _2, allowPassword);
++  HandlerFunction f = boost::bind(&WebServer::apiWrapper, this, handler, boost::placeholders::_1, boost::placeholders::_2, allowPassword);
+   registerBareHandler(url, f);
+ }
+@@ -196,7 +196,7 @@
+ }
+ void WebServer::registerWebHandler(const string& url, HandlerFunction handler) {
+-  HandlerFunction f = boost::bind(&WebServer::webWrapper, this, handler, _1, _2);
++  HandlerFunction f = boost::bind(&WebServer::webWrapper, this, handler, boost::placeholders::_1, boost::placeholders::_2);
+   registerBareHandler(url, f);
+ }
+--- pdns-4.3.0/pdns/ws-auth.cc.orig    2020-03-21 03:38:01.000000000 +0100
++++ pdns-4.3.0/pdns/ws-auth.cc 2020-07-31 22:32:10.629153686 +0200
+@@ -2328,8 +2328,8 @@
+       d_ws->registerApiHandler("/api", &apiDiscovery);
+     }
+     if (::arg().mustDo("webserver")) {
+-      d_ws->registerWebHandler("/style.css", boost::bind(&AuthWebServer::cssfunction, this, _1, _2));
+-      d_ws->registerWebHandler("/", boost::bind(&AuthWebServer::indexfunction, this, _1, _2));
++      d_ws->registerWebHandler("/style.css", boost::bind(&AuthWebServer::cssfunction, this, boost::placeholders::_1, boost::placeholders::_2));
++      d_ws->registerWebHandler("/", boost::bind(&AuthWebServer::indexfunction, this, boost::placeholders::_1, boost::placeholders::_2));
+     }
+     d_ws->go();
+   }
index b53aa7e11573e5cd7bd79ed04367796f93397d83..6fe2724511951f374c77454f3f990ebad8520441 100644 (file)
--- a/pdns.spec
+++ b/pdns.spec
@@ -6,7 +6,7 @@ Summary:        PowerDNS - a Versatile Database Driven Nameserver
 Summary(pl.UTF-8):     PowerDNS - wielofunkcyjny serwer nazw korzystajÄ…cy z relacyjnych baz danych
 Name:          pdns
 Version:       4.3.0
-Release:       1
+Release:       2
 License:       GPL v2
 Group:         Networking/Daemons
 Source0:       https://downloads.powerdns.com/releases/%{name}-%{version}.tar.bz2
@@ -17,6 +17,7 @@ Source2:      https://downloads.powerdns.com/documentation/%{name}.txt
 Source3:       %{name}.init
 Source4:       %{name}.conf
 Source5:       %{name}.sysconfig
+Patch0:                %{name}-boost.patch
 Patch1:                %{name}-openldap-2.3.patch
 URL:           https://www.powerdns.com/
 BuildRequires: autoconf >= 2.61
@@ -137,6 +138,7 @@ LDAP.
 
 %prep
 %setup -q
+%patch0 -p1
 %patch1 -p1
 cp -p %{SOURCE1} .
 cp -p %{SOURCE2} .
This page took 0.120396 seconds and 4 git commands to generate.