]> git.pld-linux.org Git - packages/pcl.git/commitdiff
- fix return type of non-void functions
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 26 Jan 2017 22:14:58 +0000 (23:14 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 26 Jan 2017 22:14:58 +0000 (23:14 +0100)
fix-return-type.patch [new file with mode: 0644]
pcl.spec

diff --git a/fix-return-type.patch b/fix-return-type.patch
new file mode 100644 (file)
index 0000000..15ebdc3
--- /dev/null
@@ -0,0 +1,22 @@
+--- pcl-pcl-1.7.2/registration/include/pcl/registration/correspondence_estimation_backprojection.h~    2014-09-10 23:22:57.000000000 +0200
++++ pcl-pcl-1.7.2/registration/include/pcl/registration/correspondence_estimation_backprojection.h     2017-01-26 23:11:14.970602304 +0100
+@@ -184,7 +184,7 @@
+           * cloud for computing correspondences. By default we use k = 10 nearest 
+           * neighbors.
+           */
+-        inline void
++        inline unsigned int
+         getKSearch () const { return (k_); }
+         
+         /** \brief Clone and cast to CorrespondenceEstimationBase */
+--- pcl-pcl-1.7.2/registration/include/pcl/registration/correspondence_estimation_normal_shooting.h~   2014-09-10 23:22:57.000000000 +0200
++++ pcl-pcl-1.7.2/registration/include/pcl/registration/correspondence_estimation_normal_shooting.h    2017-01-26 23:12:02.468654319 +0100
+@@ -180,7 +180,7 @@
+           * cloud for computing correspondences. By default we use k = 10 nearest 
+           * neighbors.
+           */
+-        inline void
++        inline unsigned int
+         getKSearch () const { return (k_); }
+         /** \brief Clone and cast to CorrespondenceEstimationBase */
index fcc40bad36382728be9c8a17605668682c4a4ff0..360b190b4d950a9c214c3911120c13ed405482b2 100644 (file)
--- a/pcl.spec
+++ b/pcl.spec
@@ -24,6 +24,7 @@ Patch3:               eigen-dependency.patch
 Patch4:                vtk7.patch
 Patch5:                vtk71.patch
 Patch6:                vtkOpenGL2.patch
+Patch7:                fix-return-type.patch
 URL:           http://pointclouds.org/
 BuildRequires: OpenGL-devel
 BuildRequires: OpenGL-GLU-devel
@@ -118,6 +119,7 @@ Dokumentacja API oraz wprowadzenie do biblioteki PCL.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 %build
 mkdir build
This page took 0.157202 seconds and 4 git commands to generate.