]> git.pld-linux.org Git - packages/pcl.git/commitdiff
- rel 2; fix pc files (openni-dev -> libopenni; openni2-dev -> libopenni2) auto/th/pcl-1.7.2-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 11 Nov 2014 17:17:41 +0000 (18:17 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 11 Nov 2014 17:17:41 +0000 (18:17 +0100)
pcl-openni.patch [new file with mode: 0644]
pcl.spec

diff --git a/pcl-openni.patch b/pcl-openni.patch
new file mode 100644 (file)
index 0000000..924bdbe
--- /dev/null
@@ -0,0 +1,71 @@
+--- pcl-pcl-1.7.2/./PCLConfig.cmake.in~        2014-09-10 23:22:57.000000000 +0200
++++ pcl-pcl-1.7.2/./PCLConfig.cmake.in 2014-11-11 11:37:12.494124290 +0100
+@@ -182,13 +182,13 @@ macro(find_openni)
+   endif(NOT OPENNI_ROOT AND ("@HAVE_OPENNI@" STREQUAL "ON"))
+   if(PKG_CONFIG_FOUND)
+-    pkg_check_modules(PC_OPENNI openni-dev)
++    pkg_check_modules(PC_OPENNI libopenni)
+   endif(PKG_CONFIG_FOUND)
+   find_path(OPENNI_INCLUDE_DIRS XnStatus.h
+     HINTS ${PC_OPENNI_INCLUDEDIR} ${PC_OPENNI_INCLUDE_DIRS} 
+           "${OPENNI_ROOT}" "$ENV{OPENNI_ROOT}"
+     PATHS "$ENV{OPEN_NI_INCLUDE}" "${OPENNI_INCLUDE_DIRS_HINT}"
+-    PATH_SUFFIXES include/openni Include)
++    PATH_SUFFIXES include/openni include/ni Include)
+   #add a hint so that it can find it without the pkg-config
+   set(OPENNI_SUFFIX)
+   if(WIN32 AND CMAKE_SIZEOF_VOID_P EQUAL 8)
+@@ -222,7 +222,7 @@ macro(find_openni2)
+   endif(WIN32 AND CMAKE_SIZEOF_VOID_P EQUAL 8)
+   
+   if(PKG_CONFIG_FOUND)
+-    pkg_check_modules(PC_OPENNI2 openni2-dev)
++    pkg_check_modules(PC_OPENNI2 libopenni2)
+   endif(PKG_CONFIG_FOUND)
+   
+   find_path(OPENNI2_INCLUDE_DIRS OpenNI.h
+--- pcl-pcl-1.7.2/./cmake/Modules/FindOpenNI.cmake~    2014-09-10 23:22:57.000000000 +0200
++++ pcl-pcl-1.7.2/./cmake/Modules/FindOpenNI.cmake     2014-11-11 11:37:58.671931739 +0100
+@@ -35,9 +35,9 @@ if(NOT WIN32)
+ endif(NOT WIN32)
+ if(${CMAKE_VERSION} VERSION_LESS 2.8.2)
+-  pkg_check_modules(PC_OPENNI openni-dev)
++  pkg_check_modules(PC_OPENNI libopenni)
+ else()
+-  pkg_check_modules(PC_OPENNI QUIET openni-dev)
++  pkg_check_modules(PC_OPENNI QUIET libopenni)
+ endif()
+ set(OPENNI_DEFINITIONS ${PC_OPENNI_CFLAGS_OTHER})
+--- pcl-pcl-1.7.2/./io/CMakeLists.txt~ 2014-09-10 23:22:57.000000000 +0200
++++ pcl-pcl-1.7.2/./io/CMakeLists.txt  2014-11-11 11:38:42.636351255 +0100
+@@ -329,10 +329,10 @@ if(build)
+     set(EXT_DEPS eigen3)
+     if(OPENNI_FOUND)
+-      list(APPEND EXT_DEPS openni-dev)
++      list(APPEND EXT_DEPS libopenni)
+     endif(OPENNI_FOUND)
+     if(OPENNI2_FOUND)
+-      list(APPEND EXT_DEPS openni2-dev)
++      list(APPEND EXT_DEPS libopenni2)
+     endif(OPENNI2_FOUND)
+     PCL_MAKE_PKGCONFIG("${LIB_NAME}" "${SUBSYS_NAME}" "${SUBSYS_DESC}"
+--- pcl-pcl-1.7.2/./visualization/CMakeLists.txt~      2014-09-10 23:22:57.000000000 +0200
++++ pcl-pcl-1.7.2/./visualization/CMakeLists.txt       2014-11-11 11:39:19.057251297 +0100
+@@ -154,10 +154,10 @@ if(build)
+     set(EXT_DEPS "")
+     if(OPENNI_FOUND)
+-      list(APPEND EXT_DEPS openni-dev)
++      list(APPEND EXT_DEPS libopenni)
+     endif(OPENNI_FOUND)
+       if(OPENNI2_FOUND)
+-      list(APPEND EXT_DEPS openni2-dev)
++      list(APPEND EXT_DEPS libopenni2)
+     endif(OPENNI2_FOUND)
+     PCL_MAKE_PKGCONFIG("${LIB_NAME}" "${SUBSYS_NAME}" "${SUBSYS_DESC}"
+       "${SUBSYS_DEPS}" "${EXT_DEPS}" "" "" "")
index 44aa784694318ec4254beec9092c9ea57a257eee..759868830ae4b7eb406552eb2eb74f95911b766b 100644 (file)
--- a/pcl.spec
+++ b/pcl.spec
@@ -11,7 +11,7 @@ Summary:      Point Cloud Library - library for point cloud processing
 Summary(pl.UTF-8):     Point Cloud Library - biblioteka do operacji na chmurze punktów
 Name:          pcl
 Version:       1.7.2
-Release:       1
+Release:       2
 License:       BSD
 Group:         Libraries
 #Source0Download: http://pointclouds.org/downloads/
@@ -19,10 +19,11 @@ Source0:    https://github.com/PointCloudLibrary/pcl/archive/%{name}-%{version}.tar
 # Source0-md5: 02c72eb6760fcb1f2e359ad8871b9968
 Patch0:                %{name}-fz_api.patch
 Patch1:                %{name}-tawara.patch
+Patch2:                %{name}-openni.patch
 URL:           http://pointclouds.org/
 BuildRequires: OpenGL-devel
 BuildRequires: OpenGL-GLU-devel
-BuildRequires: OpenNI-devel
+BuildRequires: OpenNI2-devel
 BuildRequires: QtCore-devel >= 4
 BuildRequires: QtOpenGL-devel >= 4
 BuildRequires: boost-devel >= 1.43
@@ -106,6 +107,7 @@ Dokumentacja API oraz wprowadzenie do biblioteki PCL.
 %setup -q -n pcl-pcl-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 mkdir build
This page took 0.185084 seconds and 4 git commands to generate.