]> git.pld-linux.org Git - packages/passenger.git/blob - passenger.spec
b3f208d77ab3ed21c6632835e5a90342e875dd5a
[packages/passenger.git] / passenger.spec
1 # Conditional build:
2 %bcond_with     tests           # build without tests
3
4 Summary:        A module to bridge Ruby on Rails to Apache
5 Name:           passenger
6 Version:        4.0.50
7 Release:        1
8 # Passenger code uses MIT license.
9 # Bundled(Boost) uses Boost Software License
10 # BCrypt and Blowfish files use BSD license.
11 # Documentation is CC-BY-SA
12 # See: https://bugzilla.redhat.com/show_bug.cgi?id=470696#c146
13 License:        Boost and BSD and BSD with advertising and MIT and zlib
14 Group:          Networking/Daemons/HTTP
15 Source0:        https://github.com/phusion/passenger/archive/release-%{version}.tar.gz
16 # Source0-md5:  69c6ade41d870782ae12c3f49d79ce20
17 Source1:        apache-mod_%{name}.conf
18 Patch0:         alias+public.patch
19 Patch1:         dirs.patch
20 URL:            https://www.phusionpassenger.com/
21 BuildRequires:  apache-devel >= 2.0.55-1
22 BuildRequires:  apache-tools
23 BuildRequires:  apr-devel >= 1:1.0.0
24 BuildRequires:  apr-util-devel >= 1:1.0.0
25 #BuildRequires: asciidoc
26 BuildRequires:  curl-devel
27 BuildRequires:  libev-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  openssl-devel
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  rpmbuild(macros) >= 1.559
32 BuildRequires:  ruby-devel
33 BuildRequires:  ruby-rake >= 0.8.0
34 BuildRequires:  ruby-rdoc
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  zlib-devel
37 %if %(locale -a | grep -q '^en_US$'; echo $?)
38 BuildRequires:  glibc-localedb-all
39 %endif
40 Obsoletes:      apache-mod_rails-rdoc
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         apxs            /usr/sbin/apxs
44 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
45 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
46
47 %description
48 Phusion Passenger - a.k.a. mod_passenger - makes deployment of
49 applications built on the revolutionary Ruby on Rails web framework a
50 breeze. It follows the usual Ruby on Rails conventions, such as
51 "Don't-Repeat-Yourself".
52
53 %package -n apache-mod_passenger
54 Summary:        Apache Module for Phusion Passenger
55 License:        Boost and BSD and BSD with advertising and MIT and zlib
56 Group:          Daemons
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       apache(modules-api) = %apache_modules_api
59 Provides:       apache(mod_passenger)
60 Provides:       apache(mod_rails)
61 Obsoletes:      apache-mod_rails < 4.0
62
63 %description -n apache-mod_passenger
64 This package contains the pluggable Apache server module for Phusion
65 Passenger(tm).
66
67 %package -n ruby-passenger-ri
68 Summary:        ri documentation for Phusion Passenger
69 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla Phusion Passenger
70 Group:          Documentation
71 Requires:       ruby
72 Obsoletes:      apache-mod_rails-ri < 4.0
73
74 %description -n ruby-passenger-ri
75 ri documentation for Phusion Passenger
76
77 %description -n ruby-passenger-ri -l pl.UTF-8
78 Dokumentacji w formacie ri dla Phusion Passenger
79
80 %prep
81 %setup -q -n %{name}-release-%{version}
82 #%patch0 -p1
83 %patch1 -p1
84
85 __rubydir=$(echo %{ruby_vendorlibdir} | %{__sed} -e 's|/usr||')
86
87 %{__sed} -i -e "s|@@LIB@@|%{_lib}|g" \
88         -e "s|@@RUBYLIBDIR@@|$__rubydir|g" ext/common/ResourceLocator.h
89
90 %{__sed} -i -e 's|#!/usr/bin/env python|#!%{_bindir}/python|' helper-scripts/*.py
91 %{__sed} -i -e 's|#!/usr/bin/env ruby|#!%{_bindir}/ruby|' helper-scripts/{prespawn,download_binaries/extconf.rb,*.rb} bin/*
92
93 # Don't use bundled libev
94 rm -r ext/libev
95
96 %build
97 export USE_VENDORED_LIBEV=false
98 export CC="%{__cc}"
99 export CXX="%{__cxx}"
100 export CFLAGS="%{rpmcflags} -fno-strict-aliasing"
101 export CXXFLAGS="%{rpmcxxflags} -fno-strict-aliasing"
102 export EXTRA_CFLAGS="%{rpmcflags} -fno-strict-aliasing"
103 export EXTRA_CXXFLAGS="%{rpmcxxflags} -fno-strict-aliasing"
104
105 export APACHECTL=%{_sbindir}/apachectl
106 export HTTPD_VERSION=$(rpm -q apache-devel --qf '%{V}')
107 export HTTPD=%{_sbindir}/httpd
108 export APXS2=%{apxs}
109
110 rake apache2 V=1 \
111         RELEASE=yes \
112         OPTIMIZE=yes
113
114 %if %{with tests}
115 # Run the tests, capture the output, but don't fail the build if the tests fail
116 #
117 # This will make the test failure non-critical, but it should be examined
118 # anyway.
119 sed -i 's|sh "cd test && \./cxx/CxxTestMain"|& rescue true|' build/cxx_tests.rb
120
121 # adjust for rspec 2 while the test suite seems to require RSpec 1.
122 sed -i \
123         "s|return locate_ruby_tool('spec')|return locate_ruby_tool('rspec')|" \
124         lib/phusion_passenger/platform_info/ruby.rb
125
126 rake test --trace
127 %endif
128
129 # UTF8 locale needed for doc generation
130 LC_ALL=en_US.UTF-8 \
131 rdoc --ri --op ri lib ext/ruby
132 %{__rm} -r ri/{GC,IO,Object,Signal,CommonLibraryBuilder,Exception,DaemonController}
133 %{__rm} ri/{cache.ri,created.rid}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},%{_mandir}/man{1,8}} \
138         $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_vendorarchdir},%{ruby_ridir}} \
139         $RPM_BUILD_ROOT%{_bindir} \
140         $RPM_BUILD_ROOT%{_libdir}/phusion-passenger/agents/apache2 \
141         $RPM_BUILD_ROOT%{_datadir}/phusion-passenger/helper-scripts
142
143 install -p buildout/apache2/mod_passenger.so $RPM_BUILD_ROOT%{_pkglibdir}
144 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/75_mod_passenger.conf
145
146 install -p buildout/ruby/ruby-*/passenger_native_support.so $RPM_BUILD_ROOT%{ruby_vendorarchdir}
147 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
148
149 install -p bin/passenger-{config,memory-stats,status} bin/passenger $RPM_BUILD_ROOT%{_bindir}
150 install -p buildout/agents/{PassengerLoggingAgent,PassengerWatchdog,PassengerHelperAgent,SpawnPreparer,TempDirToucher} $RPM_BUILD_ROOT%{_libdir}/phusion-passenger/agents
151 cp -a helper-scripts/* $RPM_BUILD_ROOT%{_datadir}/phusion-passenger/helper-scripts
152 cp -a resources node_lib $RPM_BUILD_ROOT%{_datadir}/phusion-passenger/
153
154 cp -p man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
155 cp -p man/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
156 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post -n apache-mod_passenger
162 %service -q httpd restart
163
164 %postun -n apache-mod_passenger
165 if [ "$1" = "0" ]; then
166         %service -q httpd restart
167 fi
168
169 %files
170 %defattr(644,root,root,755)
171 %doc README.md INSTALL.md
172 %attr(755,root,root) %{_bindir}/passenger
173 %attr(755,root,root) %{_bindir}/passenger-config
174 %attr(755,root,root) %{_bindir}/passenger-memory-stats
175 %attr(755,root,root) %{_bindir}/passenger-status
176 %{_mandir}/man1/passenger-config.1*
177 %{_mandir}/man8/passenger-memory-stats.8*
178 %{_mandir}/man8/passenger-status.8*
179
180 %attr(755,root,root) %{ruby_vendorarchdir}/passenger_native_support.so
181 %{ruby_vendorlibdir}/phusion_passenger.rb
182 %{ruby_vendorlibdir}/phusion_passenger
183
184 %dir %{_libdir}/phusion-passenger
185 %dir %{_libdir}/phusion-passenger/agents
186 %attr(755,root,root) %{_libdir}/phusion-passenger/agents/PassengerHelperAgent
187 %attr(755,root,root) %{_libdir}/phusion-passenger/agents/PassengerLoggingAgent
188 %attr(755,root,root) %{_libdir}/phusion-passenger/agents/PassengerWatchdog
189 %attr(755,root,root) %{_libdir}/phusion-passenger/agents/SpawnPreparer
190 %attr(755,root,root) %{_libdir}/phusion-passenger/agents/TempDirToucher
191 %dir %{_datadir}/phusion-passenger
192 %dir %{_datadir}/phusion-passenger/helper-scripts
193 %attr(755,root,root) %{_datadir}/phusion-passenger/helper-scripts/*
194 %{_datadir}/phusion-passenger/resources
195 %{_datadir}/phusion-passenger/node_lib
196
197 %files -n apache-mod_passenger
198 %defattr(644,root,root,755)
199 %doc doc/Users?guide?Apache.txt
200 %defattr(644,root,root,755)
201 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_passenger.conf
202 %attr(755,root,root) %{_pkglibdir}/mod_passenger.so
203
204 %files -n ruby-passenger-ri
205 %defattr(644,root,root,755)
206 %{ruby_ridir}/PhusionPassenger
This page took 0.047081 seconds and 2 git commands to generate.