]> git.pld-linux.org Git - packages/passenger.git/blob - passenger.spec
156c0fafddd4100b21a20d3fc5678031d38d2559
[packages/passenger.git] / passenger.spec
1 # Conditional build:
2 %bcond_with     tests           # build without tests
3
4 Summary:        A module to bridge Ruby on Rails to Apache
5 Name:           passenger
6 Version:        4.0.48
7 Release:        0.1
8 # Passenger code uses MIT license.
9 # Bundled(Boost) uses Boost Software License
10 # BCrypt and Blowfish files use BSD license.
11 # Documentation is CC-BY-SA
12 # See: https://bugzilla.redhat.com/show_bug.cgi?id=470696#c146
13 License:        Boost and BSD and BSD with advertising and MIT and zlib
14 Group:          Networking/Daemons/HTTP
15 Source0:        https://github.com/phusion/passenger/archive/release-%{version}.tar.gz
16 # Source0-md5:  e77d1940f9bc86314d84634236339d1b
17 Source1:        apache-mod_%{name}.conf
18 Patch0:         nogems.patch
19 Patch1:         alias+public.patch
20 Patch2:         %{name}_apache_fix_autofoo.patch
21 Patch3:         progs.patch
22 URL:            https://www.phusionpassenger.com/
23 BuildRequires:  apache-devel >= 2.0.55-1
24 BuildRequires:  apache-tools
25 BuildRequires:  apr-devel >= 1:1.0.0
26 BuildRequires:  apr-util-devel >= 1:1.0.0
27 #BuildRequires: asciidoc
28 BuildRequires:  curl-devel
29 BuildRequires:  libev-devel
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  openssl-devel
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.559
34 BuildRequires:  ruby-devel
35 BuildRequires:  ruby-rake >= 0.8.0
36 BuildRequires:  ruby-rdoc
37 BuildRequires:  sed >= 4.0
38 BuildRequires:  zlib-devel
39 %if %(locale -a | grep -q '^en_US$'; echo $?)
40 BuildRequires:  glibc-localedb-all
41 %endif
42 Obsoletes:      apache-mod_rails-rdoc
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         apxs            /usr/sbin/apxs
46 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
47 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
48
49 %description
50 Phusion Passenger - a.k.a. mod_passenger - makes deployment of
51 applications built on the revolutionary Ruby on Rails web framework a
52 breeze. It follows the usual Ruby on Rails conventions, such as
53 "Don't-Repeat-Yourself".
54
55 %package -n apache-mod_passenger
56 Summary:        Apache Module for Phusion Passenger
57 License:        Boost and BSD and BSD with advertising and MIT and zlib
58 Group:          Daemons
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       apache(modules-api) = %apache_modules_api
61 Provides:       apache(mod_passenger)
62 Obsoletes:      apache-mod_rails < 4.0
63
64 %description -n apache-mod_passenger
65 This package contains the pluggable Apache server module for Phusion
66 Passenger(tm).
67
68 %package -n ruby-passenger-ri
69 Summary:        ri documentation for Phusion Passenger
70 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla Phusion Passenger
71 Group:          Documentation
72 Requires:       ruby
73 Obsoletes:      apache-mod_rails-ri < 4.0
74
75 %description -n ruby-passenger-ri
76 ri documentation for Phusion Passenger
77
78 %description -n ruby-passenger-ri -l pl.UTF-8
79 Dokumentacji w formacie ri dla Phusion Passenger
80
81 %prep
82 %setup -q -n %{name}-release-%{version}
83 #%patch0 -p1
84 #%patch1 -p0
85 #%patch2 -p0
86 #%patch3 -p1
87
88 %{__sed} -i -e 's|#!/usr/bin/env python|#!%{_bindir}/python|' helper-scripts/*.py
89 %{__sed} -i -e 's|#!/usr/bin/env ruby|#!%{_bindir}/ruby|' helper-scripts/{prespawn,download_binaries/extconf.rb,*.rb} bin/*
90
91 # Don't use bundled libev
92 rm -r ext/libev
93
94 %build
95 export USE_VENDORED_LIBEV=false
96 export CC="%{__cc}"
97 export CXX="%{__cxx}"
98 export CFLAGS="%{rpmcflags} -fno-strict-aliasing"
99 export CXXFLAGS="%{rpmcxxflags} -fno-strict-aliasing"
100 export EXTRA_CFLAGS="%{rpmcflags} -fno-strict-aliasing"
101 export EXTRA_CXXFLAGS="%{rpmcxxflags} -fno-strict-aliasing"
102
103 export APACHECTL=%{_sbindir}/apachectl
104 export HTTPD_VERSION=$(rpm -q apache-devel --qf '%{V}')
105 export HTTPD=%{_sbindir}/httpd
106 export APXS2=%{apxs}
107
108 rake apache2 V=1 \
109         RELEASE=yes \
110         OPTIMIZE=yes
111
112 %if %{with tests}
113 # Run the tests, capture the output, but don't fail the build if the tests fail
114 #
115 # This will make the test failure non-critical, but it should be examined
116 # anyway.
117 sed -i 's|sh "cd test && \./cxx/CxxTestMain"|& rescue true|' build/cxx_tests.rb
118
119 # adjust for rspec 2 while the test suite seems to require RSpec 1.
120 sed -i \
121         "s|return locate_ruby_tool('spec')|return locate_ruby_tool('rspec')|" \
122         lib/phusion_passenger/platform_info/ruby.rb
123
124 rake test --trace
125 %endif
126
127 # UTF8 locale needed for doc generation
128 LC_ALL=en_US.UTF-8 \
129 rdoc --ri --op ri lib ext/ruby
130 %{__rm} -r ri/{GC,IO,Object,Signal,CommonLibraryBuilder,Exception,DaemonController}
131 %{__rm} ri/{cache.ri,created.rid}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},%{_mandir}/man{1,8}} \
136         $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_vendorarchdir},%{ruby_ridir}} \
137         $RPM_BUILD_ROOT%{_bindir} \
138         $RPM_BUILD_ROOT%{_libdir}/phusion-passenger/agents/apache2 \
139         $RPM_BUILD_ROOT%{_datadir}/phusion-passenger/helper-scripts
140
141 install -p buildout/apache2/mod_passenger.so $RPM_BUILD_ROOT%{_pkglibdir}
142 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/75_mod_passenger.conf
143
144 install -p buildout/ruby/ruby-*/passenger_native_support.so $RPM_BUILD_ROOT%{ruby_vendorarchdir}
145 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
146
147 install -p bin/passenger-{config,memory-stats,status} bin/passenger $RPM_BUILD_ROOT%{_bindir}
148 install -p buildout/agents/{PassengerLoggingAgent,PassengerWatchdog,PassengerHelperAgent} $RPM_BUILD_ROOT%{_libdir}/phusion-passenger/agents
149 cp -a helper-scripts/* $RPM_BUILD_ROOT%{_datadir}/phusion-passenger/helper-scripts
150
151 cp -p man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
152 cp -p man/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
153 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post -n apache-mod_passenger
159 %service -q httpd restart
160
161 %postun -n apache-mod_passenger
162 if [ "$1" = "0" ]; then
163         %service -q httpd restart
164 fi
165
166 %files
167 %defattr(644,root,root,755)
168 %doc README.md INSTALL.md
169 %attr(755,root,root) %{_bindir}/passenger
170 %attr(755,root,root) %{_bindir}/passenger-config
171 %attr(755,root,root) %{_bindir}/passenger-memory-stats
172 %attr(755,root,root) %{_bindir}/passenger-status
173 %{_mandir}/man1/passenger-config.1*
174 %{_mandir}/man8/passenger-memory-stats.8*
175 %{_mandir}/man8/passenger-status.8*
176
177 %attr(755,root,root) %{ruby_vendorarchdir}/passenger_native_support.so
178 %{ruby_vendorlibdir}/phusion_passenger.rb
179 %{ruby_vendorlibdir}/phusion_passenger
180
181 %dir %{_libdir}/phusion-passenger
182 %dir %{_libdir}/phusion-passenger/agents
183 %attr(755,root,root) %{_libdir}/phusion-passenger/agents/PassengerHelperAgent
184 %attr(755,root,root) %{_libdir}/phusion-passenger/agents/PassengerLoggingAgent
185 %attr(755,root,root) %{_libdir}/phusion-passenger/agents/PassengerWatchdog
186 %dir %{_datadir}/phusion-passenger
187 %dir %{_datadir}/phusion-passenger/helper-scripts
188 %attr(755,root,root) %{_datadir}/phusion-passenger/helper-scripts/*
189
190 %files -n apache-mod_passenger
191 %defattr(644,root,root,755)
192 %doc doc/Users?guide?Apache.txt
193 %defattr(644,root,root,755)
194 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_passenger.conf
195 %attr(755,root,root) %{_pkglibdir}/mod_passenger.so
196
197 %files -n ruby-passenger-ri
198 %defattr(644,root,root,755)
199 %{ruby_ridir}/PhusionPassenger
This page took 0.081937 seconds and 2 git commands to generate.