]> git.pld-linux.org Git - packages/parallel-netcdf.git/blob - parallel-netcdf.spec
49cb60b006cb74d1c12e34aa842af82aecb19eb0
[packages/parallel-netcdf.git] / parallel-netcdf.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        Parallel netCDF (PnetCDF) library
7 Summary(pl.UTF-8):      Biblioteka zrównoleglona netCDF (PnetCDF)
8 Name:           parallel-netcdf
9 Version:        1.9.0
10 Release:        2
11 License:        BSD-like
12 Group:          Libraries
13 #Source0Download: http://cucis.ece.northwestern.edu/projects/PnetCDF/download.html
14 Source0:        http://cucis.ece.northwestern.edu/projects/PnetCDF/Release/%{name}-%{version}.tar.gz
15 # Source0-md5:  f8d5627cb297263c1459d67254dc5fab
16 Patch0:         %{name}-sh.patch
17 URL:            https://trac.mcs.anl.gov/projects/parallel-netcdf
18 BuildRequires:  autoconf >= 2.69
19 BuildRequires:  automake >= 1:1.13
20 BuildRequires:  gcc-fortran
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:2.4.2
23 # mpicc and co.
24 BuildRequires:  mpich-devel
25 BuildRequires:  m4
26 %if %{with apidocs}
27 BuildRequires:  doxygen
28 BuildRequires:  ghostscript
29 BuildRequires:  texlive-latex
30 %endif
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Parallel netCDF (PnetCDF) is a library providing high-performance
35 parallel I/O while still maintaining file-format compatibility with
36 Unidata's NetCDF, specifically the classic CDF 1, 2, and 5 formats.
37 Although NetCDF supports parallel I/O starting from version 4, it is
38 built on top of HDF5 and thus its parallel feature requires files in
39 HDF5 format. PnetCDF is currently the only option for parallel I/O on
40 files in classic formats.
41
42 %description -l pl.UTF-8
43 Parallel netCDF (PnetCDF) to biblioteka zapewniająca bardzo wydajne,
44 równoległe operacje we/wy, zachowując zgodność z formatem plików
45 Unidata NetCDF, w szczególności klasycznych formatach CDF 1, 2, 5.
46 Mimo że NetCDF obsługuje równoległe operacje we/wy począwszy od wersji
47 4, ale w oparciu o HDF5, więc opcja zrównoleglenia wymaga plików w
48 formacie HDF5. PnetCDF to obecnie jedyna możliwość zrównoleglenia
49 we/wy dla plików w klasycznych formatach.
50
51 %package devel
52 Summary:        Header files for PnetCDF library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki PnetCDF
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       mpich-devel
57
58 %description devel
59 Header files for PnetCDF library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki PnetCDF.
63
64 %package static
65 Summary:        Static PnetCDF library
66 Summary(pl.UTF-8):      Statyczna biblioteka PnetCDF
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static PnetCDF library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka PnetCDF.
75
76 %package apidocs
77 Summary:        API documentation for PnetCDF library
78 Summary(pl.UTF-8):      Dokumentacja API biblioteki PnetCDF
79 Group:          Documentation
80 %if "%{_rpmversion}" >= "5"
81 BuildArch:      noarch
82 %endif
83
84 %description apidocs
85 API documentation for PnetCDF library.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API biblioteki PnetCDF.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93
94 %build
95 %{__libtoolize}
96 %{__aclocal} -I m4
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         %{?with_apidocs:--enable-doxygen} \
102         --disable-silent-rules \
103         --enable-shared \
104         %{!?with_static_libs:--disable-static}
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 # .la kept because of MPI dependencies
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS COPYRIGHT CREDITS README RELEASE_NOTES doc/README.{LINUX,consistency,large_files}
124 %attr(755,root,root) %{_bindir}/ncmpidiff
125 %attr(755,root,root) %{_bindir}/ncmpidump
126 %attr(755,root,root) %{_bindir}/ncmpigen
127 %attr(755,root,root) %{_bindir}/ncoffsets
128 %attr(755,root,root) %{_bindir}/ncvalidator
129 %attr(755,root,root) %{_bindir}/pnetcdf_version
130 %attr(755,root,root) %{_libdir}/libpnetcdf.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libpnetcdf.so.1
132 %{_mandir}/man1/ncmpidiff.1*
133 %{_mandir}/man1/ncmpidump.1*
134 %{_mandir}/man1/ncmpigen.1*
135 %{_mandir}/man1/ncoffsets.1*
136 %{_mandir}/man1/ncvalidator.1*
137 %{_mandir}/man1/pnetcdf_version.1*
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/pnetcdf-config
142 %attr(755,root,root) %{_libdir}/libpnetcdf.so
143 %{_libdir}/libpnetcdf.la
144 %{_includedir}/pnetcdf.h
145 %{_includedir}/pnetcdf
146 %{_includedir}/pnetcdf.inc
147 %{_includedir}/pnetcdf.mod
148 %{_pkgconfigdir}/pnetcdf.pc
149 %{_mandir}/man3/pnetcdf.3*
150 %{_mandir}/man3/pnetcdf_f77.3*
151 %{_mandir}/man3/pnetcdf_f90.3*
152
153 %if %{with static_libs}
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libpnetcdf.a
157 %endif
158
159 %if %{with apidocs}
160 %files apidocs
161 %defattr(644,root,root,755)
162 %doc doc/pnetcdf-api/pnetcdf-api.pdf
163 %endif
This page took 0.047097 seconds and 2 git commands to generate.