]> git.pld-linux.org Git - packages/parallel-netcdf.git/blame - parallel-netcdf.spec
- updated to 1.12.0
[packages/parallel-netcdf.git] / parallel-netcdf.spec
CommitLineData
9efb83bf
JB
1#
2# Conditional build:
3%bcond_without apidocs # API documentation
4%bcond_without static_libs # static library
5#
6Summary: Parallel netCDF (PnetCDF) library
7Summary(pl.UTF-8): Biblioteka zrównoleglona netCDF (PnetCDF)
8Name: parallel-netcdf
371cf8f1 9Version: 1.12.0
8a3b62ac 10Release: 1
9efb83bf
JB
11License: BSD-like
12Group: Libraries
13#Source0Download: http://cucis.ece.northwestern.edu/projects/PnetCDF/download.html
8a3b62ac 14Source0: http://cucis.ece.northwestern.edu/projects/PnetCDF/Release/pnetcdf-%{version}.tar.gz
371cf8f1 15# Source0-md5: 67ba3266da3c6050ba3dc042d67551d7
9efb83bf
JB
16Patch0: %{name}-sh.patch
17URL: https://trac.mcs.anl.gov/projects/parallel-netcdf
18BuildRequires: autoconf >= 2.69
19BuildRequires: automake >= 1:1.13
20BuildRequires: gcc-fortran
21BuildRequires: libstdc++-devel
22BuildRequires: libtool >= 2:2.4.2
23# mpicc and co.
24BuildRequires: mpich-devel
25BuildRequires: m4
26%if %{with apidocs}
27BuildRequires: doxygen
28BuildRequires: ghostscript
29BuildRequires: texlive-latex
30%endif
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Parallel netCDF (PnetCDF) is a library providing high-performance
35parallel I/O while still maintaining file-format compatibility with
36Unidata's NetCDF, specifically the classic CDF 1, 2, and 5 formats.
37Although NetCDF supports parallel I/O starting from version 4, it is
38built on top of HDF5 and thus its parallel feature requires files in
39HDF5 format. PnetCDF is currently the only option for parallel I/O on
40files in classic formats.
41
42%description -l pl.UTF-8
43Parallel netCDF (PnetCDF) to biblioteka zapewniająca bardzo wydajne,
44równoległe operacje we/wy, zachowując zgodność z formatem plików
45Unidata NetCDF, w szczególności klasycznych formatach CDF 1, 2, 5.
46Mimo że NetCDF obsługuje równoległe operacje we/wy począwszy od wersji
474, ale w oparciu o HDF5, więc opcja zrównoleglenia wymaga plików w
48formacie HDF5. PnetCDF to obecnie jedyna możliwość zrównoleglenia
49we/wy dla plików w klasycznych formatach.
50
51%package devel
52Summary: Header files for PnetCDF library
53Summary(pl.UTF-8): Pliki nagłówkowe biblioteki PnetCDF
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56Requires: mpich-devel
57
58%description devel
59Header files for PnetCDF library.
60
61%description devel -l pl.UTF-8
62Pliki nagłówkowe biblioteki PnetCDF.
63
64%package static
65Summary: Static PnetCDF library
66Summary(pl.UTF-8): Statyczna biblioteka PnetCDF
67Group: Development/Libraries
68Requires: %{name}-devel = %{version}-%{release}
69
70%description static
71Static PnetCDF library.
72
73%description static -l pl.UTF-8
74Statyczna biblioteka PnetCDF.
75
76%package apidocs
77Summary: API documentation for PnetCDF library
78Summary(pl.UTF-8): Dokumentacja API biblioteki PnetCDF
79Group: Documentation
80%if "%{_rpmversion}" >= "5"
81BuildArch: noarch
82%endif
83
84%description apidocs
85API documentation for PnetCDF library.
86
87%description apidocs -l pl.UTF-8
88Dokumentacja API biblioteki PnetCDF.
89
90%prep
8a3b62ac 91%setup -q -n pnetcdf-%{version}
9efb83bf
JB
92%patch0 -p1
93
94%build
95%{__libtoolize}
96%{__aclocal} -I m4
97%{__autoconf}
98%{__autoheader}
99%{__automake}
100%configure \
101 %{?with_apidocs:--enable-doxygen} \
102 --disable-silent-rules \
103 --enable-shared \
104 %{!?with_static_libs:--disable-static}
105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110%{__make} install \
111 DESTDIR=$RPM_BUILD_ROOT
112
113# .la kept because of MPI dependencies
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post -p /sbin/ldconfig
119%postun -p /sbin/ldconfig
120
121%files
122%defattr(644,root,root,755)
123%doc AUTHORS COPYRIGHT CREDITS README RELEASE_NOTES doc/README.{LINUX,consistency,large_files}
371cf8f1 124%attr(755,root,root) %{_bindir}/cdfdiff
9efb83bf
JB
125%attr(755,root,root) %{_bindir}/ncmpidiff
126%attr(755,root,root) %{_bindir}/ncmpidump
127%attr(755,root,root) %{_bindir}/ncmpigen
128%attr(755,root,root) %{_bindir}/ncoffsets
129%attr(755,root,root) %{_bindir}/ncvalidator
130%attr(755,root,root) %{_bindir}/pnetcdf_version
131%attr(755,root,root) %{_libdir}/libpnetcdf.so.*.*.*
371cf8f1
JB
132%attr(755,root,root) %ghost %{_libdir}/libpnetcdf.so.4
133%{_mandir}/man1/cdfdiff.1*
9efb83bf
JB
134%{_mandir}/man1/ncmpidiff.1*
135%{_mandir}/man1/ncmpidump.1*
136%{_mandir}/man1/ncmpigen.1*
137%{_mandir}/man1/ncoffsets.1*
138%{_mandir}/man1/ncvalidator.1*
139%{_mandir}/man1/pnetcdf_version.1*
140
141%files devel
142%defattr(644,root,root,755)
143%attr(755,root,root) %{_bindir}/pnetcdf-config
144%attr(755,root,root) %{_libdir}/libpnetcdf.so
145%{_libdir}/libpnetcdf.la
146%{_includedir}/pnetcdf.h
147%{_includedir}/pnetcdf
148%{_includedir}/pnetcdf.inc
149%{_includedir}/pnetcdf.mod
150%{_pkgconfigdir}/pnetcdf.pc
151%{_mandir}/man3/pnetcdf.3*
152%{_mandir}/man3/pnetcdf_f77.3*
153%{_mandir}/man3/pnetcdf_f90.3*
154
155%if %{with static_libs}
156%files static
157%defattr(644,root,root,755)
158%{_libdir}/libpnetcdf.a
159%endif
160
161%if %{with apidocs}
162%files apidocs
163%defattr(644,root,root,755)
164%doc doc/pnetcdf-api/pnetcdf-api.pdf
165%endif
This page took 0.385818 seconds and 4 git commands to generate.