]> git.pld-linux.org Git - packages/pacemaker.git/commitdiff
- updated to 1.1.14 (note: new libpe_status,libpengine sonames) auto/th/pacemaker-1.1.14-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 10 Apr 2016 05:46:45 +0000 (07:46 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 10 Apr 2016 05:46:45 +0000 (07:46 +0200)
- updated manpage_xslt,libs patches

pacemaker-libs.patch
pacemaker-manpage_xslt.patch
pacemaker.spec

index 5075d5724305f08cc70f95ed1f71bb37e402a159..737f997a7a59c8c3403c474c4054b8e83591a7f7 100644 (file)
@@ -1,6 +1,6 @@
---- pacemaker-Pacemaker-1.1.11/configure.ac.orig       2014-02-14 19:38:11.914625405 +0100
-+++ pacemaker-Pacemaker-1.1.11/configure.ac    2014-02-14 19:43:35.904611808 +0100
-@@ -614,17 +614,21 @@
+--- pacemaker-Pacemaker-1.1.14/configure.ac.orig       2016-04-09 21:49:56.760659968 +0200
++++ pacemaker-Pacemaker-1.1.14/configure.ac    2016-04-09 22:00:07.427301010 +0200
+@@ -619,17 +619,21 @@
  dnl ===============================================
  dnl Libraries
  dnl ===============================================
@@ -29,7 +29,7 @@
  
  AC_CHECK_HEADERS(uuid/uuid.h)
  
-@@ -772,8 +776,10 @@
+@@ -777,8 +781,10 @@
  else
     XML2HEAD="`$XML2CONFIG --cflags`"
     AC_MSG_RESULT($XML2HEAD)
@@ -42,7 +42,7 @@
  fi
  
  CPPFLAGS="$CPPFLAGS $XML2HEAD"
-@@ -838,7 +844,8 @@
+@@ -846,7 +852,8 @@
  dnl   bzip2
  dnl ========================================================================
  AC_CHECK_HEADERS(bzlib.h)
  
  if test x$ac_cv_lib_bz2_BZ2_bzBuffToBuffCompress != xyes ; then
     AC_MSG_ERROR(BZ2 libraries not found)
-@@ -1000,7 +1007,8 @@
- PKG_CHECK_MODULES(libqb, libqb, HAVE_libqb=1, HAVE_libqb=0)
- AC_CHECK_HEADERS(qb/qbipc_common.h)
--AC_CHECK_LIB(qb, qb_ipcs_connection_auth_set)
-+AC_CHECK_LIB(qb, qb_ipcs_connection_auth_set, [LIBQB=-lqb])
-+AC_SUBST([LIBQB])
- LIBQB_LOG=1
- PCMK_FEATURES="$PCMK_FEATURES libqb-logging libqb-ipc"
-@@ -1013,7 +1021,6 @@
-    AC_MSG_FAILURE(Version of libqb is too old: v0.13 or greater requried)
- fi
+@@ -1023,7 +1030,6 @@
+ AC_CHECK_FUNCS(qb_ipcs_connection_get_buffer_size, AC_DEFINE(HAVE_IPCS_GET_BUFFER_SIZE,  1, [Have qb_ipcc_get_buffer_size function]))
  
 -LIBS="$LIBS $libqb_LIBS"
  
  AC_CHECK_HEADERS(heartbeat/hb_config.h)
  AC_CHECK_HEADERS(heartbeat/glue_config.h)
-@@ -1040,8 +1047,10 @@
+@@ -1050,8 +1056,10 @@
  if test $HAVE_GLUE = 1; then
     dnl On Debian, AC_CHECK_LIBS fail if a library has any unresolved symbols
     dnl So check for all the depenancies (so they're added to LIBS) before checking for -lplumb
@@ -83,7 +73,7 @@
  fi
  
  dnl ===============================================
-@@ -1545,7 +1554,7 @@
+@@ -1563,7 +1571,7 @@
      AC_MSG_RESULT($SUPPORT_ACL)
  
      SUPPORT_ACL=1
@@ -92,7 +82,7 @@
      if test $ac_cv_lib_qb_qb_ipcs_connection_auth_set != yes; then
          SUPPORT_ACL=0
      fi
-@@ -1611,8 +1620,11 @@
+@@ -1629,8 +1637,11 @@
        GNUTLSLIBS="`$LIBGNUTLS_CONFIG --libs`";
        AC_MSG_RESULT($GNUTLSLIBS)
  fi
  
  pengine_SOURCES       = main.c
 -pengine_LDADD = $(top_builddir)/lib/cib/libcib.la $(COMMONLIBS)
-+pengine_LDADD = $(top_builddir)/lib/cib/libcib.la $(COMMONLIBS) $(LIBQB)
++pengine_LDADD = $(top_builddir)/lib/cib/libcib.la $(COMMONLIBS) $(libqb_LIBS)
  # libcib for get_object_root()
  #             $(top_builddir)/lib/hbclient/libhbclient.la
  
---- pacemaker-Pacemaker-1.1.13/lib/common/Makefile.am.orig     2014-02-14 19:44:12.731276928 +0100
-+++ pacemaker-Pacemaker-1.1.13/lib/common/Makefile.am  2014-02-14 19:53:20.877920591 +0100
-@@ -38,7 +38,7 @@
+--- pacemaker-Pacemaker-1.1.14/lib/common/Makefile.am.orig     2016-04-09 22:00:51.310632499 +0200
++++ pacemaker-Pacemaker-1.1.14/lib/common/Makefile.am  2016-04-09 22:03:00.857293731 +0200
+@@ -41,7 +41,7 @@
  endif
  
- libcrmcommon_la_LDFLAGS       = -version-info 7:0:4
--libcrmcommon_la_LIBADD  = @LIBADD_DL@ $(GNUTLSLIBS)
-+libcrmcommon_la_LIBADD  = @LIBADD_DL@ $(LIBPLUMB) $(GNUTLSLIBS) $(LIBXML2) $(LIBXSLT) $(LIBQB) $(LIBBZ2) $(LIBUUID)
+ libcrmcommon_la_LDFLAGS       = -version-info 8:0:5
+-libcrmcommon_la_LIBADD  = @LIBADD_DL@ $(GNUTLSLIBS) -lm
++libcrmcommon_la_LIBADD  = @LIBADD_DL@ $(LIBPLUMB) $(GNUTLSLIBS) $(LIBXML2) $(LIBXSLT) $(libqb_LIBS) $(LIBBZ2) $(LIBUUID) -lm
  libcrmcommon_la_SOURCES += $(top_builddir)/lib/gnu/md5.c
  
  clean-generic:
---- pacemaker-Pacemaker-1.1.10/lib/cib/Makefile.am.orig        2013-07-26 02:02:31.000000000 +0200
-+++ pacemaker-Pacemaker-1.1.10/lib/cib/Makefile.am     2013-09-08 15:20:01.962772701 +0200
-@@ -33,7 +33,7 @@
- endif
+--- pacemaker-Pacemaker-1.1.14/lib/cib/Makefile.am.orig        2016-04-09 22:03:33.010625713 +0200
++++ pacemaker-Pacemaker-1.1.14/lib/cib/Makefile.am     2016-04-09 22:04:03.627291096 +0200
+@@ -29,7 +29,7 @@
+ libcib_la_SOURCES      += cib_file.c cib_remote.c
  
- libcib_la_LDFLAGS     = -version-info 4:1:0 -L$(top_builddir)/lib/pengine/.libs
+ libcib_la_LDFLAGS     = -version-info 5:0:1 -L$(top_builddir)/lib/pengine/.libs
 -libcib_la_LIBADD        = $(CRYPTOLIB) $(top_builddir)/lib/pengine/libpe_rules.la $(top_builddir)/lib/common/libcrmcommon.la
 +libcib_la_LIBADD        = $(CRYPTOLIB) $(top_builddir)/lib/pengine/libpe_rules.la $(top_builddir)/lib/common/libcrmcommon.la $(GNUTLSLIBS)
  libcib_la_CFLAGS      = -I$(top_srcdir)
  
  clean-generic:
        rm -f *.log *.debug *~
---- pacemaker-Pacemaker-1.1.10/lib/fencing/Makefile.am.orig    2013-07-26 02:02:31.000000000 +0200
-+++ pacemaker-Pacemaker-1.1.10/lib/fencing/Makefile.am 2013-09-08 17:10:35.692494309 +0200
+--- pacemaker-Pacemaker-1.1.14/lib/fencing/Makefile.am.orig    2016-04-09 22:03:33.013959047 +0200
++++ pacemaker-Pacemaker-1.1.14/lib/fencing/Makefile.am 2016-04-09 22:04:30.660623301 +0200
 @@ -26,6 +26,6 @@
  
  libstonithd_la_SOURCES = st_client.c
- libstonithd_la_LDFLAGS = -version-info 3:2:1
+ libstonithd_la_LDFLAGS = -version-info 4:0:2
 -libstonithd_la_LIBADD = $(top_builddir)/lib/common/libcrmcommon.la
 +libstonithd_la_LIBADD = $(top_builddir)/lib/common/libcrmcommon.la $(LIBPILS)
  
- AM_CFLAGS = $(INCLUDES)
+ AM_CFLAGS = $(AM_CPPFLAGS)
 --- pacemaker-Pacemaker-1.1.10/cib/Makefile.am.orig    2013-07-26 02:02:31.000000000 +0200
 +++ pacemaker-Pacemaker-1.1.10/cib/Makefile.am 2013-09-08 17:11:22.042492364 +0200
 @@ -48,7 +48,7 @@
index 6cb09eef0abff6bf738e4a6b14040c4d9f519dee..22c8b43105ddfa0e0a71f237acc4960ad56242ed 100644 (file)
@@ -1,22 +1,29 @@
-diff -dur pacemaker-Pacemaker-1.1.9.orig/configure.ac pacemaker-Pacemaker-1.1.9/configure.ac
---- pacemaker-Pacemaker-1.1.9.orig/configure.ac        2013-06-21 21:29:19.000000000 +0200
-+++ pacemaker-Pacemaker-1.1.9/configure.ac     2013-06-21 21:30:52.227965879 +0200
-@@ -547,19 +547,7 @@
+--- pacemaker-Pacemaker-1.1.14/configure.ac.orig       2016-04-09 21:34:06.520699847 +0200
++++ pacemaker-Pacemaker-1.1.14/configure.ac    2016-04-09 21:49:29.907327769 +0200
+@@ -558,27 +558,7 @@
     PCMK_FEATURES="$PCMK_FEATURES generated-manpages"
  fi
  
 -MANPAGE_XSLT=""
 -if test x"${XSLTPROC}" != x""; then
 -  AC_MSG_CHECKING(docbook to manpage transform)
--  XSLT=`find ${datadir} -name docbook.xsl`
--  for xsl in $XSLT; do
--    dname=`dirname $xsl`
--    bname=`basename $dname`
--    if test "$bname" = "manpages"; then
--       MANPAGE_XSLT="$xsl"
--       break
--    fi
--  done
+-  # first try to figure out correct template using xmlcatalog query,
+-  # resort to extensive (semi-deterministic) file search if that fails
+-  DOCBOOK_XSL_URI='http://docbook.sourceforge.net/release/xsl/current'
+-  DOCBOOK_XSL_PATH='manpages/docbook.xsl'
+-  MANPAGE_XSLT=$(${XMLCATALOG} "" ${DOCBOOK_XSL_URI}/${DOCBOOK_XSL_PATH} \
+-                 | sed -n 's|^file://||p;q')
+-  if test x"${MANPAGE_XSLT}" = x""; then
+-    DIRS=$(find "${datadir}" -name $(basename $(dirname ${DOCBOOK_XSL_PATH})) \
+-           -type d | LC_ALL=C sort)
+-    XSLT=$(basename ${DOCBOOK_XSL_PATH})
+-    for d in ${DIRS}; do
+-      if test -f "${d}/${XSLT}"; then
+-         MANPAGE_XSLT="${d}/${XSLT}"
+-         break
+-      fi
+-    done
+-  fi
 -fi
 +MANPAGE_XSLT="/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
  AC_MSG_RESULT($MANPAGE_XSLT)
index fcb90f62ea97e750bea2e501e2b5857d61a1adfb..34825699e0d9da9466f5e3ef90419edd59ab0eaf 100644 (file)
@@ -1,3 +1,4 @@
+# TODO: publican docs (BR: publican, inkscape)
 #
 # Conditional build:
 %bcond_without corosync        # Corosync stack support
 Summary:       The scalable High-Availability cluster resource manager
 Summary(pl.UTF-8):     Skalowalny zarządca zasobów klastrów o wysokiej dostępności
 Name:          pacemaker
-Version:       1.1.13
+Version:       1.1.14
 Release:       1
 License:       GPL v2+, LGPL v2.1+
 Group:         Applications/System
+#Source0Download: https://github.com/ClusterLabs/pacemaker/releases
 Source0:       https://github.com/ClusterLabs/pacemaker/archive/Pacemaker-%{version}.tar.gz
-# Source0-md5: 219a1b5864013101dae3f9977f342b87
+# Source0-md5: 8f9973085512b6782c019b6d9a78ca8e
 Source1:       %{name}.tmpfiles
 Source2:       %{name}.init
 Source3:       %{name}.service
@@ -265,7 +267,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc doc/README* doc/*.html doc/*.txt AUTHORS COPYING*
+%doc AUTHORS ChangeLog NEWS README.markdown TODO.markdown doc/*.html doc/{executioner,msg-schema,security}.txt doc/{openstack,pcs-crmsh-quick-ref}.md
 %attr(755,root,root) %{_sbindir}/attrd_updater
 %attr(755,root,root) %{_sbindir}/cibadmin
 %attr(755,root,root) %{_sbindir}/crm_attribute
@@ -377,9 +379,9 @@ fi
 %attr(755,root,root) %{_libdir}/libpe_rules.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libpe_rules.so.2
 %attr(755,root,root) %{_libdir}/libpe_status.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpe_status.so.4
+%attr(755,root,root) %ghost %{_libdir}/libpe_status.so.10
 %attr(755,root,root) %{_libdir}/libpengine.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpengine.so.4
+%attr(755,root,root) %ghost %{_libdir}/libpengine.so.10
 %attr(755,root,root) %{_libdir}/libstonithd.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libstonithd.so.2
 %attr(755,root,root) %{_libdir}/libtransitioner.so.*.*.*
This page took 0.155681 seconds and 4 git commands to generate.