]> git.pld-linux.org Git - packages/ossp-uuid.git/blobdiff - ossp-uuid.spec
- release 30 (by relup.sh)
[packages/ossp-uuid.git] / ossp-uuid.spec
index 68499d58e5ce8a64d123605912e55e24fb562019..def90e1a3201799c23e8789d9981fe4391eef7a7 100644 (file)
@@ -5,22 +5,24 @@
 %bcond_with    pgsql           # build postgresql binding
 %bcond_without  static_libs     # don't build static libraries
 
+%define                php_name        php55
 Summary:       Universally Unique Identifier library
 Summary(pl.UTF-8):     Biblioteka unikalnych identyfikatorów UUID
 Name:          ossp-uuid
 Version:       1.6.2
-Release:       11
+Release:       30
 License:       MIT
 Group:         Libraries
 Source0:       ftp://ftp.ossp.org/pkg/lib/uuid/uuid-%{version}.tar.gz
 # Source0-md5: 5db0d43a9022a6ebbbc25337ae28942f
 Patch0:                uuid-ossp-prefix.patch
+Patch1:                php3.patch
 URL:           http://www.ossp.org/pkg/lib/uuid/
-%{?with_php:BuildRequires:     /usr/bin/php}
+%{?with_php:BuildRequires:     %{php_name}-devel}
+%{?with_php:BuildRequires:     %{php_name}-program}
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
 %{?with_perl:BuildRequires:    perl-devel}
-%{?with_php:BuildRequires:     php-devel >= 3:5.0.0}
 %{?with_pgsql:BuildRequires:   postgresql-backend-devel}
 %{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: rpmbuild(macros) >= 1.519
@@ -162,19 +164,18 @@ Perl OSSP uuid modules, which includes a Data::UUID replacement.
 %description -n perl-uuid -l pl.UTF-8
 Moduły Perla OSSP uuid, zawierające zamiennik Data::UUID.
 
-%package -n php-uuid
+%package -n %{php_name}-uuid
 Summary:       PHP support for Universally Unique Identifier library
 Summary(pl.UTF-8):     Wiązania PHP dla biblioteki OSSP UUID
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 %{?requires_php_extension}
-Requires:      php-common >= 4:5.0.4
 
-%description -n php-uuid
+%description -n %{php_name}-uuid
 UUID is a PHP extension for the creation of Universally Unique
 Identifiers (UUID).
 
-%description -n php-uuid -l pl.UTF-8
+%description -n %{php_name}-uuid -l pl.UTF-8
 UUID to rozrzeszenie PHP do tworzenia całkowicie unikalnych
 identyfikatorów UUID.
 
@@ -193,8 +194,14 @@ Moduł OSSP uuid dla PostgreSQL-a.
 %prep
 %setup -q -n uuid-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
+%if %{with php}
+cd php
+%{__libtoolize}
+cd ..
+%endif
 # Build the library.
 %configure \
        --includedir=%{_includedir}/ossp-uuid \
@@ -202,7 +209,7 @@ Moduł OSSP uuid dla PostgreSQL-a.
        --with-dce \
        --with-cxx \
        --with%{!?with_perl:out}-perl \
-       --with%{!?with_php:out}-php \
+       --with%{!?with_php:out}-php PHP=php \
        --with%{!?with_pgsql:out}-pgsql
 
 %{__make}
@@ -226,7 +233,6 @@ ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libossp-uuid.so.*.*) $RPM_BUI
 
 rm $RPM_BUILD_ROOT%{perl_vendorarch}/OSSP/uuid.pod
 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/OSSP/uuid/.packlist
-rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/OSSP/uuid/uuid.bs
 %endif
 
 %if %{with php}
@@ -328,7 +334,7 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %if %{with php}
-%files -n php-uuid
+%files -n %{php_name}-uuid
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{name}.ini
 %attr(755,root,root) %{php_extensiondir}/%{name}.so
This page took 0.076846 seconds and 4 git commands to generate.