]> git.pld-linux.org Git - packages/opera.git/blobdiff - opera.spec
up to 12.15
[packages/opera.git] / opera.spec
index dcf934a890efd9670f84cc46bc0e72c6e87e7a51..e5437418d2afe02cafb594aca8598ea9c520b1ab 100644 (file)
@@ -2,15 +2,16 @@
 # - HEAD - stable version
 # - DEVEL - development version
 # - WEEKLY - weekly development version
+# - NEXT - opera next
 #
 # NOTE: to avoid creating unreadable/unmaintainable spec:
 # - don't put static version here, create STATIC branch for that for example
 # - don't create useless bconds that for example limit SourceX: to current arch only
 #
 
-%define                ver     10.61
+%define                ver     12.15
 %define                shver   %(echo %{ver} | tr -d .)
-%define                buildid 6430
+%define                buildid 1748
 
 Summary:       World fastest web browser
 Summary(hu.UTF-8):     A világ leggyorsabb webböngészője
@@ -21,12 +22,10 @@ Release:    3
 Epoch:         2
 License:       Distributable
 Group:         X11/Applications/Networking
-Source10:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.i386.linux.tar.bz2
-# Source10-md5:        e91b9bd1ddbb3c85d7bdd7991b56add8
-Source11:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.x86_64.linux.tar.bz2
-# Source11-md5:        82e1906aed9f6770ec2ee8f65576c841
-Source12:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.ppc.linux.tar.bz2
-# Source12-md5:        b975faa6ebfeccecf53069be6e99284b
+Source10:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.i386.linux.tar.xz
+# Source10-md5:        5a18cce4635fd2930be54649b4dabaee
+Source11:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.x86_64.linux.tar.xz
+# Source11-md5:        59e1bb087e5861126a296ef0a68df8a4
 Source0:       %{name}.desktop
 Patch0:                %{name}-wrapper.patch
 Patch1:                %{name}-desktop.patch
@@ -35,16 +34,24 @@ URL:                http://www.opera.com/
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.356
 BuildRequires: sed >= 4.0
+BuildRequires: xz
+Requires(post,postun): gtk-update-icon-cache
+Requires(post,postun): hicolor-icon-theme
+Requires(post,postun): shared-mime-info
 Requires:      browser-plugins >= 2.0
 Requires:      desktop-file-utils
 Requires:      freetype >= 2
+Suggests:      gstreamer-theora
+Suggests:      gstreamer-vorbis
 Provides:      wwwbrowser
 Obsoletes:     opera-i18n
-ExclusiveArch: %{ix86} %{x8664} ppc
+ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _enable_debug_packages  0
 
+%define                _noautoreq      'libcurl.so.4\\(CURL_OPENSSL_3\\)'
+
 %define                _plugindir      %{_libdir}/opera/plugins
 %define                _operadocdir    %{_docdir}/%{name}-%{ver}
 # alternative arch for plugin32
@@ -91,17 +98,13 @@ Obsługa 32-bitowych wtyczek Opery.
 %setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.x86_64.linux
 %endif
 
-%ifarch ppc
-%setup -q -T -b 12 -n %{name}-%{version}-%{buildid}.ppc.linux
-%endif
-
-sed -i -e '
+%{__sed} -i -e '
        s,@@{PREFIX},%{_prefix},g
        s,@@{SUFFIX},,
        s,@@{_SUFFIX},,
 ' share/{applications/*.desktop,mime/packages/*.xml}
 
-sed -i -e 's,kfmclient exec,xdg-open,' share/opera/defaults/filehandler.ini
+%{__sed} -i -e 's,kfmclient exec,xdg-open,' share/opera/defaults/filehandler.ini
 
 %patch0 -p1
 %patch1 -p1
@@ -118,7 +121,10 @@ mv share/doc/opera/* .
 rm -rf share/icons/hicolor/scalable
 
 # opera packaging tools we don't need runtime
-mv share/opera/package .
+mv share/opera/package-id.ini .
+
+# cleanup backups after patching
+find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -135,6 +141,7 @@ EOF
 install -p opera* $RPM_BUILD_ROOT%{_bindir}
 cp -a lib/opera $RPM_BUILD_ROOT%{_libdir}
 cp -a share/* $RPM_BUILD_ROOT%{_datadir}
+ln -s %{_docdir}/%{name}-%{version}/LICENSE $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/license.txt
 #cp -a etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
 
 sed -i -e 's#/usr/lib/opera#%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
@@ -182,37 +189,45 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc LICENSE
-#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
 
 # browser plugins v2
 %{_browserpluginsconfdir}/browsers.d/%{name}.*
 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/operaprefs*.ini
+
 %attr(755,root,root) %{_bindir}/opera
-%attr(755,root,root) %{_bindir}/opera-widget-manager
+#%attr(755,root,root) %{_bindir}/opera-widget-manager
 %dir %{_libdir}/opera
 %ifarch %{x8664}
-%exclude %{_libdir}/opera/*-ia32-*
+%exclude %{_libdir}/opera/pluginwrapper/*-ia32-*
 %endif
 %attr(755,root,root) %{_libdir}/opera/*.so
 %attr(755,root,root) %{_libdir}/opera/opera*
+%dir %{_libdir}/opera/pluginwrapper
+%attr(755,root,root) %{_libdir}/opera/pluginwrapper/*
 %dir %{_plugindir}
 %dir %{_libdir}/opera/gstreamer
 %dir %{_libdir}/opera/gstreamer/plugins
 %attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperamatroska.so
 %attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperavp8.so
 %dir %{_datadir}/opera
+%{_datadir}/mime/packages/opera-extension.xml
 %{_datadir}/opera/*.*
 %{_datadir}/opera/defaults
 %{_datadir}/opera/extra
 %{_datadir}/opera/skin
+#%{_datadir}/opera/scripts
 %{_datadir}/opera/styles
 %{_datadir}/opera/ui
-%{_datadir}/opera/unite
+#%{_datadir}/opera/unite
 %dir %{_datadir}/opera/locale
 %{_datadir}/opera/locale/en
+%lang(af) %{_datadir}/opera/locale/af
+%lang(ar) %{_datadir}/opera/locale/ar
+%lang(az) %{_datadir}/opera/locale/az
 %lang(be) %{_datadir}/opera/locale/be
 %lang(bg) %{_datadir}/opera/locale/bg
+%lang(bn) %{_datadir}/opera/locale/bn
 %lang(cs) %{_datadir}/opera/locale/cs
 %lang(da) %{_datadir}/opera/locale/da
 %lang(de) %{_datadir}/opera/locale/de
@@ -221,10 +236,13 @@ fi
 %lang(es_ES) %{_datadir}/opera/locale/es-ES
 %lang(es_LA) %{_datadir}/opera/locale/es-LA
 %lang(et) %{_datadir}/opera/locale/et
+%lang(fa) %{_datadir}/opera/locale/fa
 %lang(fi) %{_datadir}/opera/locale/fi
 %lang(fr) %{_datadir}/opera/locale/fr
 %lang(fr_CA) %{_datadir}/opera/locale/fr-CA
 %lang(fy) %{_datadir}/opera/locale/fy
+%lang(gd) %{_datadir}/opera/locale/gd
+%lang(he) %{_datadir}/opera/locale/he
 %lang(hi) %{_datadir}/opera/locale/hi
 %lang(hr) %{_datadir}/opera/locale/hr
 %lang(hu) %{_datadir}/opera/locale/hu
@@ -232,12 +250,17 @@ fi
 %lang(it) %{_datadir}/opera/locale/it
 %lang(ja) %{_datadir}/opera/locale/ja
 %lang(ka) %{_datadir}/opera/locale/ka
+%lang(kk) %{_datadir}/opera/locale/kk
 %lang(ko) %{_datadir}/opera/locale/ko
 %lang(lt) %{_datadir}/opera/locale/lt
+%lang(lt) %{_datadir}/opera/locale/lv
+%lang(me) %{_datadir}/opera/locale/me
 %lang(mk) %{_datadir}/opera/locale/mk
+%lang(ms) %{_datadir}/opera/locale/ms
 %lang(nb) %{_datadir}/opera/locale/nb
 %lang(nl) %{_datadir}/opera/locale/nl
 %lang(nn) %{_datadir}/opera/locale/nn
+%lang(pa) %{_datadir}/opera/locale/pa
 %lang(pl) %{_datadir}/opera/locale/pl
 %lang(pt) %{_datadir}/opera/locale/pt
 %lang(pt_BR) %{_datadir}/opera/locale/pt-BR
@@ -246,23 +269,31 @@ fi
 %lang(sk) %{_datadir}/opera/locale/sk
 %lang(sr) %{_datadir}/opera/locale/sr
 %lang(sv) %{_datadir}/opera/locale/sv
+%lang(sw) %{_datadir}/opera/locale/sw
 %lang(ta) %{_datadir}/opera/locale/ta
 %lang(te) %{_datadir}/opera/locale/te
+%lang(th) %{_datadir}/opera/locale/th
+%lang(tl) %{_datadir}/opera/locale/tl
 %lang(tr) %{_datadir}/opera/locale/tr
 %lang(uk) %{_datadir}/opera/locale/uk
+%lang(ur) %{_datadir}/opera/locale/ur
+%lang(uz) %{_datadir}/opera/locale/uz
 %lang(vi) %{_datadir}/opera/locale/vi
 %lang(zh_CN) %{_datadir}/opera/locale/zh-cn
-%lang(zh_HK) %{_datadir}/opera/locale/zh-hk
+#%lang(zh_HK) %{_datadir}/opera/locale/zh-hk
 %lang(zh_TW) %{_datadir}/opera/locale/zh-tw
-%{_datadir}/mime/packages/opera-widget.xml
-%{_datadir}/mime/packages/opera-unite-application.xml
+%lang(zu) %{_datadir}/opera/locale/zu
+%{_datadir}/opera/region
+#%{_datadir}/mime/packages/opera-widget.xml
+#%{_datadir}/mime/packages/opera-unite-application.xml
 %{_desktopdir}/*.desktop
 %{_mandir}/man1/opera.1*
-%{_mandir}/man1/opera-widget-manager.1*
+#%{_mandir}/man1/opera-widget-manager.1*
+#%{_pixmapsdir}/opera.xpm
 %{_iconsdir}/hicolor/*/*/*.png
 
 %ifarch %{x8664}
 %files plugin32
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/opera/*-ia32-*
+%attr(755,root,root) %{_libdir}/opera/pluginwrapper/*-ia32-*
 %endif
This page took 0.527086 seconds and 4 git commands to generate.