]> git.pld-linux.org Git - packages/opera.git/blobdiff - opera.spec
- Requires(post,postun): gtk-update-icon-cache
[packages/opera.git] / opera.spec
index 1a1d0e8179d30688b7c92a9be09372d2ca27dd56..dd9b4d2d8f3441e45d97ac9034a627570f49049d 100644 (file)
-# TODO:
-# - move translations into a separate, noarch package
+# BRANCHES:
+# - HEAD - stable version
+# - DEVEL - development version
+# - WEEKLY - weekly development version
+#
+# NOTE: to avoid creating unreadable/unmaintainable spec:
+# - don't put static version here, create STATIC branch for that for example
+# - don't create useless bconds that for example limit SourceX: to current arch only
 #
-%bcond_without shared          # static or shared version
-%bcond_without distributable   # distributable or not
-%bcond_without incall          # include all tarballs into src.rpm (but splitted into shared/static)
-%bcond_with    snap            # snap version
-%bcond_with    weekly          # weekly snapshot version
-
-%ifarch sparc sparc64
-%undefine with_shared
-%endif
-
-%if %{with weekly}
-%define        ver             9.20
-%define        sver            %{ver}
-%define        fix             %{nil}
-%define        dirrel          20070330
-%define        magicstr        628
-%define with_snap      1
-%else
-%if %{with snap}
-%define        ver             9.0
-%define        sver            %{ver}
-%define        fix             %{nil}
-%define        dirrel          20060206
-%define        reltype         Preview-2
-%define        magicstr        %{nil}
-%else
-%define        ver             9.10
-%define        sver            9.10
-%define        fix             %{nil}
-%define        dirrel          20061214
-%define        reltype         final
-%define        magicstr        521
-%endif
-%endif
-
-%define        shver           %(echo %{ver} | tr -d .)%{fix}
-%define        x86_shared_rel          %{dirrel}.5
-%define        x86_static_rel          %{dirrel}.1
-%define        sparc_shared_rel        %{dirrel}.2
-%define        sparc_static_rel        %{dirrel}.1
-%define        ppc_shared_rel          %{dirrel}.3
-%define        ppc_static_rel          %{dirrel}.1
-%if %{with shared}
-%define        type            shared
-# We should be able to build src.rpm also on not supported archs
-%define        rel             %{x86_shared_rel}
-%ifarch sparc sparc64
-#%%define      rel             %{sparc_shared_rel}
-%define        rel             %{sparc_static_rel}
-%else
-%ifarch ppc
-%define        rel             %{ppc_shared_rel}
-%endif
-%endif
-%else
-%define        type            static
-%define        rel             %{x86_static_rel}
-%ifarch sparc sparc64
-%define        rel             %{sparc_static_rel}
-%else
-%ifarch ppc
-%define        rel             %{ppc_static_rel}
-%endif
-%endif
-%endif
-
-# define to 0 and then redefine to avoid
-# not defined macros
-%define        need_ix86_shared_snap   0
-%define        need_sparc_shared_snap  0
-%define        need_ppc_shared_snap    0
-%define        need_ix86_static_snap   0
-%define        need_sparc_static_snap  0
-%define        need_ppc_static_snap    0
-
-%define        need_ix86_shared        0
-%define        need_sparc_shared       0
-%define        need_ppc_shared         0
-%define        need_ix86_static        0
-%define        need_sparc_static       0
-%define        need_ppc_static         0
-
-%if %{with incall}
-#      with incall?    [if]
-%if    %{with snap}
-#              with snap?      [if]
-%if    %{with shared}
-#                      with shared?    [if]
-%define        need_ix86_shared_snap   1
-%define        need_sparc_shared_snap  0
-%define        need_ppc_shared_snap    1
-%else
-#                      with shared:    [else]
-%define        need_ix86_static_snap   1
-%define        need_sparc_static_snap  1
-%define        need_ppc_static_snap    1
-%endif
-#                      with shared;    [endif]
-%else
-#              with snap:      [else]
-%if %{with shared}
-#                      with shared?    [if]
-%define        need_ix86_shared        1
-#%%define      need_sparc_shared       1
-%define        need_sparc_static       1
-%define        need_ppc_shared 1
-%else
-#                      with shared:    [else]
-%define        need_ix86_static        1
-%define        need_sparc_static       1
-%define        need_ppc_static 1
-%endif
-#                      with shared;    [endif]
-%endif
-#              with snap;      [endif]
-%else
-#      with incall:    [else]
-%ifarch        %{ix86}
-#              is ix86?        [if]
-%if    %{with snap}
-#                      with snap?      [if]
-%if    %{with shared}
-#                              with shared?    [if]
-%define        need_ix86_shared_snap   1
-%else
-#                              with shared:    [else]
-%define        need_ix86_static_snap   1
-%endif
-#                              with shared;    [endif]
-%else
-#                      with snap:      [else]
-%if    %{with shared}
-#                              with shared?    [if]
-%define        need_ix86_shared        1
-%else
-#                              with shared:    [else]
-%define        need_ix86_static        1
-%endif
-#                              with shared;    [endif]
-%endif
-#                      with snap;      [endif]
-%else
-#              is ix86:        [else]
-%ifarch        sparc sparc64
-#              is sparc?       [if]
-%if    %{with snap}
-#                      with snap?      [if]
-%if    %{with shared}
-#                              with shared?    [if]
-%define        need_sparc_shared_snap  1
-%else
-#                              with shared:    [else]
-%define        need_sparc_static_snap  1
-%endif
-#                              with shared;    [endif]
-%else
-#                      with snap:      [else]
-%if    %{with shared}
-#                              with shared?    [if]
-#%%define      need_sparc_shared       1
-%define        need_sparc_static       1
-%else
-#                              with shared:    [else]
-%define        need_sparc_static       1
-%endif
-#                              with shared;    [endif]
-%endif
-#                      with snap;      [endif]
-%else
-#              is sparc:       [else]
-%ifarch        ppc
-#              is ppc?         [if]
-%if    %{with snap}
-#                      with snap?      [if]
-%if    %{with shared}
-#                              with shared?    [if]
-%define        need_ppc_shared_snap    1
-%else
-#                              with shared:    [else]
-%define        need_ppc_static_snap    1
-%endif
-#                              with shared;    [endif]
-%else
-#                      with snap:      [else]
-%if    %{with shared}
-#                              with shared?    [if]
-%define        need_ppc_shared 1
-%else
-#                              with shared:    [else]
-%define        need_ppc_static 1
-%endif
-#                              with shared;    [endif]
-%endif
-#                      with snap;      [endif]
-%endif
-#              is ppc;         [endif]
-%endif
-#              is sparc;       [endif]
-%endif
-#              is ix86;        [endif]
-%endif
-#      with incall;    [endif]
 
-%if %{with weekly}
-%define        need_ppc_shared_snap    0
-%define        need_ppc_static_snap    0
-%define        need_sparc_shared_snap  0
-%define        need_sparc_static_snap  0
-%endif
+%define                ver     11.01
+%define                shver   %(echo %{ver} | tr -d .)
+%define                buildid 1190
 
-%define                _rel    4
 Summary:       World fastest web browser
+Summary(hu.UTF-8):     A világ leggyorsabb webböngészője
 Summary(pl.UTF-8):     Najszybsza przeglądarka WWW na świecie
 Name:          opera
-Version:       %{ver}%{fix}
-Release:       %{?with_snap:1.%{rel}.}%{_rel}
+Version:       %{ver}
+Release:       2
 Epoch:         2
-License:       Distributable for PLD until 31 Dec 2006 - http://distribute.opera.com/ (otherwise restricted, see file LICENSE)
+License:       Distributable
 Group:         X11/Applications/Networking
-
-%if %{need_ix86_static}
-Source0:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/static/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
-# Source0-md5: dccdc5252ffc6658f3c46f32c64c8219
-%{!?with_distributable:NoSource:       0}
-%endif
-
-%if %{need_ix86_static_snap}
-%if %{with weekly}
-Source30100:   http://snapshot.opera.com/unix/Weekly-%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en-%{magicstr}.tar.bz2
-%else
-Source100:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en-%{magicstr}.tar.bz2
-%endif
-%{!?with_distributable:NoSource:       100}
-%endif
-
-%if %{need_sparc_static}
-Source1:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/static/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
-# Source1-md5: e7bcbbaa48a63827d0efc60cf6fef68d
-%{!?with_distributable:NoSource:       1}
-%endif
-
-%if %{need_sparc_static_snap}
-Source101:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/sparc-linux/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
-# Source101-md5:       913ccb28106f9f5acd3d94c8dc71ae1
-%{!?with_distributable:NoSource:       101}
-%endif
-
-%if %{need_ppc_static}
-Source2:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/static/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
-# Source2-md5: d67428a09a036e786efc22e03150a344
-%{!?with_distributable:NoSource:       2}
-%endif
-
-%if %{need_ppc_static_snap}
-%if %{with weekly}
-Source30102:   http://snapshot.opera.com/unix/Weekly-%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en-%{magicstr}.tar.bz2
-%else
-Source102:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
-%endif
-%{!?with_distributable:NoSource:       102}
-%endif
-
-%if %{need_ix86_shared}
-Source20:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/shared/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
-# Source20-md5:        a60b0abe55ca580952b30f4540632425
-%{!?with_distributable:NoSource:       20}
-%endif
-
-%if %{need_ix86_shared_snap}
-%if %{with weekly}
-Source301020:  http://snapshot.opera.com/unix/Weekly-%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en-%{magicstr}.tar.bz2
-# Source301020-md5:    232b0111e9b9c0a7266c66776f597ba5
-%else
-Source1020:    http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
-# Source1020-md5:      6f296be6b9fc3001588d4509016062bd
-%{!?with_distributable:NoSource:       1020}
-%endif
-%endif
-
-%if %{need_sparc_shared}
-Source21:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/shared/gcc-2.95/%{name}-%{sver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
-# Source21-md5:        883df8058672cf52678a07d714dcfce
-%{!?with_distributable:NoSource:       21}
-%endif
-
-%if %{need_sparc_shared_snap}
-Source1021:    http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/sparc-linux/%{name}-%{sver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
-# Source1021-md5:      e190021f5530de3f711006cd9f6bb339
-%{!?with_distributable:NoSource:       1021}
-%endif
-
-%if %{need_ppc_shared}
-Source22:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/shared/gcc-2.95/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
-# Source22-md5:        6ef04f12a39fdbe671dfbd6a37080a81
-%{!?with_distributable:NoSource:       22}
-%endif
-
-%if %{need_ppc_shared_snap}
-%if %{with weekly}
-Source301022:  http://snapshot.opera.com/unix/Weekly-%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en-%{magicstr}.tar.bz2
-# Source301022-md5:    65293d788e18d0c23cccac71b9fe567c
-%else
-Source1022:    http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
-# Source1022-md5:      74985fa6da49b2e54c9d03dab1119325
-%{!?with_distributable:NoSource:       1022}
-%endif
-%endif
-
-Source4:       %{name}.desktop
+Source10:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.i386.linux.tar.xz
+# Source10-md5:        9614f1c8b1e7e71aeb398122db30bfed
+Source11:      ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.x86_64.linux.tar.xz
+# Source11-md5:        802e1725acddc713dffb3441815156b9
+Source0:       %{name}.desktop
 Patch0:                %{name}-wrapper.patch
+Patch1:                %{name}-desktop.patch
+Patch2:                %{name}-pluginpath.patch
 URL:           http://www.opera.com/
+BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.356
 BuildRequires: sed >= 4.0
+BuildRequires: xz
+Requires(post,postun): gtk-update-icon-cache
+Requires(post,postun): hicolor-icon-theme
 Requires:      browser-plugins >= 2.0
+Requires:      desktop-file-utils
 Requires:      freetype >= 2
 Provides:      wwwbrowser
-ExclusiveArch: %{ix86} ppc sparc sparc64
+Obsoletes:     opera-i18n
+ExclusiveArch: %{ix86} %{x8664} ppc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _enable_debug_packages  0
+
 %define                _plugindir      %{_libdir}/opera/plugins
 %define                _operadocdir    %{_docdir}/%{name}-%{ver}
+# alternative arch for plugin32
+%define                alt_arch        i386
 
 %description
 Opera is world fastest web browser. It supports most of nowaday
-extensions of HTML. And it is quite stable. This version is %{?with_shared:shared}%{!?with_shared:statically}
-linked with Qt.
+extensions of HTML. And it is quite stable. This version is linked
+with shared version of Qt.
+
+%description -l hu.UTF-8
+Opera a világ leggyorsabb webböngészője. A manapság elterjedt
+HTML-kiterjesztések túlnyomó többségét támogatja. És elég stabili is.
+Ez a verzió a Qt megosztott verziójához linkelődik.
 
 %description -l pl.UTF-8
 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
 dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
-wersja jest skonsolidowana %{?with_shared:dynamicznie}%{!?with_shared:statycznie} z Qt.
+wersja jest skonsolidowana dynamicznie z Qt.
+
+%package plugin32
+Summary:       Opera 32-bit plugins support
+Summary(hu.UTF-8):     Opera 32-bites plugin támogatás
+Summary(pl.UTF-8):     Obsługa 32-bitowych wtyczek Opery
+Group:         X11/Applications/Networking
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      browser-plugins >= 2.0
+
+%description plugin32
+Opera 32-bit plugins support.
+
+%description plugin32 -l hu.UTF-8
+Opera 32-bites plugin támogatás.
+
+%description plugin32 -l pl.UTF-8
+Obsługa 32-bitowych wtyczek Opery.
 
 %prep
 %ifarch %{ix86}
-%setup -q -T -b %{?with_weekly:30}%{?with_snap:10}%{?with_shared:2}0 -n %{name}-%{sver}-%{rel}-%{type}-qt.i386-en%{?magicstr:-%{magicstr}}
+%setup -q -T -b 10 -n %{name}-%{version}-%{buildid}.i386.linux
 %endif
-%ifarch sparc sparc64
-%setup -q -T -b %{?with_weekly:30}%{?with_snap:10}%{?with_shared:2}1 -n %{name}-%{sver}-%{rel}-%{type}-qt.sparc-en%{?magicstr:-%{magicstr}}
-%endif
-%ifarch ppc
-%setup -q -T -b %{?with_weekly:30}%{?with_snap:10}%{?with_shared:2}2 -n %{name}-%{sver}-%{rel}-%{type}-qt.ppc-en%{?magicstr:-%{magicstr}}
+
+%ifarch %{x8664}
+%setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.x86_64.linux
 %endif
+
+sed -i -e '
+       s,@@{PREFIX},%{_prefix},g
+       s,@@{SUFFIX},,
+       s,@@{_SUFFIX},,
+' share/{applications/*.desktop,mime/packages/*.xml}
+
+sed -i -e 's,kfmclient exec,xdg-open,' share/opera/defaults/filehandler.ini
+
 %patch0 -p1
+%patch1 -p1
+
+# remove lib32/lib64 paths so patch2 can apply (i386 build contained lib64 as well, oh well)
+%{__sed} -i -e '/lib32\|lib64/d;$d' share/opera/defaults/pluginpath.ini
+%patch2 -p1
+
+mv lib/opera/plugins/README README.plugins
+mv share/opera/defaults/license.txt .
+mv share/doc/opera/* .
+
+# nobody wants scalable huge icons
+rm -rf share/icons/hicolor/scalable
+
+# opera packaging tools we don't need runtime
+mv share/opera/package .
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
 
 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
 # opera does not use for .xpt files
@@ -355,30 +127,51 @@ install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
 
 # use mplayerplug-in-opera instead
 mplayerplug-in*
-
-# opera uses libjava.so to run java
-libjavaplugin_oji.so
 EOF
 
-sh install.sh \
-       DESTDIR=$RPM_BUILD_ROOT \
-       --prefix=%{_prefix} \
-       --exec_prefix=%{_libdir}/opera/bin \
-       --docdir=%{_operadocdir}
+install -p opera* $RPM_BUILD_ROOT%{_bindir}
+cp -a lib/opera $RPM_BUILD_ROOT%{_libdir}
+cp -a share/* $RPM_BUILD_ROOT%{_datadir}
+#cp -a etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
 
-# install in kde etc.
-install images/opera.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
-install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
+sed -i -e 's#/usr/lib/opera#%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
 
-mv -f $RPM_BUILD_ROOT%{_datadir}/%{name}/config/* $RPM_BUILD_ROOT%{_sysconfdir}
+cat << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/operaprefs_default.ini
+[ISP]
+Id="DISTRO"
+EOF
+
+%if "%{pld_release}" == "ti"
+sed -i -e 's#DISTRO#PLD/Titanium#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
+%else
+%if "%{pld_release}" == "ac"
+sed -i -e 's#DISTRO#PLD/2.0 (Ac)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
+%else
+sed -i -e 's#DISTRO#PLD/3.0 (Th)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
+%endif
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
+%update_mime_database
+%update_icon_cache hicolor
+%update_desktop_database_post
 %update_browser_plugins
 
 %postun
+%update_mime_database
+%update_icon_cache hicolor
+%update_desktop_database_postun
+if [ "$1" = 0 ]; then
+       %update_browser_plugins
+fi
+
+%post plugin32
+%update_browser_plugins
+
+%postun plugin32
 if [ "$1" = 0 ]; then
        %update_browser_plugins
 fi
@@ -386,28 +179,88 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc LICENSE
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*rc*
+#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
 
 # browser plugins v2
 %{_browserpluginsconfdir}/browsers.d/%{name}.*
 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
-
-%attr(755,root,root) %{_bindir}/*
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/operaprefs*.ini
+%attr(755,root,root) %{_bindir}/opera
+%attr(755,root,root) %{_bindir}/opera-widget-manager
 %dir %{_libdir}/opera
-%dir %{_libdir}/opera/bin
-%attr(755,root,root) %{_libdir}/opera/bin/*
+%ifarch %{x8664}
+%exclude %{_libdir}/opera/*-ia32-*
+%endif
+%attr(755,root,root) %{_libdir}/opera/*.so
+%attr(755,root,root) %{_libdir}/opera/opera*
 %dir %{_plugindir}
-%attr(755,root,root) %{_plugindir}/*
+%dir %{_libdir}/opera/gstreamer
+%dir %{_libdir}/opera/gstreamer/plugins
+%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperamatroska.so
+%attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperavp8.so
 %dir %{_datadir}/opera
 %{_datadir}/opera/*.*
-%{_datadir}/opera/images
-%{_datadir}/opera/ini
-%{_datadir}/opera/java
+%{_datadir}/opera/defaults
+%{_datadir}/opera/extra
 %{_datadir}/opera/skin
 %{_datadir}/opera/styles
+%{_datadir}/opera/ui
+%{_datadir}/opera/unite
 %dir %{_datadir}/opera/locale
 %{_datadir}/opera/locale/en
-%{_datadir}/opera/locale/english.lng
+%lang(be) %{_datadir}/opera/locale/be
+%lang(bg) %{_datadir}/opera/locale/bg
+%lang(cs) %{_datadir}/opera/locale/cs
+%lang(da) %{_datadir}/opera/locale/da
+%lang(de) %{_datadir}/opera/locale/de
+%lang(el) %{_datadir}/opera/locale/el
+%lang(en_GB) %{_datadir}/opera/locale/en-GB
+%lang(es_ES) %{_datadir}/opera/locale/es-ES
+%lang(es_LA) %{_datadir}/opera/locale/es-LA
+%lang(et) %{_datadir}/opera/locale/et
+%lang(fi) %{_datadir}/opera/locale/fi
+%lang(fr) %{_datadir}/opera/locale/fr
+%lang(fr_CA) %{_datadir}/opera/locale/fr-CA
+%lang(fy) %{_datadir}/opera/locale/fy
+%lang(hi) %{_datadir}/opera/locale/hi
+%lang(hr) %{_datadir}/opera/locale/hr
+%lang(hu) %{_datadir}/opera/locale/hu
+%lang(id) %{_datadir}/opera/locale/id
+%lang(it) %{_datadir}/opera/locale/it
+%lang(ja) %{_datadir}/opera/locale/ja
+%lang(ka) %{_datadir}/opera/locale/ka
+%lang(ko) %{_datadir}/opera/locale/ko
+%lang(lt) %{_datadir}/opera/locale/lt
+%lang(mk) %{_datadir}/opera/locale/mk
+%lang(nb) %{_datadir}/opera/locale/nb
+%lang(nl) %{_datadir}/opera/locale/nl
+%lang(nn) %{_datadir}/opera/locale/nn
+%lang(pl) %{_datadir}/opera/locale/pl
+%lang(pt) %{_datadir}/opera/locale/pt
+%lang(pt_BR) %{_datadir}/opera/locale/pt-BR
+%lang(ro) %{_datadir}/opera/locale/ro
+%lang(ru) %{_datadir}/opera/locale/ru
+%lang(sk) %{_datadir}/opera/locale/sk
+%lang(sr) %{_datadir}/opera/locale/sr
+%lang(sv) %{_datadir}/opera/locale/sv
+%lang(ta) %{_datadir}/opera/locale/ta
+%lang(te) %{_datadir}/opera/locale/te
+%lang(tr) %{_datadir}/opera/locale/tr
+%lang(uk) %{_datadir}/opera/locale/uk
+%lang(vi) %{_datadir}/opera/locale/vi
+%lang(zh_CN) %{_datadir}/opera/locale/zh-cn
+%lang(zh_HK) %{_datadir}/opera/locale/zh-hk
+%lang(zh_TW) %{_datadir}/opera/locale/zh-tw
+%{_datadir}/mime/packages/opera-extension.xml
+%{_datadir}/mime/packages/opera-widget.xml
+%{_datadir}/mime/packages/opera-unite-application.xml
 %{_desktopdir}/*.desktop
 %{_mandir}/man1/opera.1*
-%{_pixmapsdir}/opera.xpm
+%{_mandir}/man1/opera-widget-manager.1*
+%{_iconsdir}/hicolor/*/*/*.png
+
+%ifarch %{x8664}
+%files plugin32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/opera/*-ia32-*
+%endif
This page took 0.394996 seconds and 4 git commands to generate.