]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- use x8664 macro
[packages/openssl.git] / openssl.spec
index 7990ba88765188bc1ebb9a28ead86cc4da6bccc6..f32a9ad87cc022813b87c6c0f0ec43b7496b9134 100644 (file)
@@ -8,12 +8,12 @@ Summary(pt_BR):       Uma biblioteca C que fornece v
 Summary(ru):   âÉÂÌÉÏÔÅËÉ É ÕÔÉÌÉÔÙ ÄÌÑ ÓÏÅÄÉÎÅÎÉÊ ÞÅÒÅÚ Secure Sockets Layer
 Summary(uk):   â¦Â̦ÏÔÅËÉ ÔÁ ÕÔÉ̦ÔÉ ÄÌÑ Ú'¤ÄÎÁÎØ ÞÅÒÅÚ Secure Sockets Layer
 Name:          openssl
-Version:       0.9.7d
-Release:       5
+Version:       0.9.7g
+Release:       1
 License:       Apache-style License
 Group:         Libraries
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: 1b49e90fc8a75c3a507c0a624529aca5
+# Source0-md5: 991615f73338a571b6a1be7d74906934
 Source1:       %{name}-ca-bundle.crt
 Source2:       %{name}.1.pl
 Source3:       %{name}-ssl-certificate.sh
@@ -21,15 +21,17 @@ Patch0:             %{name}-alpha-ccc.patch
 Patch1:                %{name}-optflags.patch
 Patch2:                %{name}-globalCA.diff
 Patch3:                %{name}-include.patch
-Patch4:                %{name}-smime.patch
+Patch4:                %{name}-md5-sparcv9.patch
+Patch5:                %{name}-ssl-algs.patch
 URL:           http://www.openssl.org/
 BuildRequires: perl-devel >= 1:5.6.1
 BuildRequires: rpm-perlprov >= 4.1-13
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+BuildRequires: rpmbuild(macros) >= 1.213
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
 Obsoletes:     SSLeay-perl
 Obsoletes:     libopenssl0
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 The OpenSSL Project is a collaborative effort to develop a robust,
@@ -182,6 +184,11 @@ RC4, RSA 
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
+
+# conflicts with i386-only DES implementation
+# (missing #ifdef OPENSSL_FIPS  ...  #endif)
+:> fips/des/asm/fips-dx86-elf.s
 
 %build
 %{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' \
@@ -194,7 +201,8 @@ touch Makefile.*
 OPTFLAGS="%{rpmcflags}"
 export OPTFLAGS
 %ifarch %{ix86}
-%ifarch i386 i486
+%ifarch i386
+# allow running on 80386 (default code uses bswapl available on i486+)
 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared 386
 %else
 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared
@@ -203,7 +211,7 @@ export OPTFLAGS
 %ifarch alpha
 ./Configure --openssldir=%{_var}/lib/%{name} threads linux-alpha+bwx-gcc shared
 %endif
-%ifarch amd64
+%ifarch %{x8664}
 ./Configure --openssldir=%{_var}/lib/%{name} linux-x86_64 shared
 %endif
 %ifarch ia64
@@ -322,7 +330,7 @@ install doc/ssl/*.3 doc/crypto/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
 install doc/crypto/*.7 $RPM_BUILD_ROOT%{_mandir}/man7
 install %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
 install %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
-
+install fips/openssl_fips_fingerprint $RPM_BUILD_ROOT%{_bindir}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -331,7 +339,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%attr(755,root,root) %{_libdir}/libcrypto.so.*.*.*
+%attr(755,root,root) %{_libdir}/libssl.so.*.*.*
 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
 %doc doc/openssl_button.gif doc/openssl_button.html
 %dir %{_var}/lib/%{name}
@@ -348,7 +357,9 @@ rm -rf $RPM_BUILD_ROOT
 %verify(not md5 size mtime) %config(noreplace) %{_datadir}/ssl/ca-bundle.crt
 
 %attr(755,root,root) %{_bindir}/%{name}
+%attr(755,root,root) %{_bindir}/openssl_fips_fingerprint
 %attr(754,root,root) %{_bindir}/ssl-certificate
+
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
 %attr(755,root,root) %{_libdir}/%{name}/c_hash
@@ -367,6 +378,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/openssl_dsa.1*
 %{_mandir}/man1/openssl_dsaparam.1*
 %{_mandir}/man1/openssl_enc.1*
+%{_mandir}/man1/openssl_errstr.1*
 %{_mandir}/man1/openssl_gendsa.1*
 %{_mandir}/man1/openssl_genrsa.1*
 %{_mandir}/man1/openssl_nseq.1*
@@ -395,13 +407,13 @@ rm -rf $RPM_BUILD_ROOT
 %files tools-perl
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
-%attr(755,root,root) %{_libdir}/%{name}/der_chop
 %attr(755,root,root) %{_libdir}/%{name}/c_rehash
 %{_mandir}/man1/openssl_CA.pl.1*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
+%attr(755,root,root) %{_libdir}/libcrypto.so
+%attr(755,root,root) %{_libdir}/libssl.so
 %{_includedir}/%{name}
 %{_pkgconfigdir}/openssl.pc
 %{_mandir}/man3/openssl*.3*
This page took 0.219824 seconds and 4 git commands to generate.