]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- fixed removing uclibc stuff
[packages/openssl.git] / openssl.spec
index 9ea16468fb05b5fb2778ba75db8501322195129d..e2e7a27b8cbd55bcfab7ed38661a19898c131ad9 100644 (file)
@@ -1,5 +1,3 @@
-# conditional build:
-# _without_embed - don't build uClibc version
 %include       /usr/lib/rpm/macros.perl
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
 Summary(de):   Secure Sockets Layer (SSL)-Kommunikationslibrary
@@ -7,17 +5,10 @@ Summary(pl):  Biblioteki OpenSSL (SSL v2/v3)
 Summary(fr):   Utilitaires de communication SSL (Secure Sockets Layer)
 Name:          openssl
 Version:       0.9.6b
-Release:       6
+Release:       7
 License:       Apache-style License
 Vendor:                The OpenSSL Project
 Group:         Libraries
-Group(de):     Libraries
-Group(es):     Bibliotecas
-Group(fr):     Librairies
-Group(pl):     Biblioteki
-Group(pt_BR):  Bibliotecas
-Group(ru):     âÉÂÌÉÏÔÅËÉ
-Group(uk):     â¦Â̦ÏÔÅËÉ
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
 Patch0:                %{name}-alpha-ccc.patch
 # patch1 is only for 0.9.6a version. This version isn't binary
@@ -27,21 +18,12 @@ Patch2:             %{name}-optflags.patch
 Patch3:                %{name}-nocrypt.patch
 BuildRequires: perl-devel >= 5.6.1
 BuildRequires: textutils
-%if %{!?_without_embed:1}%{?_without_embed:0}
-BuildRequires: uClibc-devel
-BuildRequires: uClibc-static
-%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
 Obsoletes:     SSLeay-perl
 Obsoletes:     libopenssl0
 
-%define embed_path     /usr/lib/embed
-%define embed_cc       %{_arch}-uclibc-cc
-%define embed_cflags   %{rpmcflags} -Os
-%define uclibc_prefix  /usr/%{_arch}-linux-uclibc
-
 %description
 The OpenSSL Project is a collaborative effort to develop a robust,
 commercial-grade, full-featured, and Open Source toolkit implementing
@@ -79,8 +61,6 @@ v2/v3 oraz Transport Layer Security (TLS v1).
 Summary:       OpenSSL command line tool and utilities
 Summary(pl):   Zestaw narzêdzi i skryptów
 Group:         Applications/Communications
-Group(de):     Applikationen/Kommunikation
-Group(pl):     Aplikacje/Komunikacja
 Requires:      %{name} = %{version}
 
 %description tools
@@ -93,8 +73,6 @@ Zestaw narz
 Summary:       OpenSSL utilities written in Perl
 Summary(pl):   Narzêdzia OpenSSL napisane w perlu
 Group:         Applications/Communications
-Group(de):     Applikationen/Kommunikation
-Group(pl):     Aplikacje/Komunikacja
 Requires:      %{name} = %{version}
 
 %description tools-perl
@@ -109,13 +87,6 @@ Summary(de):        Secure Sockets Layer Kommunikationslibrary: statische libraries+hea
 Summary(fr):   Librairies statiques, headers et utilitaires pour communication SSL
 Summary(pl):   Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
 Group:         Development/Libraries
-Group(de):     Entwicklung/Libraries
-Group(es):     Desarrollo/Bibliotecas
-Group(fr):     Development/Librairies
-Group(pl):     Programowanie/Biblioteki
-Group(pt_BR):  Desenvolvimento/Bibliotecas
-Group(ru):     òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
-Group(uk):     òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
 Requires:      %{name} = %{version}
 Obsoletes:     libopenssl0-devel
 
@@ -129,33 +100,12 @@ Cz
 Summary:       Development part of OpenSSL Toolkit embedded libraries
 Summary(pl):   Czê¶æ bibiloteki OpenSSL przeznaczona dla aplikacji wbudowanych
 Group:         Development/Libraries
-Group(de):     Entwicklung/Libraries
-Group(es):     Desarrollo/Bibliotecas
-Group(fr):     Development/Librairies
-Group(pl):     Programowanie/Biblioteki
-Group(pt_BR):  Desenvolvimento/Bibliotecas
-Group(ru):     òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
-Group(uk):     òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
 Requires:      %{name} = %{version}
 
-%description devel-embed
-Development part of OpenSSL library for embedded applications.
-
-%description devel-embed -l pl
-Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów aplikacji
-wbudowanych.
-
 %package static
 Summary:       Static OpenSSL libraries
 Summary(pl):   Statyczne wersje bibliotek z OpenSSL
 Group:         Development/Libraries
-Group(de):     Entwicklung/Libraries
-Group(es):     Desarrollo/Bibliotecas
-Group(fr):     Development/Librairies
-Group(pl):     Programowanie/Biblioteki
-Group(pt_BR):  Desenvolvimento/Bibliotecas
-Group(ru):     òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
-Group(uk):     òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
 Requires:      %{name}-devel = %{version}
 
 %description static
@@ -172,8 +122,8 @@ Statyczne wersje bibliotek z OpenSSL.
 %patch3 -p1
 
 %build
-for f in ` grep -r "/usr/local/bin/perl" . | cut -d":" -f1`; do
-       perl -pi -e 's#/usr/local/bin/perl#%{_bindir}/perl#g' $f
+for f in ` grep -r "%{_prefix}/local/bin/perl" . | cut -d":" -f1`; do
+perl -pi -e 's#%{_prefix}/local/bin/perl#%{_bindir}/perl#g' $f
 done
 
 touch Makefile.*
@@ -198,15 +148,6 @@ export OPTFLAGS
 ./Configure --openssldir=%{_var}/lib/%{name} threads linux-sparcv8 shared
 %endif
 
-%if %{!?_without_embed:1}%{?_without_embed:0}
-%{__make} CC=%{embed_cc}
-%{__make} rehash CC=%{embed_cc}
-for f in RSAglue crypto ssl ; do
-       mv -f lib$f.a lib$f.a-embed
-done
-%{__make} clean
-%endif
-
 %{__make}
 %{__make} rehash
 
@@ -291,15 +232,6 @@ install doc/apps/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
 install doc/ssl/*.3 doc/crypto/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
 install doc/crypto/*.7 $RPM_BUILD_ROOT%{_mandir}/man7
 
-%if %{!?_without_embed:1}%{?_without_embed:0}
-install -d $RPM_BUILD_ROOT%{uclibc_prefix}/{include,lib}
-for f in RSAglue crypto ssl ; do
-       install lib$f.a-embed $RPM_BUILD_ROOT%{uclibc_prefix}/lib/lib$f.a
-done
-cp -a $RPM_BUILD_ROOT%{_includedir}/%{name} \
-       $RPM_BUILD_ROOT%{uclibc_prefix}/include
-%endif
-
 gzip -9nf CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
 
 %post   -p /sbin/ldconfig
@@ -376,13 +308,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/%{name}
 %{_mandir}/man3/*.3*
 
-%if %{!?_without_embed:1}%{?_without_embed:0}
-%files devel-embed
-%defattr(644,root,root,755)
-%{uclibc_prefix}/lib/*
-%{uclibc_prefix}/include/%{name}
-%endif
-
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
This page took 0.034125 seconds and 4 git commands to generate.