]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- athlon updates
[packages/openssl.git] / openssl.spec
index 506cc597e7e8ba125bb00a6d5870a8d668eb4db5..cb113e21675fb3eb18fd6d6edfded425415d8277 100644 (file)
@@ -1,10 +1,12 @@
+# conditional build:
+# _without_embed - don't build uClibc version
 %include       /usr/lib/rpm/macros.perl
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
 Summary(de):   Secure Sockets Layer (SSL)-Kommunikationslibrary
 Summary(fr):   Utilitaires de communication SSL (Secure Sockets Layer)
 Name:          openssl
 Version:       0.9.6b
-Release:       5
+Release:       6
 License:       Apache-style License
 Vendor:                The OpenSSL Project
 Group:         Libraries
@@ -21,12 +23,21 @@ Patch2:             %{name}-optflags.patch
 Patch3:                %{name}-nocrypt.patch
 BuildRequires: perl-devel >= 5.6.1
 BuildRequires: textutils
+%if %{!?_without_embed:1}%{?_without_embed:0}
+BuildRequires: uClibc-devel
+BuildRequires: uClibc-static
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
 Obsoletes:     SSLeay-perl
 Obsoletes:     libopenssl0
 
+%define embed_path     /usr/lib/embed
+%define embed_cc       %{_arch}-uclibc-cc
+%define embed_cflags   %{rpmcflags} -Os
+%define uclibc_prefix  /usr/%{_arch}-linux-uclibc
+
 %description
 The OpenSSL Project is a collaborative effort to develop a robust,
 commercial-grade, full-featured, and Open Source toolkit implementing
@@ -95,6 +106,22 @@ Development part of OpenSSL library.
 %description devel -l pl
 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
 
+%package devel-embed
+Summary:       Development part of OpenSSL Toolkit embedded libraries
+Summary(pl):   Czê¶æ bibiloteki OpenSSL przeznaczona dla aplikacji wbudowanych
+Group:         Development/Libraries
+Group(de):     Entwicklung/Libraries
+Group(fr):     Development/Librairies
+Group(pl):     Programowanie/Biblioteki
+Requires:      %{name} = %{version}
+
+%description devel-embed
+Development part of OpenSSL library for embedded applications.
+
+%description -l pl devel-embed
+Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów aplikacji
+wbudowanych.
+
 %package static
 Summary:       Static OpenSSL libraries
 Summary(pl):   Statyczne wersje bibliotek z OpenSSL
@@ -131,7 +158,7 @@ export OPTFLAGS
 %ifarch i386 i486
 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared 386
 %endif
-%ifarch i586 i686
+%ifarch i586 i686 athlon
 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared
 %endif
 %ifarch ppc
@@ -144,6 +171,15 @@ export OPTFLAGS
 ./Configure --openssldir=%{_var}/lib/%{name} threads linux-sparcv8 shared
 %endif
 
+%if %{!?_without_embed:1}%{?_without_embed:0}
+%{__make} CC=%{embed_cc}
+%{__make} rehash CC=%{embed_cc}
+for f in RSAglue crypto ssl ; do
+       mv -f lib$f.a lib$f.a-embed
+done
+%{__make} clean
+%endif
+
 %{__make}
 %{__make} rehash
 
@@ -228,6 +264,15 @@ install doc/apps/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
 install doc/ssl/*.3 doc/crypto/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
 install doc/crypto/*.7 $RPM_BUILD_ROOT%{_mandir}/man7
 
+%if %{!?_without_embed:1}%{?_without_embed:0}
+install -d $RPM_BUILD_ROOT%{uclibc_prefix}/{include,lib}
+for f in RSAglue crypto ssl ; do
+       install lib$f.a-embed $RPM_BUILD_ROOT%{uclibc_prefix}/lib/lib$f.a
+done
+cp -a $RPM_BUILD_ROOT%{_includedir}/%{name} \
+       $RPM_BUILD_ROOT%{uclibc_prefix}/include
+%endif
+
 gzip -9nf CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
 
 %post   -p /sbin/ldconfig
@@ -304,6 +349,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/%{name}
 %{_mandir}/man3/*.3*
 
+%if %{!?_without_embed:1}%{?_without_embed:0}
+%files devel-embed
+%defattr(644,root,root,755)
+%{uclibc_prefix}/lib/*
+%{uclibc_prefix}/include/%{name}
+%endif
+
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
This page took 0.066044 seconds and 4 git commands to generate.