]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- fix build on 64bit archs, pkgconfig fixes in patch
[packages/openssl.git] / openssl.spec
index a03868deea2ed255b3e9515ecb0d825922e62857..c93e2436e513e15344d49009bb87b1931b424ba5 100644 (file)
@@ -1,3 +1,7 @@
+#
+# Conditional build:
+%bcond_with purify     # Compile openssl with \-DPURIFY, useful when one wants to
+                       # use valgrind debugger against openssl-linked programs
 %include       /usr/lib/rpm/macros.perl
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
 Summary(de):   Secure Sockets Layer (SSL)-Kommunikationslibrary
@@ -8,28 +12,31 @@ Summary(pt_BR):      Uma biblioteca C que fornece v
 Summary(ru):   âÉÂÌÉÏÔÅËÉ É ÕÔÉÌÉÔÙ ÄÌÑ ÓÏÅÄÉÎÅÎÉÊ ÞÅÒÅÚ Secure Sockets Layer
 Summary(uk):   â¦Â̦ÏÔÅËÉ ÔÁ ÕÔÉ̦ÔÉ ÄÌÑ Ú'¤ÄÎÁÎØ ÞÅÒÅÚ Secure Sockets Layer
 Name:          openssl
-Version:       0.9.7c
+Version:       0.9.8b
 Release:       1
 License:       Apache-style License
 Group:         Libraries
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: c54fb36218adaaaba01ef733cd88c8ec
+# Source0-md5: 12cedbeb6813a0d7919dbf1f82134b86
 Source1:       %{name}-ca-bundle.crt
 Source2:       %{name}.1.pl
+Source3:       %{name}-ssl-certificate.sh
 Patch0:                %{name}-alpha-ccc.patch
 Patch1:                %{name}-optflags.patch
 Patch2:                %{name}-globalCA.diff
-Patch3:                %{name}-parallel_make.patch
-Patch4:                %{name}-include.patch
-Patch5:         %{name}-makefile.patch
+Patch3:                %{name}-include.patch
+Patch4:                %{name}-md5-sparcv9.patch
+Patch5:                %{name}-libvar.patch
 URL:           http://www.openssl.org/
-BuildRequires: perl-devel >= 5.6.1
-BuildRequires: textutils
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+BuildRequires: perl-devel >= 1:5.6.1
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.213
+BuildRequires: sed >= 4.0
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
 Obsoletes:     SSLeay-perl
 Obsoletes:     libopenssl0
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 The OpenSSL Project is a collaborative effort to develop a robust,
@@ -86,7 +93,7 @@ RC4, RSA 
 Summary:       OpenSSL command line tool and utilities
 Summary(pl):   Zestaw narzêdzi i skryptów
 Group:         Applications/Communications
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description tools
 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
@@ -98,7 +105,7 @@ Zestaw narz
 Summary:       OpenSSL utilities written in Perl
 Summary(pl):   Narzêdzia OpenSSL napisane w perlu
 Group:         Applications/Communications
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description tools-perl
 OpenSSL Toolkit tools written in Perl.
@@ -116,7 +123,7 @@ Summary(pt_BR):     Bibliotecas e arquivos de inclus
 Summary(ru):   âÉÂÌÉÏÔÅËÉ, ÈÅÄÅÒÙ É ÕÔÉÌÉÔÙ ÄÌÑ Secure Sockets Layer
 Summary(uk):   â¦Â̦ÏÔÅËÉ, ÈÅÄÅÒÉ ÔÁ ÕÔÉ̦ÔÉ ÄÌÑ Secure Sockets Layer
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Obsoletes:     libopenssl0-devel
 
 %description devel
@@ -126,7 +133,7 @@ Development part of OpenSSL library.
 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
 
 %description devel -l pl
-Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
+Czê¶æ biblioteki OpenSSL przeznaczona dla programistów.
 
 %description devel -l pt_BR
 Uma biblioteca C que fornece vários algoritmos e protocolos
@@ -152,7 +159,7 @@ Summary(pt_BR):     Bibliotecas est
 Summary(ru):   óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ ÄÌÑ OpenSSL
 Summary(uk):   óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ ÄÌÑ OpenSSL
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static OpenSSL Toolkit libraries.
@@ -185,33 +192,51 @@ RC4, RSA 
 %patch5 -p1
 
 %build
-for f in ` grep -r "%{_prefix}/local/bin/perl" . | cut -d":" -f1`; do
-%{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' $f
-done
+%{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' \
+       `grep -l -r "%{_prefix}/local/bin/perl" *`
 
 touch Makefile.*
 
 %{__perl} util/perlpath.pl %{__perl}
 
-OPTFLAGS="%{rpmcflags}"
+OPTFLAGS="%{rpmcflags} %{?with_purify:-DPURIFY}"
 export OPTFLAGS
-%ifarch i386 i486
-./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared 386
+./Configure \
+       --openssldir=%{_var}/lib/%{name} \
+       --lib=%{_lib} \
+       shared threads \
+       enable-mdc2 enable-rc5 \
+%ifarch %{ix86}
+%ifarch i386
+# allow running on 80386 (default code uses bswapl available on i486+)
+       386 linux-elf
+%else
+       linux-elf
+%endif
+%endif
+%ifarch alpha
+       linux-alpha+bwx-gcc
 %endif
-%ifarch i586 i686 athlon
-./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared
+%ifarch %{x8664}
+       linux-x86_64
 %endif
-%ifarch x86_64
-./Configure --openssldir=%{_var}/lib/%{name} linux-x86_64 shared
+%ifarch ia64
+       linux-ia64
 %endif
 %ifarch ppc
-./Configure --openssldir=%{_var}/lib/%{name} linux-ppc shared
+       linux-ppc
 %endif
-%ifarch alpha
-./Configure --openssldir=%{_var}/lib/%{name} threads linux-alpha+bwx-gcc shared
+%ifarch ppc64
+       linux-ppc64
 %endif
 %ifarch sparc
-./Configure --openssldir=%{_var}/lib/%{name} threads linux-sparcv8 shared
+       linux-sparcv8
+%endif
+%ifarch sparcv9
+       linux-sparcv9
+%endif
+%ifarch sparc64
+       linux64-sparcv9
 %endif
 
 %{__make} \
@@ -278,9 +303,11 @@ done
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
-       $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl}
+       $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
+       $RPM_BUILD_ROOT%{_pkgconfigdir}
 
 %{__make} install \
+       CC="%{__cc}" \
        INSTALLTOP=%{_prefix} \
        INSTALL_PREFIX=$RPM_BUILD_ROOT \
        MANDIR=%{_mandir}
@@ -306,6 +333,7 @@ install doc/apps/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
 install doc/ssl/*.3 doc/crypto/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
 install doc/crypto/*.7 $RPM_BUILD_ROOT%{_mandir}/man7
 install %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
+install %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -315,23 +343,28 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%attr(755,root,root) %{_libdir}/libcrypto.so.*.*.*
+%attr(755,root,root) %{_libdir}/libssl.so.*.*.*
 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
 %doc doc/openssl_button.gif doc/openssl_button.html
+%dir %{_libdir}/engines
+%attr(755,root,root) %{_libdir}/engines/*.so
+%dir %{_var}/lib/%{name}
+%dir %{_var}/lib/%{name}/certs
+%dir %{_var}/lib/%{name}/private
+%dir %{_datadir}/ssl
+%verify(not md5 mtime size) %config(noreplace) %{_datadir}/ssl/ca-bundle.crt
 
 %files tools
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/%{name}
-%dir %{_var}/lib/%{name}
-%dir %{_var}/lib/%{name}/private
-%dir %{_var}/lib/%{name}/certs
 
-%verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/%{name}/openssl.cnf
-%verify(not md5 size mtime) %config(noreplace) %{_var}/lib/%{name}/openssl.cnf
-%dir %{_datadir}/ssl
-%verify(not md5 size mtime) %config(noreplace) %{_datadir}/ssl/ca-bundle.crt
+%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/%{name}/openssl.cnf
+%verify(not md5 mtime size) %config(noreplace) %{_var}/lib/%{name}/openssl.cnf
 
 %attr(755,root,root) %{_bindir}/%{name}
+%attr(754,root,root) %{_bindir}/ssl-certificate
+
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
 %attr(755,root,root) %{_libdir}/%{name}/c_hash
@@ -349,7 +382,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/openssl_dhparam.1*
 %{_mandir}/man1/openssl_dsa.1*
 %{_mandir}/man1/openssl_dsaparam.1*
+%{_mandir}/man1/openssl_ec.1*
+%{_mandir}/man1/openssl_ecparam.1*
 %{_mandir}/man1/openssl_enc.1*
+%{_mandir}/man1/openssl_errstr.1*
 %{_mandir}/man1/openssl_gendsa.1*
 %{_mandir}/man1/openssl_genrsa.1*
 %{_mandir}/man1/openssl_nseq.1*
@@ -364,6 +400,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/openssl_rsautl.1*
 %{_mandir}/man1/openssl_s_client.1*
 %{_mandir}/man1/openssl_s_server.1*
+%{_mandir}/man1/openssl_s_time.1*
 %{_mandir}/man1/openssl_sess_id.1*
 %{_mandir}/man1/openssl_smime.1*
 %{_mandir}/man1/openssl_speed.1*
@@ -371,20 +408,23 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/openssl_verify.1*
 %{_mandir}/man1/openssl_version.1*
 %{_mandir}/man1/openssl_x509.1*
+%{_mandir}/man1/openssl_x509v3_config.1*
 %{_mandir}/man5/*.5*
 %lang(pl) %{_mandir}/pl/man1/openssl.1*
 
 %files tools-perl
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
-%attr(755,root,root) %{_libdir}/%{name}/der_chop
 %attr(755,root,root) %{_libdir}/%{name}/c_rehash
 %{_mandir}/man1/openssl_CA.pl.1*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
+%attr(755,root,root) %{_libdir}/libcrypto.so
+%attr(755,root,root) %{_libdir}/libssl.so
 %{_includedir}/%{name}
+%{_pkgconfigdir}/libcrypto.pc
+%{_pkgconfigdir}/libssl.pc
 %{_pkgconfigdir}/openssl.pc
 %{_mandir}/man3/openssl*.3*
 %{_mandir}/man7/*.7*
This page took 0.034353 seconds and 4 git commands to generate.