]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- fix build on 64bit archs, pkgconfig fixes in patch
[packages/openssl.git] / openssl.spec
index 6c8ee45c505c3e089f577f7870e2c27c16db0505..c93e2436e513e15344d49009bb87b1931b424ba5 100644 (file)
@@ -1,3 +1,7 @@
+#
+# Conditional build:
+%bcond_with purify     # Compile openssl with \-DPURIFY, useful when one wants to
+                       # use valgrind debugger against openssl-linked programs
 %include       /usr/lib/rpm/macros.perl
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
 Summary(de):   Secure Sockets Layer (SSL)-Kommunikationslibrary
@@ -8,12 +12,12 @@ Summary(pt_BR):      Uma biblioteca C que fornece v
 Summary(ru):   âÉÂÌÉÏÔÅËÉ É ÕÔÉÌÉÔÙ ÄÌÑ ÓÏÅÄÉÎÅÎÉÊ ÞÅÒÅÚ Secure Sockets Layer
 Summary(uk):   â¦Â̦ÏÔÅËÉ ÔÁ ÕÔÉ̦ÔÉ ÄÌÑ Ú'¤ÄÎÁÎØ ÞÅÒÅÚ Secure Sockets Layer
 Name:          openssl
-Version:       0.9.7g
+Version:       0.9.8b
 Release:       1
 License:       Apache-style License
 Group:         Libraries
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: 991615f73338a571b6a1be7d74906934
+# Source0-md5: 12cedbeb6813a0d7919dbf1f82134b86
 Source1:       %{name}-ca-bundle.crt
 Source2:       %{name}.1.pl
 Source3:       %{name}-ssl-certificate.sh
@@ -22,10 +26,12 @@ Patch1:             %{name}-optflags.patch
 Patch2:                %{name}-globalCA.diff
 Patch3:                %{name}-include.patch
 Patch4:                %{name}-md5-sparcv9.patch
-Patch5:                %{name}-ssl-algs.patch
+Patch5:                %{name}-libvar.patch
 URL:           http://www.openssl.org/
 BuildRequires: perl-devel >= 1:5.6.1
 BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.213
+BuildRequires: sed >= 4.0
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
 Obsoletes:     SSLeay-perl
@@ -185,10 +191,6 @@ RC4, RSA 
 %patch4 -p1
 %patch5 -p1
 
-# conflicts with i386-only DES implementation
-# (missing #ifdef OPENSSL_FIPS  ...  #endif)
-:> fips/des/asm/fips-dx86-elf.s
-
 %build
 %{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' \
        `grep -l -r "%{_prefix}/local/bin/perl" *`
@@ -197,36 +199,44 @@ touch Makefile.*
 
 %{__perl} util/perlpath.pl %{__perl}
 
-OPTFLAGS="%{rpmcflags}"
+OPTFLAGS="%{rpmcflags} %{?with_purify:-DPURIFY}"
 export OPTFLAGS
+./Configure \
+       --openssldir=%{_var}/lib/%{name} \
+       --lib=%{_lib} \
+       shared threads \
+       enable-mdc2 enable-rc5 \
 %ifarch %{ix86}
 %ifarch i386
 # allow running on 80386 (default code uses bswapl available on i486+)
-./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared 386
+       386 linux-elf
 %else
-./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared
+       linux-elf
 %endif
 %endif
 %ifarch alpha
-./Configure --openssldir=%{_var}/lib/%{name} threads linux-alpha+bwx-gcc shared
+       linux-alpha+bwx-gcc
 %endif
-%ifarch amd64
-./Configure --openssldir=%{_var}/lib/%{name} linux-x86_64 shared
+%ifarch %{x8664}
+       linux-x86_64
 %endif
 %ifarch ia64
-./Configure --openssldir=%{_var}/lib/%{name} linux-ia64 shared
+       linux-ia64
 %endif
 %ifarch ppc
-./Configure --openssldir=%{_var}/lib/%{name} linux-ppc shared
+       linux-ppc
+%endif
+%ifarch ppc64
+       linux-ppc64
 %endif
 %ifarch sparc
-./Configure --openssldir=%{_var}/lib/%{name} threads linux-sparcv8 shared
+       linux-sparcv8
 %endif
 %ifarch sparcv9
-./Configure --openssldir=%{_var}/lib/%{name} threads linux-sparcv9 shared
+       linux-sparcv9
 %endif
 %ifarch sparc64
-./Configure --openssldir=%{_var}/lib/%{name} threads linux64-sparcv9 shared
+       linux64-sparcv9
 %endif
 
 %{__make} \
@@ -302,11 +312,6 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
        INSTALL_PREFIX=$RPM_BUILD_ROOT \
        MANDIR=%{_mandir}
 
-if [ "%{_prefix}/lib/pkgconfig" != "%{_pkgconfigdir}" ] ; then
-       mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* \
-               $RPM_BUILD_ROOT%{_pkgconfigdir}
-fi
-
 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/ssl/ca-bundle.crt
 install libcrypto.a libssl.a $RPM_BUILD_ROOT%{_libdir}
 install lib*.so.*.* $RPM_BUILD_ROOT%{_libdir}
@@ -329,7 +334,7 @@ install doc/ssl/*.3 doc/crypto/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
 install doc/crypto/*.7 $RPM_BUILD_ROOT%{_mandir}/man7
 install %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
 install %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
-install fips/openssl_fips_fingerprint $RPM_BUILD_ROOT%{_bindir}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -338,24 +343,26 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%attr(755,root,root) %{_libdir}/libcrypto.so.*.*.*
+%attr(755,root,root) %{_libdir}/libssl.so.*.*.*
 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
 %doc doc/openssl_button.gif doc/openssl_button.html
+%dir %{_libdir}/engines
+%attr(755,root,root) %{_libdir}/engines/*.so
 %dir %{_var}/lib/%{name}
 %dir %{_var}/lib/%{name}/certs
 %dir %{_var}/lib/%{name}/private
+%dir %{_datadir}/ssl
+%verify(not md5 mtime size) %config(noreplace) %{_datadir}/ssl/ca-bundle.crt
 
 %files tools
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/%{name}
 
-%verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/%{name}/openssl.cnf
-%verify(not md5 size mtime) %config(noreplace) %{_var}/lib/%{name}/openssl.cnf
-%dir %{_datadir}/ssl
-%verify(not md5 size mtime) %config(noreplace) %{_datadir}/ssl/ca-bundle.crt
+%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/%{name}/openssl.cnf
+%verify(not md5 mtime size) %config(noreplace) %{_var}/lib/%{name}/openssl.cnf
 
 %attr(755,root,root) %{_bindir}/%{name}
-%attr(755,root,root) %{_bindir}/openssl_fips_fingerprint
 %attr(754,root,root) %{_bindir}/ssl-certificate
 
 %dir %{_libdir}/%{name}
@@ -375,6 +382,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/openssl_dhparam.1*
 %{_mandir}/man1/openssl_dsa.1*
 %{_mandir}/man1/openssl_dsaparam.1*
+%{_mandir}/man1/openssl_ec.1*
+%{_mandir}/man1/openssl_ecparam.1*
 %{_mandir}/man1/openssl_enc.1*
 %{_mandir}/man1/openssl_errstr.1*
 %{_mandir}/man1/openssl_gendsa.1*
@@ -399,6 +408,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/openssl_verify.1*
 %{_mandir}/man1/openssl_version.1*
 %{_mandir}/man1/openssl_x509.1*
+%{_mandir}/man1/openssl_x509v3_config.1*
 %{_mandir}/man5/*.5*
 %lang(pl) %{_mandir}/pl/man1/openssl.1*
 
@@ -410,8 +420,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
+%attr(755,root,root) %{_libdir}/libcrypto.so
+%attr(755,root,root) %{_libdir}/libssl.so
 %{_includedir}/%{name}
+%{_pkgconfigdir}/libcrypto.pc
+%{_pkgconfigdir}/libssl.pc
 %{_pkgconfigdir}/openssl.pc
 %{_mandir}/man3/openssl*.3*
 %{_mandir}/man7/*.7*
This page took 0.063286 seconds and 4 git commands to generate.