]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- fixed and updated optflags patch
[packages/openssl.git] / openssl.spec
index 92d792cb126e17df1fc55a235731b5816d6e8eb4..ba10ef4d94dd98b437b37fd2989ee7b7d80698d2 100644 (file)
@@ -1,4 +1,6 @@
 #
 #
+# TODO: consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
+#
 # Conditional build:
 %bcond_without tests   # don't perform "make tests"
 %bcond_with    purify  # Compile openssl with \-DPURIFY, useful when one wants to
 # Conditional build:
 %bcond_without tests   # don't perform "make tests"
 %bcond_with    purify  # Compile openssl with \-DPURIFY, useful when one wants to
@@ -14,12 +16,12 @@ Summary(pt_BR.UTF-8):       Uma biblioteca C que fornece vários algoritmos e protocol
 Summary(ru.UTF-8):     Библиотеки и утилиты для соединений через Secure Sockets Layer
 Summary(uk.UTF-8):     Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
 Name:          openssl
 Summary(ru.UTF-8):     Библиотеки и утилиты для соединений через Secure Sockets Layer
 Summary(uk.UTF-8):     Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
 Name:          openssl
-Version:       1.0.0
-Release:       2
+Version:       1.0.1c
+Release:       1
 License:       Apache-like
 Group:         Libraries
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
 License:       Apache-like
 Group:         Libraries
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: 89eaa86e25b2845f920ec00ae4c864ed
+# Source0-md5: ae412727c8c15b67880aef7bd2999b2e
 Source2:       %{name}.1.pl
 Source3:       %{name}-ssl-certificate.sh
 Source4:       %{name}-c_rehash.sh
 Source2:       %{name}.1.pl
 Source3:       %{name}-ssl-certificate.sh
 Source4:       %{name}-c_rehash.sh
@@ -30,8 +32,7 @@ Patch3:               %{name}-include.patch
 Patch4:                %{name}-man-namespace.patch
 Patch5:                %{name}-asflag.patch
 Patch6:                %{name}-ca-certificates.patch
 Patch4:                %{name}-man-namespace.patch
 Patch5:                %{name}-asflag.patch
 Patch6:                %{name}-ca-certificates.patch
-Patch7:                %{name}-fips_install.patch
-Patch8:                %{name}-ldflags.patch
+Patch7:                %{name}-ldflags.patch
 URL:           http://www.openssl.org/
 BuildRequires: bc
 BuildRequires: perl-devel >= 1:5.6.1
 URL:           http://www.openssl.org/
 BuildRequires: bc
 BuildRequires: perl-devel >= 1:5.6.1
@@ -97,6 +98,48 @@ RC4, RSA и SSL.
 користування, що реалізують велику кількість криптографічних
 алгоритмів, включаючи DES, RC4, RSA та SSL.
 
 користування, що реалізують велику кількість криптографічних
 алгоритмів, включаючи DES, RC4, RSA та SSL.
 
+%package engines
+Summary:       OpenSSL optional crypto engines
+Summary(pl.UTF-8):     Opcjonalne silniki kryptograficzne dla OpenSSL-a
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description engines
+With OpenSSL 0.9.6, a new component was added to support alternative
+cryptography implementations, most commonly for interfacing with
+external crypto devices (eg. accelerator cards). This component is
+called ENGINE.
+
+There are currently built-in ENGINE implementations for the following
+crypto devices:
+
+- CryptoSwift
+- Compaq Atalla
+- nCipher CHIL
+- Nuron
+- Broadcom uBSec
+
+In addition, dynamic binding to external ENGINE implementations is now
+provided by a special ENGINE called "dynamic". 
+
+%description engines -l pl.UTF-8
+Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
+wspierać alternatywne implementacje kryptografii, przeważnie
+współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
+kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM
+(ang. ENGINE).
+
+Obecnie istnieją wbudowane implementacje silników dla następujących
+urządzeń kryptograficznych:
+- CryptoSwift
+- Compaq Atalla
+- nCipher CHIL
+- Nuron
+- Broadcom uBSec
+
+Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
+implementacji silników poprzez specjalny silnik o nazwie "dynamic".
+
 %package tools
 Summary:       OpenSSL command line tool and utilities
 Summary(pl.UTF-8):     Zestaw narzędzi i skryptów
 %package tools
 Summary:       OpenSSL command line tool and utilities
 Summary(pl.UTF-8):     Zestaw narzędzi i skryptów
@@ -193,38 +236,38 @@ RC4, RSA и SSL. Включает статические библиотеки д
 
 %prep
 %setup -q
 
 %prep
 %setup -q
-#%patch0 -p1
-#%patch1 -p1
+%patch0 -p1
+%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch2 -p1
 %patch3 -p1
-#%patch4 -p1
-#%patch5 -p1
+%patch4 -p1
+%patch5 -p1
 %patch6 -p1
 %patch6 -p1
-#%patch7 -p1
-#%patch8 -p1
+%patch7 -p1
 
 
-%{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' \
-       `grep -l -r "%{_prefix}/local/bin/perl" *`
-
-sed -i -e 's|$prefix/lib/engines|/%{_lib}/engines|g' Configure
+sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
 
 %build
 touch Makefile.*
 
 %{__perl} util/perlpath.pl %{__perl}
 
 
 %build
 touch Makefile.*
 
 %{__perl} util/perlpath.pl %{__perl}
 
-OPTFLAGS="%{rpmcflags} %{?with_purify:-DPURIFY}" \
-./Configure \
+OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
+PERL="%{__perl}" \
+%{__perl} ./Configure \
 %if "%{pld_release}" == "ti"
        --openssldir=%{_var}/lib/%{name} \
 %else
        --openssldir=%{_sysconfdir}/%{name} \
 %endif
        --libdir=%{_lib} \
 %if "%{pld_release}" == "ti"
        --openssldir=%{_var}/lib/%{name} \
 %else
        --openssldir=%{_sysconfdir}/%{name} \
 %endif
        --libdir=%{_lib} \
-       shared threads \
+       shared \
+       threads \
+       zlib \
        enable-tlsext \
        enable-seed \
        enable-rfc3779 \
        enable-tlsext \
        enable-seed \
        enable-rfc3779 \
+       enable-camelia \
        enable-cms \
        enable-idea \
        enable-mdc2 \
        enable-cms \
        enable-idea \
        enable-mdc2 \
@@ -262,10 +305,13 @@ OPTFLAGS="%{rpmcflags} %{?with_purify:-DPURIFY}" \
 %ifarch sparc64
        linux64-sparcv9
 %endif
 %ifarch sparc64
        linux64-sparcv9
 %endif
+%ifarch armv4 armv5 armv5t armv5te armv5tel
+       linux-armv4
+%endif
 
 %{__make} -j1 all rehash %{?with_tests:tests} \
        CC="%{__cc}" \
 
 %{__make} -j1 all rehash %{?with_tests:tests} \
        CC="%{__cc}" \
-       ASFLAG='$(CFLAG) -c -Wa,--noexecstack' \
+       ASFLAG='$(CFLAG) -Wa,--noexecstack' \
        INSTALLTOP=%{_prefix}
 
 # Rename POD sources of man pages. "openssl_" prefix is added to each
        INSTALLTOP=%{_prefix}
 
 # Rename POD sources of man pages. "openssl_" prefix is added to each
@@ -293,8 +339,8 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
        INSTALL_PREFIX=$RPM_BUILD_ROOT \
        MANDIR=%{_mandir}
 
        INSTALL_PREFIX=$RPM_BUILD_ROOT \
        MANDIR=%{_mandir}
 
-mv -f $RPM_BUILD_ROOT/%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
-mv -f $RPM_BUILD_ROOT/%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
+mv -f $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
+mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
 
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
 
@@ -315,27 +361,20 @@ rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
 # not installed as individual utilities (see openssl dgst instead)
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{md2,md4,md5,mdc2,ripemd160,sha,sha1}.1
 
 # not installed as individual utilities (see openssl dgst instead)
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{md2,md4,md5,mdc2,ripemd160,sha,sha1}.1
 
-cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
 
 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
 
-for mtype in man1 man3 man5 man7; do
-       for man in $RPM_BUILD_ROOT%{_mandir}/${mtype}/*.[0-9]; do
-               b=$(readlink "$man" || :)
-               [ -z "$b" ] && continue
-               # delete manual pages pointing to nowhere
-               [ ! -f "$RPM_BUILD_ROOT%{_mandir}/${mtype}/$b" ] && rm "$man"
-               # delete manual pages pointing to openssl_ prefixed man page
-               echo "$b" | grep -q "^openssl_" && rm "$man"
-       done
-done
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
+%triggerpostun -- %{name}-tools < 1.0.0-5
+# the hashing format has changed in 1.0.0
+[ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
+
 %if "%{pld_release}" == "ti"
 %triggerin -- %{name}-tools < 0.9.8i-2
 if [ -L /var/lib/openssl/openssl.cnf ] ; then
 %if "%{pld_release}" == "ti"
 %triggerin -- %{name}-tools < 0.9.8i-2
 if [ -L /var/lib/openssl/openssl.cnf ] ; then
@@ -345,6 +384,10 @@ if [ -L /var/lib/openssl/openssl.cnf ] ; then
 fi
 %else
 %triggerpostun -- %{name} < 0.9.8i-2
 fi
 %else
 %triggerpostun -- %{name} < 0.9.8i-2
+# don't do anything on --downgrade
+if [ $1 -le 1 ]; then
+       exit 0
+fi
 if [ -d /var/lib/openssl/certs ] ; then
        mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
 fi
 if [ -d /var/lib/openssl/certs ] ; then
        mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
 fi
@@ -355,6 +398,8 @@ if [ -d /var/lib/openssl ] ; then
        for f in /var/lib/openssl/* ; do
                [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
        done
        for f in /var/lib/openssl/* ; do
                [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
        done
+       rmdir /var/lib/openssl/* 2>/dev/null || :
+       rmdir /var/lib/openssl 2>/dev/null || :
 fi
 %endif
 
 fi
 %endif
 
@@ -364,8 +409,6 @@ fi
 %doc doc/openssl_button.gif doc/openssl_button.html
 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
 %doc doc/openssl_button.gif doc/openssl_button.html
 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
-%dir /%{_lib}/engines
-%attr(755,root,root) /%{_lib}/engines/*.so
 %if "%{pld_release}" == "ti"
 %dir %{_var}/lib/%{name}
 %dir %{_var}/lib/%{name}/certs
 %if "%{pld_release}" == "ti"
 %dir %{_var}/lib/%{name}
 %dir %{_var}/lib/%{name}/certs
@@ -380,6 +423,10 @@ fi
 %endif
 %dir %{_datadir}/ssl
 
 %endif
 %dir %{_datadir}/ssl
 
+%files engines
+%dir /%{_lib}/engines
+%attr(755,root,root) /%{_lib}/engines/*.so
+
 %files tools
 %defattr(644,root,root,755)
 %if "%{pld_release}" == "ti"
 %files tools
 %defattr(644,root,root,755)
 %if "%{pld_release}" == "ti"
@@ -388,8 +435,8 @@ fi
 %else
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
 %endif
 %else
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
 %endif
-%attr(755,root,root) %{_bindir}/%{name}
 %attr(755,root,root) %{_bindir}/c_rehash.sh
 %attr(755,root,root) %{_bindir}/c_rehash.sh
+%attr(755,root,root) %{_bindir}/openssl
 %attr(754,root,root) %{_bindir}/ssl-certificate
 
 %dir %{_libdir}/%{name}
 %attr(754,root,root) %{_bindir}/ssl-certificate
 
 %dir %{_libdir}/%{name}
@@ -398,7 +445,6 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/c_info
 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
 %attr(755,root,root) %{_libdir}/%{name}/c_name
 %attr(755,root,root) %{_libdir}/%{name}/c_info
 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
 %attr(755,root,root) %{_libdir}/%{name}/c_name
-%attr(755,root,root) %{_libdir}/%{name}/tsget
 
 %{_mandir}/man1/openssl.1*
 %{_mandir}/man1/openssl_asn1parse.1*
 
 %{_mandir}/man1/openssl.1*
 %{_mandir}/man1/openssl_asn1parse.1*
@@ -414,9 +460,9 @@ fi
 %{_mandir}/man1/openssl_ec.1*
 %{_mandir}/man1/openssl_ecparam.1*
 %{_mandir}/man1/openssl_enc.1*
 %{_mandir}/man1/openssl_ec.1*
 %{_mandir}/man1/openssl_ecparam.1*
 %{_mandir}/man1/openssl_enc.1*
-%{_mandir}/man1/openssl_*pkey*.1*
 %{_mandir}/man1/openssl_errstr.1*
 %{_mandir}/man1/openssl_gendsa.1*
 %{_mandir}/man1/openssl_errstr.1*
 %{_mandir}/man1/openssl_gendsa.1*
+%{_mandir}/man1/openssl_genpkey.1*
 %{_mandir}/man1/openssl_genrsa.1*
 %{_mandir}/man1/openssl_nseq.1*
 %{_mandir}/man1/openssl_ocsp.1*
 %{_mandir}/man1/openssl_genrsa.1*
 %{_mandir}/man1/openssl_nseq.1*
 %{_mandir}/man1/openssl_ocsp.1*
@@ -424,6 +470,9 @@ fi
 %{_mandir}/man1/openssl_pkcs12.1*
 %{_mandir}/man1/openssl_pkcs7.1*
 %{_mandir}/man1/openssl_pkcs8.1*
 %{_mandir}/man1/openssl_pkcs12.1*
 %{_mandir}/man1/openssl_pkcs7.1*
 %{_mandir}/man1/openssl_pkcs8.1*
+%{_mandir}/man1/openssl_pkey.1*
+%{_mandir}/man1/openssl_pkeyparam.1*
+%{_mandir}/man1/openssl_pkeyutl.1*
 %{_mandir}/man1/openssl_rand.1*
 %{_mandir}/man1/openssl_req.1*
 %{_mandir}/man1/openssl_rsa.1*
 %{_mandir}/man1/openssl_rand.1*
 %{_mandir}/man1/openssl_req.1*
 %{_mandir}/man1/openssl_rsa.1*
@@ -448,6 +497,7 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/c_rehash
 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/c_rehash
 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
+%attr(755,root,root) %{_libdir}/%{name}/tsget
 %{_mandir}/man1/openssl_CA.pl.1*
 
 %files devel
 %{_mandir}/man1/openssl_CA.pl.1*
 
 %files devel
@@ -463,4 +513,5 @@ fi
 
 %files static
 %defattr(644,root,root,755)
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libcrypto.a
+%{_libdir}/libssl.a
This page took 0.033931 seconds and 4 git commands to generate.