]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- fixed and updated optflags patch
[packages/openssl.git] / openssl.spec
index 6dfd7606a9e6e190a7d813a4a29a41fe97cb0be4..ba10ef4d94dd98b437b37fd2989ee7b7d80698d2 100644 (file)
@@ -16,12 +16,12 @@ Summary(pt_BR.UTF-8):       Uma biblioteca C que fornece vários algoritmos e protocol
 Summary(ru.UTF-8):     Библиотеки и утилиты для соединений через Secure Sockets Layer
 Summary(uk.UTF-8):     Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
 Name:          openssl
-Version:       1.0.0
-Release:       6
+Version:       1.0.1c
+Release:       1
 License:       Apache-like
 Group:         Libraries
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: 89eaa86e25b2845f920ec00ae4c864ed
+# Source0-md5: ae412727c8c15b67880aef7bd2999b2e
 Source2:       %{name}.1.pl
 Source3:       %{name}-ssl-certificate.sh
 Source4:       %{name}-c_rehash.sh
@@ -98,6 +98,48 @@ RC4, RSA и SSL.
 користування, що реалізують велику кількість криптографічних
 алгоритмів, включаючи DES, RC4, RSA та SSL.
 
+%package engines
+Summary:       OpenSSL optional crypto engines
+Summary(pl.UTF-8):     Opcjonalne silniki kryptograficzne dla OpenSSL-a
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description engines
+With OpenSSL 0.9.6, a new component was added to support alternative
+cryptography implementations, most commonly for interfacing with
+external crypto devices (eg. accelerator cards). This component is
+called ENGINE.
+
+There are currently built-in ENGINE implementations for the following
+crypto devices:
+
+- CryptoSwift
+- Compaq Atalla
+- nCipher CHIL
+- Nuron
+- Broadcom uBSec
+
+In addition, dynamic binding to external ENGINE implementations is now
+provided by a special ENGINE called "dynamic". 
+
+%description engines -l pl.UTF-8
+Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
+wspierać alternatywne implementacje kryptografii, przeważnie
+współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
+kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM
+(ang. ENGINE).
+
+Obecnie istnieją wbudowane implementacje silników dla następujących
+urządzeń kryptograficznych:
+- CryptoSwift
+- Compaq Atalla
+- nCipher CHIL
+- Nuron
+- Broadcom uBSec
+
+Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
+implementacji silników poprzez specjalny silnik o nazwie "dynamic".
+
 %package tools
 Summary:       OpenSSL command line tool and utilities
 Summary(pl.UTF-8):     Zestaw narzędzi i skryptów
@@ -203,9 +245,6 @@ RC4, RSA и SSL. Включает статические библиотеки д
 %patch6 -p1
 %patch7 -p1
 
-%{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' \
-       `grep -l -r "%{_prefix}/local/bin/perl" *`
-
 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
 
 %build
@@ -213,18 +252,22 @@ touch Makefile.*
 
 %{__perl} util/perlpath.pl %{__perl}
 
-OPTFLAGS="%{rpmcflags} %{?with_purify:-DPURIFY}" \
-./Configure \
+OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
+PERL="%{__perl}" \
+%{__perl} ./Configure \
 %if "%{pld_release}" == "ti"
        --openssldir=%{_var}/lib/%{name} \
 %else
        --openssldir=%{_sysconfdir}/%{name} \
 %endif
        --libdir=%{_lib} \
-       shared threads \
+       shared \
+       threads \
+       zlib \
        enable-tlsext \
        enable-seed \
        enable-rfc3779 \
+       enable-camelia \
        enable-cms \
        enable-idea \
        enable-mdc2 \
@@ -262,6 +305,9 @@ OPTFLAGS="%{rpmcflags} %{?with_purify:-DPURIFY}" \
 %ifarch sparc64
        linux64-sparcv9
 %endif
+%ifarch armv4 armv5 armv5t armv5te armv5tel
+       linux-armv4
+%endif
 
 %{__make} -j1 all rehash %{?with_tests:tests} \
        CC="%{__cc}" \
@@ -315,7 +361,7 @@ rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
 # not installed as individual utilities (see openssl dgst instead)
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{md2,md4,md5,mdc2,ripemd160,sha,sha1}.1
 
-cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
 
@@ -338,6 +384,10 @@ if [ -L /var/lib/openssl/openssl.cnf ] ; then
 fi
 %else
 %triggerpostun -- %{name} < 0.9.8i-2
+# don't do anything on --downgrade
+if [ $1 -le 1 ]; then
+       exit 0
+fi
 if [ -d /var/lib/openssl/certs ] ; then
        mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
 fi
@@ -348,6 +398,8 @@ if [ -d /var/lib/openssl ] ; then
        for f in /var/lib/openssl/* ; do
                [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
        done
+       rmdir /var/lib/openssl/* 2>/dev/null || :
+       rmdir /var/lib/openssl 2>/dev/null || :
 fi
 %endif
 
@@ -357,8 +409,6 @@ fi
 %doc doc/openssl_button.gif doc/openssl_button.html
 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
-%dir /%{_lib}/engines
-%attr(755,root,root) /%{_lib}/engines/*.so
 %if "%{pld_release}" == "ti"
 %dir %{_var}/lib/%{name}
 %dir %{_var}/lib/%{name}/certs
@@ -373,6 +423,10 @@ fi
 %endif
 %dir %{_datadir}/ssl
 
+%files engines
+%dir /%{_lib}/engines
+%attr(755,root,root) /%{_lib}/engines/*.so
+
 %files tools
 %defattr(644,root,root,755)
 %if "%{pld_release}" == "ti"
@@ -391,7 +445,6 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/c_info
 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
 %attr(755,root,root) %{_libdir}/%{name}/c_name
-%attr(755,root,root) %{_libdir}/%{name}/tsget
 
 %{_mandir}/man1/openssl.1*
 %{_mandir}/man1/openssl_asn1parse.1*
@@ -444,6 +497,7 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/c_rehash
 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
+%attr(755,root,root) %{_libdir}/%{name}/tsget
 %{_mandir}/man1/openssl_CA.pl.1*
 
 %files devel
@@ -459,4 +513,5 @@ fi
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libcrypto.a
+%{_libdir}/libssl.a
This page took 0.065135 seconds and 4 git commands to generate.