]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- fix for CVE-2007-3108
[packages/openssl.git] / openssl.spec
index d951b8bb89dd720f3e42e0b1875c9ab0f30e3f27..b893f1edc421ee3b1b4abc886f3f720de145a6c2 100644 (file)
@@ -1,5 +1,8 @@
-#
+# TODO:
+# - get rid of gcc_4_2 patch and header files crapolla
+
 # Conditional build:
+%bcond_without tests
 %bcond_with purify     # Compile openssl with \-DPURIFY, useful when one wants to
                        # use valgrind debugger against openssl-linked programs
 #
@@ -13,12 +16,12 @@ Summary(pt_BR.UTF-8):       Uma biblioteca C que fornece vários algoritmos e protocol
 Summary(ru.UTF-8):     Библиотеки и утилиты для соединений через Secure Sockets Layer
 Summary(uk.UTF-8):     Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
 Name:          openssl
-Version:       0.9.8d
-Release:       2
+Version:       0.9.8e
+Release:       5
 License:       Apache-style License
 Group:         Libraries
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: 8ed1853538e1d05a1f5ada61ebf8bffa
+# Source0-md5: 3a7ff24f6ea5cd711984722ad654b927
 Source1:       %{name}-ca-bundle.crt
 Source2:       %{name}.1.pl
 Source3:       %{name}-ssl-certificate.sh
@@ -29,6 +32,7 @@ Patch3:               %{name}-include.patch
 Patch4:                %{name}-md5-sparcv9.patch
 Patch5:                %{name}-libvar.patch
 Patch6:                %{name}-gcc_4_2.patch
+Patch7:                %{name}-CVE-2007-3108.patch
 URL:           http://www.openssl.org/
 BuildRequires: bc
 BuildRequires: perl-devel >= 1:5.6.1
@@ -193,7 +197,12 @@ RC4, RSA и SSL. Включает статические библиотеки д
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+# XXX: gcc 4.2 hack
+cp crypto/asn1/asn1.h crypto/asn1/asn1.h.X
+cp crypto/ocsp/ocsp.h crypto/ocsp/ocsp.h.X
+cp crypto/pem/pem.h crypto/pem/pem.h.X
 %patch6 -p1
+%patch7 -p1
 
 %build
 %{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' \
@@ -244,7 +253,7 @@ export OPTFLAGS LDFLAGS
        linux64-sparcv9
 %endif
 
-%{__make} -j1 all rehash tests \
+%{__make} -j1 all rehash %{?with_tests:tests} \
        CC="%{__cc}" \
        INSTALLTOP=%{_prefix}
 
@@ -326,8 +335,6 @@ ln -s %{_sysconfdir}/%{name}/openssl.cnf \
 mv -f $RPM_BUILD_ROOT%{_var}/lib/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
 rm -rf $RPM_BUILD_ROOT%{_var}/lib/%{name}/misc
 
-mv -f $RPM_BUILD_ROOT%{_bindir}/c_rehash $RPM_BUILD_ROOT%{_libdir}/%{name}
-
 find $RPM_BUILD_ROOT%{_mandir} -type f | xargs rm -f
 install doc/apps/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 install doc/apps/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
@@ -338,9 +345,16 @@ install %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
 
 rm $RPM_BUILD_ROOT%{_mandir}/man5/x509v3_config.5
 echo ".so openssl_x509v3_config.5" > $RPM_BUILD_ROOT%{_mandir}/man5/x509v3_config.5
+rm $RPM_BUILD_ROOT%{_mandir}/man5/config.5
+echo ".so openssl_config.5" > $RPM_BUILD_ROOT%{_mandir}/man5/config.5
 rm $RPM_BUILD_ROOT%{_mandir}/man7/Modes_of_DES.7
 echo ".so openssl_des_modes.7" > $RPM_BUILD_ROOT%{_mandir}/man7/Modes_of_DES.7
 
+# XXX: gcc 4.2 hack
+install crypto/asn1/asn1.h.X $RPM_BUILD_ROOT%{_includedir}/%{name}/asn1.h
+install crypto/ocsp/ocsp.h.X $RPM_BUILD_ROOT%{_includedir}/%{name}/ocsp.h
+install crypto/pem/pem.h.X $RPM_BUILD_ROOT%{_includedir}/%{name}/pem.h
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -420,8 +434,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files tools-perl
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/c_rehash
 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
-%attr(755,root,root) %{_libdir}/%{name}/c_rehash
 %{_mandir}/man1/openssl_CA.pl.1*
 
 %files devel
This page took 0.031282 seconds and 4 git commands to generate.