]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
python3 rebuild
[packages/openssl.git] / openssl.spec
index 339271ff1f7d51a8eb41e5bb5055334f58187612..b59a1ba38a4f38857d19f803429da5b58d26ea45 100644 (file)
@@ -1,13 +1,15 @@
 # TODO
 # - consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
+# - find a way to simplify (drop) openssl-optflags.patch, it's pain to update here in pld
 #
 # Conditional build:
 %bcond_without tests   # don't perform "make tests"
 %bcond_without zlib    # zlib: note - enables CVE-2012-4929 vulnerability
 %bcond_without sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
 %bcond_without sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
-%bcond_with    purify  # Compile openssl with \-DPURIFY, useful when one wants to
+%bcond_with    purify  # Compile openssl with "-DPURIFY", useful when one wants to
                        # use valgrind debugger against openssl-linked programs
+%bcond_with    snap    # use GitHub snapshot to build branch release
 
 %include       /usr/lib/rpm/macros.perl
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
@@ -19,43 +21,64 @@ Summary(pt_BR.UTF-8):       Uma biblioteca C que fornece vários algoritmos e protocol
 Summary(ru.UTF-8):     Библиотеки и утилиты для соединений через Secure Sockets Layer
 Summary(uk.UTF-8):     Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
 Name:          openssl
-Version:       1.0.1j
-Release:       2
+# 1.0.2 will be LTS release
+# Version 1.0.2 will be supported until 2019-12-31.
+# https://www.openssl.org/about/releasestrat.html
+Version:       1.0.2g
+Release:       6
 License:       Apache-like
 Group:         Libraries
+%if %{without snap}
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: f7175c9cd3c39bb1907ac8bba9df8ed3
+# Source0-md5: f3c710c045cdee5fd114feb69feba7aa
+%else
+Source1:       https://github.com/openssl/openssl/archive/OpenSSL_1_0_2-stable/%{name}-%{version}-dev.tar.gz
+%endif
 Source2:       %{name}.1.pl
 Source3:       %{name}-ssl-certificate.sh
 Source4:       %{name}-c_rehash.sh
 Patch0:                %{name}-alpha-ccc.patch
 Patch1:                %{name}-optflags.patch
-Patch2:                %{name}-globalCA.diff
-Patch3:                %{name}-include.patch
-Patch4:                %{name}-man-namespace.patch
-Patch5:                %{name}-asflag.patch
-Patch6:                %{name}-ca-certificates.patch
-Patch7:                %{name}-ldflags.patch
-Patch8:                %{name}-find.patch
-# from debian
-Patch10:       default_bits.patch
-Patch11:       pic.patch
-Patch12:       stddef.patch
+Patch2:                %{name}-include.patch
+Patch3:                %{name}-man-namespace.patch
+Patch4:                %{name}-asflag.patch
+Patch5:                %{name}-ca-certificates.patch
+Patch6:                %{name}-ldflags.patch
+Patch7:                %{name}-find.patch
+Patch8:                pic.patch
+Patch10:       %{name}_fix_for_x32.patch
 URL:           http://www.openssl.org/
 BuildRequires: bc
 BuildRequires: perl-devel >= 1:5.6.1
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpmbuild(macros) >= 1.213
 BuildRequires: sed >= 4.0
-Requires:      ca-certificates >= 20080809-4
+Requires:      ca-certificates >= 20120623-1.1
 Requires:      rpm-whiteout >= 1.7
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
 Obsoletes:     SSLeay-perl
 Obsoletes:     libopenssl0
+%if "%{pld_release}" == "ac"
+Conflicts:     neon < 0.26.3-3
+Conflicts:     ntpd < 4.2.4p8-10
+Conflicts:     openssh-clients < 2:5.8p1-9
+Conflicts:     openssh-server < 2:5.8p1-9
+%else
+Conflicts:     apache-mod_ssl < 1:2.2.31-4
+Conflicts:     curl-libs < 7.47.1-2
 Conflicts:     neon < 0.29.6-8
 Conflicts:     openssh-clients < 2:6.2p2-3
 Conflicts:     openssh-server < 2:6.2p2-3
+Conflicts:     php52-common < 4:5.2.17-20130717.17
+Conflicts:     php53-common < 4:5.3.29-27
+Conflicts:     php54-common < 4:5.4.45-5
+Conflicts:     php55-common < 4:5.5.32-2
+Conflicts:     php56-common < 4:5.6.18-3
+Conflicts:     python-modules < 1:2.7.10-8
+Conflicts:     python3-modules < 1:3.5.0-9
+Conflicts:     ruby-modules < 1:2.0.0.648-2
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -246,7 +269,12 @@ RC4, RSA и SSL. Включает статические библиотеки д
 бібліотеки для розробки програм з використанням SSL.
 
 %prep
+%if %{with snap}
+%setup -qcT -a1
+mv %{name}-OpenSSL_1_0_2-stable/* .
+%else
 %setup -q
+%endif
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -256,9 +284,9 @@ RC4, RSA и SSL. Включает статические библиотеки д
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%ifarch x32
 %patch10 -p1
-%patch11 -p1
-%patch12 -p1
+%endif
 
 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
 
@@ -303,6 +331,9 @@ PERL="%{__perl}" \
 %ifarch %{x8664}
        linux-x86_64
 %endif
+%ifarch x32
+       linux-x32
+%endif
 %ifarch ia64
        linux-ia64
 %endif
@@ -325,6 +356,9 @@ PERL="%{__perl}" \
        linux-armv4
 %endif
 
+v=$(awk -F= '/^VERSION/{print $2}' Makefile)
+test "$v" = %{version}%{?with_snap:-dev}
+
 %{__make} -j1 all rehash %{?with_tests:tests} \
        CC="%{__cc}" \
        ASFLAG='$(CFLAG) -Wa,--noexecstack' \
@@ -402,12 +436,11 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
-%doc doc/openssl_button.gif doc/openssl_button.html
 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
 %dir %{_sysconfdir}/%{name}
 %dir %{_sysconfdir}/%{name}/certs
-%dir %{_sysconfdir}/%{name}/private
+%dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
 %dir %{_datadir}/ssl
 
 %files engines
This page took 0.05575 seconds and 4 git commands to generate.