]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- cosmetics
[packages/openssl.git] / openssl.spec
index 8de82e8e5b7936e34f7e23cd6824e74010c12a81..a4dbb87c3f1185b95dfb2a502857f58516e1100d 100644 (file)
@@ -1,27 +1,28 @@
 %include       /usr/lib/rpm/macros.perl
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
 Summary(de):   Secure Sockets Layer (SSL)-Kommunikationslibrary
-Summary(es):   Biblioteca C que suministra algoritmos y protocolos criptográficos.
+Summary(es):   Biblioteca C que suministra algoritmos y protocolos criptográficos
 Summary(fr):   Utilitaires de communication SSL (Secure Sockets Layer)
 Summary(pl):   Biblioteki OpenSSL (SSL v2/v3)
-Summary(pt_BR):        Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos.
+Summary(pt_BR):        Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
 Summary(ru):   âÉÂÌÉÏÔÅËÉ É ÕÔÉÌÉÔÙ ÄÌÑ ÓÏÅÄÉÎÅÎÉÊ ÞÅÒÅÚ Secure Sockets Layer
 Summary(uk):   â¦Â̦ÏÔÅËÉ ÔÁ ÕÔÉ̦ÔÉ ÄÌÑ Ú'¤ÄÎÁÎØ ÞÅÒÅÚ Secure Sockets Layer
 Name:          openssl
-Version:       0.9.6g
+Version:       0.9.7c
 Release:       1
 License:       Apache-style License
-Vendor:                The OpenSSL Project
 Group:         Libraries
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
+# Source0-md5: c54fb36218adaaaba01ef733cd88c8ec
 Source1:       %{name}-ca-bundle.crt
+Source2:       %{name}.1.pl
 Patch0:                %{name}-alpha-ccc.patch
-# patch1 is only for 0.9.6a version. This version isn't binary
-# compatibile with 0.9.6 but have this same soname.
-Patch1:                %{name}-soname.patch
-Patch2:                %{name}-optflags.patch
-Patch3:                %{name}-nocrypt.patch
-Patch4:                %{name}-globalCA.diff
+Patch1:                %{name}-optflags.patch
+Patch2:                %{name}-globalCA.diff
+Patch3:                %{name}-parallel_make.patch
+Patch4:                %{name}-include.patch
+Patch5:         %{name}-makefile.patch
+URL:           http://www.openssl.org/
 BuildRequires: perl-devel >= 5.6.1
 BuildRequires: textutils
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -181,15 +182,16 @@ RC4, RSA 
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 for f in ` grep -r "%{_prefix}/local/bin/perl" . | cut -d":" -f1`; do
-perl -pi -e 's#%{_prefix}/local/bin/perl#%{_bindir}/perl#g' $f
+%{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' $f
 done
 
 touch Makefile.*
 
-perl util/perlpath.pl %{_bindir}/perl
+%{__perl} util/perlpath.pl %{__perl}
 
 OPTFLAGS="%{rpmcflags}"
 export OPTFLAGS
@@ -209,16 +211,21 @@ export OPTFLAGS
 ./Configure --openssldir=%{_var}/lib/%{name} threads linux-sparcv8 shared
 %endif
 
-%{__make} CC="%{__cc}"
-%{__make} rehash CC="%{__cc}"
+%{__make} \
+       CC="%{__cc}" \
+       INSTALLTOP=%{_prefix}
+
+%{__make} rehash \
+       CC="%{__cc}" \
+       INSTALLTOP=%{_prefix}
 
 # Conv PODs to man pages. "openssl_" prefix is added to each manpage
 # to avoid potential conflicts with others packages.
-center="OpenSSL 0.9.6"
-rel="OpenSSL 0.9.6"
+center="OpenSSL 0.9.7"
+rel="OpenSSL 0.9.7"
 
 cd doc/apps || exit 1
-perl -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
+%{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
 
 for pod in *.pod; do
        if [ $pod != "openssl.pod" ]; then
@@ -247,7 +254,7 @@ for dir in ssl crypto; do
                rel="OpenSSL cryptographic library"
        fi
 
-       perl -p -i -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
+       %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
 
        for pod in *.pod; do
                sec=`[ "$pod" = "des_modes.pod" ] && echo 7 || echo 3`;
@@ -261,20 +268,22 @@ for dir in ssl crypto; do
 done
 
 #cd perl
-#perl Makefile.PL
-#make
+#%%{__perl} Makefile.PL \
+#      INSTALLDIRS=vendor
+#%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
-       $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,7},%{_datadir}/ssl}
+       $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl}
 
 %{__make} install \
        INSTALLTOP=%{_prefix} \
-       INSTALL_PREFIX=$RPM_BUILD_ROOT
+       INSTALL_PREFIX=$RPM_BUILD_ROOT \
+       MANDIR=%{_mandir}
 
-install %{SOURCE1}  $RPM_BUILD_ROOT%{_datadir}/ssl/ca-bundle.crt
-install libRSAglue.a libcrypto.a libssl.a $RPM_BUILD_ROOT%{_libdir}
+install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/ssl/ca-bundle.crt
+install libcrypto.a libssl.a $RPM_BUILD_ROOT%{_libdir}
 install lib*.so.*.* $RPM_BUILD_ROOT%{_libdir}
 ln -sf libcrypto.so.*.* $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
 ln -sf libssl.so.*.* $RPM_BUILD_ROOT%{_libdir}/libssl.so
@@ -293,6 +302,7 @@ install doc/apps/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 install doc/apps/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
 install doc/ssl/*.3 doc/crypto/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
 install doc/crypto/*.7 $RPM_BUILD_ROOT%{_mandir}/man7
+install %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -316,7 +326,7 @@ rm -rf $RPM_BUILD_ROOT
 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/%{name}/openssl.cnf
 %verify(not md5 size mtime) %config(noreplace) %{_var}/lib/%{name}/openssl.cnf
 %dir %{_datadir}/ssl
-%verify(not md5 size mtime) %config(noreplace)%{_datadir}/ssl/ca-bundle.crt
+%verify(not md5 size mtime) %config(noreplace) %{_datadir}/ssl/ca-bundle.crt
 
 %attr(755,root,root) %{_bindir}/%{name}
 %dir %{_libdir}/%{name}
@@ -340,6 +350,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/openssl_gendsa.1*
 %{_mandir}/man1/openssl_genrsa.1*
 %{_mandir}/man1/openssl_nseq.1*
+%{_mandir}/man1/openssl_ocsp.1*
 %{_mandir}/man1/openssl_passwd.1*
 %{_mandir}/man1/openssl_pkcs12.1*
 %{_mandir}/man1/openssl_pkcs7.1*
@@ -358,6 +369,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/openssl_version.1*
 %{_mandir}/man1/openssl_x509.1*
 %{_mandir}/man5/*.5*
+%lang(pl) %{_mandir}/pl/man1/openssl.1*
 
 %files tools-perl
 %defattr(644,root,root,755)
@@ -370,7 +382,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_includedir}/%{name}
-%{_mandir}/man3/*.3*
+%{_libdir}/pkgconfig/openssl.pc
+%{_mandir}/man3/openssl*.3*
 %{_mandir}/man7/*.7*
 
 %files static
This page took 0.090669 seconds and 4 git commands to generate.