]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- separated engines subpackage; makes it possible to install openssl 1.0.0
[packages/openssl.git] / openssl.spec
index 973e82464f3f9f9ff850fc121590123503ec6fc3..769154fbcd9c5a5fb113e6cade9d935a50cfd805 100644 (file)
@@ -1,4 +1,6 @@
 #
+# TODO: consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
+#
 # Conditional build:
 %bcond_without tests   # don't perform "make tests"
 %bcond_with    purify  # Compile openssl with \-DPURIFY, useful when one wants to
@@ -15,7 +17,7 @@ Summary(ru.UTF-8):    Библиотеки и утилиты для соедине
 Summary(uk.UTF-8):     Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
 Name:          openssl
 Version:       1.0.0
-Release:       0.1
+Release:       7
 License:       Apache-like
 Group:         Libraries
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
@@ -30,8 +32,7 @@ Patch3:               %{name}-include.patch
 Patch4:                %{name}-man-namespace.patch
 Patch5:                %{name}-asflag.patch
 Patch6:                %{name}-ca-certificates.patch
-Patch7:                %{name}-fips_install.patch
-Patch8:                %{name}-ldflags.patch
+Patch7:                %{name}-ldflags.patch
 URL:           http://www.openssl.org/
 BuildRequires: bc
 BuildRequires: perl-devel >= 1:5.6.1
@@ -97,6 +98,28 @@ RC4, RSA и SSL.
 користування, що реалізують велику кількість криптографічних
 алгоритмів, включаючи DES, RC4, RSA та SSL.
 
+%package engines
+Summary:       OpenSSL optional crypto engines
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description engines
+With OpenSSL 0.9.6, a new component was added to support alternative
+cryptography implementations, most commonly for interfacing with external
+crypto devices (eg. accelerator cards). This component is called ENGINE.
+
+There are currently built-in ENGINE implementations for the following
+crypto devices:
+
+- CryptoSwift
+- Compaq Atalla
+- nCipher CHIL
+- Nuron
+- Broadcom uBSec
+
+In addition, dynamic binding to external ENGINE implementations is now
+provided by a special ENGINE called "dynamic". 
+
 %package tools
 Summary:       OpenSSL command line tool and utilities
 Summary(pl.UTF-8):     Zestaw narzędzi i skryptów
@@ -193,20 +216,19 @@ RC4, RSA и SSL. Включает статические библиотеки д
 
 %prep
 %setup -q
-#%patch0 -p1
-#%patch1 -p1
+%patch0 -p1
+%patch1 -p1
 %patch2 -p1
 %patch3 -p1
-#%patch4 -p1
-#%patch5 -p1
+%patch4 -p1
+%patch5 -p1
 %patch6 -p1
-#%patch7 -p1
-#%patch8 -p1
+%patch7 -p1
 
 %{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' \
        `grep -l -r "%{_prefix}/local/bin/perl" *`
 
-sed -i -e 's|$prefix/lib/engines|/%{_lib}/engines|g' Configure
+sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
 
 %build
 touch Makefile.*
@@ -228,6 +250,7 @@ OPTFLAGS="%{rpmcflags} %{?with_purify:-DPURIFY}" \
        enable-cms \
        enable-idea \
        enable-mdc2 \
+       enable-md2 \
        enable-rc5 \
 %ifarch %{ix86}
 %ifarch i386
@@ -264,7 +287,7 @@ OPTFLAGS="%{rpmcflags} %{?with_purify:-DPURIFY}" \
 
 %{__make} -j1 all rehash %{?with_tests:tests} \
        CC="%{__cc}" \
-       ASFLAG='$(CFLAG) -c -Wa,--noexecstack' \
+       ASFLAG='$(CFLAG) -Wa,--noexecstack' \
        INSTALLTOP=%{_prefix}
 
 # Rename POD sources of man pages. "openssl_" prefix is added to each
@@ -292,8 +315,8 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
        INSTALL_PREFIX=$RPM_BUILD_ROOT \
        MANDIR=%{_mandir}
 
-mv -f $RPM_BUILD_ROOT/%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
-mv -f $RPM_BUILD_ROOT/%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
+mv -f $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
+mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
 
@@ -324,6 +347,10 @@ rm -rf $RPM_BUILD_ROOT
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
+%triggerpostun -- %{name}-tools < 1.0.0-5
+# the hashing format has changed in 1.0.0
+[ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
+
 %if "%{pld_release}" == "ti"
 %triggerin -- %{name}-tools < 0.9.8i-2
 if [ -L /var/lib/openssl/openssl.cnf ] ; then
@@ -352,8 +379,6 @@ fi
 %doc doc/openssl_button.gif doc/openssl_button.html
 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
-%dir /%{_lib}/engines
-%attr(755,root,root) /%{_lib}/engines/*.so
 %if "%{pld_release}" == "ti"
 %dir %{_var}/lib/%{name}
 %dir %{_var}/lib/%{name}/certs
@@ -368,6 +393,10 @@ fi
 %endif
 %dir %{_datadir}/ssl
 
+%files engines
+%dir /%{_lib}/engines
+%attr(755,root,root) /%{_lib}/engines/*.so
+
 %files tools
 %defattr(644,root,root,755)
 %if "%{pld_release}" == "ti"
@@ -376,8 +405,8 @@ fi
 %else
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
 %endif
-%attr(755,root,root) %{_bindir}/%{name}
 %attr(755,root,root) %{_bindir}/c_rehash.sh
+%attr(755,root,root) %{_bindir}/openssl
 %attr(754,root,root) %{_bindir}/ssl-certificate
 
 %dir %{_libdir}/%{name}
@@ -386,11 +415,13 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/c_info
 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
 %attr(755,root,root) %{_libdir}/%{name}/c_name
+%attr(755,root,root) %{_libdir}/%{name}/tsget
 
 %{_mandir}/man1/openssl.1*
 %{_mandir}/man1/openssl_asn1parse.1*
 %{_mandir}/man1/openssl_ca.1*
 %{_mandir}/man1/openssl_ciphers.1*
+%{_mandir}/man1/openssl_cms.1*
 %{_mandir}/man1/openssl_crl.1*
 %{_mandir}/man1/openssl_crl2pkcs7.1*
 %{_mandir}/man1/openssl_dgst.1*
@@ -402,6 +433,7 @@ fi
 %{_mandir}/man1/openssl_enc.1*
 %{_mandir}/man1/openssl_errstr.1*
 %{_mandir}/man1/openssl_gendsa.1*
+%{_mandir}/man1/openssl_genpkey.1*
 %{_mandir}/man1/openssl_genrsa.1*
 %{_mandir}/man1/openssl_nseq.1*
 %{_mandir}/man1/openssl_ocsp.1*
@@ -409,6 +441,9 @@ fi
 %{_mandir}/man1/openssl_pkcs12.1*
 %{_mandir}/man1/openssl_pkcs7.1*
 %{_mandir}/man1/openssl_pkcs8.1*
+%{_mandir}/man1/openssl_pkey.1*
+%{_mandir}/man1/openssl_pkeyparam.1*
+%{_mandir}/man1/openssl_pkeyutl.1*
 %{_mandir}/man1/openssl_rand.1*
 %{_mandir}/man1/openssl_req.1*
 %{_mandir}/man1/openssl_rsa.1*
@@ -420,6 +455,8 @@ fi
 %{_mandir}/man1/openssl_smime.1*
 %{_mandir}/man1/openssl_speed.1*
 %{_mandir}/man1/openssl_spkac.1*
+%{_mandir}/man1/openssl_ts.1*
+%{_mandir}/man1/openssl_tsget.1*
 %{_mandir}/man1/openssl_verify.1*
 %{_mandir}/man1/openssl_version.1*
 %{_mandir}/man1/openssl_x509.1*
This page took 0.037288 seconds and 4 git commands to generate.