]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- removed bogus Group(fr)
[packages/openssl.git] / openssl.spec
index 955df886de8381d8cc857f96392d77775d9bf911..68711b4737ac43426db2f5c2e90f3ff07250e59c 100644 (file)
@@ -1,10 +1,12 @@
+# conditional build:
+# _without_embed - don't build uClibc version
 %include       /usr/lib/rpm/macros.perl
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
 Summary(de):   Secure Sockets Layer (SSL)-Kommunikationslibrary
 Summary(fr):   Utilitaires de communication SSL (Secure Sockets Layer)
 Name:          openssl
 Version:       0.9.6b
-Release:       2
+Release:       6
 License:       Apache-style License
 Vendor:                The OpenSSL Project
 Group:         Libraries
@@ -12,18 +14,32 @@ Group(de):  Libraries
 Group(es):     Bibliotecas
 Group(fr):     Librairies
 Group(pl):     Biblioteki
+Group(pt_BR):  Bibliotecas
+Group(ru):     âÉÂÌÉÏÔÅËÉ
+Group(uk):     â¦Â̦ÏÔÅËÉ
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
 Patch0:                %{name}-alpha-ccc.patch
 # patch1 is only for 0.9.6a version. This version isn't binary
 # compatibile with 0.9.6 but have this same soname.
 Patch1:                %{name}-soname.patch
 Patch2:                %{name}-optflags.patch
+Patch3:                %{name}-nocrypt.patch
 BuildRequires: perl-devel >= 5.6.1
 BuildRequires: textutils
+%if %{!?_without_embed:1}%{?_without_embed:0}
+BuildRequires: uClibc-devel
+BuildRequires: uClibc-static
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
 Obsoletes:     SSLeay-perl
+Obsoletes:     libopenssl0
+
+%define embed_path     /usr/lib/embed
+%define embed_cc       %{_arch}-uclibc-cc
+%define embed_cflags   %{rpmcflags} -Os
+%define uclibc_prefix  /usr/%{_arch}-linux-uclibc
 
 %description
 The OpenSSL Project is a collaborative effort to develop a robust,
@@ -68,7 +84,6 @@ The OpenSSL Toolkit cmdline tool openssl and utility scripts.
 Summary:       OpenSSL utilities written in Perl
 Group:         Applications/Communications
 Group(de):     Applikationen/Kommunikation
-Group(fr):     Utilitaires
 Group(pl):     Aplikacje/Komunikacja
 Requires:      %{name} = %{version}
 
@@ -85,6 +100,7 @@ Group(de):   Entwicklung/Libraries
 Group(fr):     Development/Librairies
 Group(pl):     Programowanie/Biblioteki
 Requires:      %{name} = %{version}
+Obsoletes:     libopenssl0-devel
 
 %description devel
 Development part of OpenSSL library.
@@ -92,6 +108,22 @@ Development part of OpenSSL library.
 %description devel -l pl
 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
 
+%package devel-embed
+Summary:       Development part of OpenSSL Toolkit embedded libraries
+Summary(pl):   Czê¶æ bibiloteki OpenSSL przeznaczona dla aplikacji wbudowanych
+Group:         Development/Libraries
+Group(de):     Entwicklung/Libraries
+Group(fr):     Development/Librairies
+Group(pl):     Programowanie/Biblioteki
+Requires:      %{name} = %{version}
+
+%description devel-embed
+Development part of OpenSSL library for embedded applications.
+
+%description -l pl devel-embed
+Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów aplikacji
+wbudowanych.
+
 %package static
 Summary:       Static OpenSSL libraries
 Summary(pl):   Statyczne wersje bibliotek z OpenSSL
@@ -112,6 +144,7 @@ Statyczne wersje bibliotek z OpenSSL.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 for f in ` grep -r "/usr/local/bin/perl" . | cut -d":" -f1`; do
@@ -127,7 +160,7 @@ export OPTFLAGS
 %ifarch i386 i486
 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared 386
 %endif
-%ifarch i586 i686
+%ifarch i586 i686 athlon
 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared
 %endif
 %ifarch ppc
@@ -140,6 +173,15 @@ export OPTFLAGS
 ./Configure --openssldir=%{_var}/lib/%{name} threads linux-sparcv8 shared
 %endif
 
+%if %{!?_without_embed:1}%{?_without_embed:0}
+%{__make} CC=%{embed_cc}
+%{__make} rehash CC=%{embed_cc}
+for f in RSAglue crypto ssl ; do
+       mv -f lib$f.a lib$f.a-embed
+done
+%{__make} clean
+%endif
+
 %{__make}
 %{__make} rehash
 
@@ -224,6 +266,15 @@ install doc/apps/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
 install doc/ssl/*.3 doc/crypto/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
 install doc/crypto/*.7 $RPM_BUILD_ROOT%{_mandir}/man7
 
+%if %{!?_without_embed:1}%{?_without_embed:0}
+install -d $RPM_BUILD_ROOT%{uclibc_prefix}/{include,lib}
+for f in RSAglue crypto ssl ; do
+       install lib$f.a-embed $RPM_BUILD_ROOT%{uclibc_prefix}/lib/lib$f.a
+done
+cp -a $RPM_BUILD_ROOT%{_includedir}/%{name} \
+       $RPM_BUILD_ROOT%{uclibc_prefix}/include
+%endif
+
 gzip -9nf CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
 
 %post   -p /sbin/ldconfig
@@ -300,6 +351,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/%{name}
 %{_mandir}/man3/*.3*
 
+%if %{!?_without_embed:1}%{?_without_embed:0}
+%files devel-embed
+%defattr(644,root,root,755)
+%{uclibc_prefix}/lib/*
+%{uclibc_prefix}/include/%{name}
+%endif
+
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
This page took 0.032417 seconds and 4 git commands to generate.