]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
add --prefix and install engines to /lib
[packages/openssl.git] / openssl.spec
index 78c7df4e982800f77ce525e3bf2235a44b743636..619881b51877c1710471e7882d5f6bbaefffb7ef 100644 (file)
@@ -9,7 +9,10 @@
 %bcond_without sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
 %bcond_with    purify  # Compile openssl with "-DPURIFY", useful when one wants to
                        # use valgrind debugger against openssl-linked programs
+%bcond_with    snap    # use GitHub snapshot to build branch release
 
+%define                subver  pre6
+%define                rel             0.1
 %include       /usr/lib/rpm/macros.perl
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
 Summary(de.UTF-8):     Secure Sockets Layer (SSL)-Kommunikationslibrary
@@ -23,16 +26,17 @@ Name:               openssl
 # 1.0.2 will be LTS release
 # Version 1.0.2 will be supported until 2019-12-31.
 # https://www.openssl.org/about/releasestrat.html
-Version:       1.0.2e
-Release:       1
+Version:       1.1.0
+Release:       0.1
 License:       Apache-like
 Group:         Libraries
-Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: 2218c1a6f807f7206c11eb3ee3a5ec80
-Source1:       https://raw.githubusercontent.com/openssl/openssl/OpenSSL_1_0_2-stable/util/pod2mantest
-# Source1-md5: 0811d285202cebe91003771475802b4f
-Source11:      https://raw.githubusercontent.com/openssl/openssl/OpenSSL_1_0_2-stable/test/bctest
-# Source11-md5:        ca85ae891de94faa821c2c6f4dba7f5a
+%if %{without snap}
+#Source0:      ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
+Source0:       https://www.openssl.org/source/%{name}-%{version}-%{subver}.tar.gz
+# Source0-md5: 5073f45b5922992234396c7d8247196f
+%else
+Source1:       https://github.com/openssl/openssl/archive/OpenSSL_1_0_2-stable/%{name}-%{version}-dev.tar.gz
+%endif
 Source2:       %{name}.1.pl
 Source3:       %{name}-ssl-certificate.sh
 Source4:       %{name}-c_rehash.sh
@@ -46,13 +50,14 @@ Patch6:             %{name}-ldflags.patch
 Patch7:                %{name}-find.patch
 Patch8:                pic.patch
 Patch10:       %{name}_fix_for_x32.patch
+Patch11:       engines-dir.patch
 URL:           http://www.openssl.org/
 BuildRequires: bc
-BuildRequires: perl-devel >= 1:5.6.1
+BuildRequires: perl-devel >= 1:5.10.0
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpmbuild(macros) >= 1.213
 BuildRequires: sed >= 4.0
-Requires:      ca-certificates >= 20080809-4
+Requires:      ca-certificates >= 20120623-1.1
 Requires:      rpm-whiteout >= 1.7
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
@@ -258,47 +263,43 @@ RC4, RSA и SSL. Включает статические библиотеки д
 бібліотеки для розробки програм з використанням SSL.
 
 %prep
-%setup -q
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
-%patch6 -p1
+%if %{with snap}
+%setup -qcT -a1
+mv %{name}-OpenSSL_1_0_2-stable/* .
+%else
+%setup -q %{?subver:-n %{name}-%{version}-%{subver}}
+%endif
+#%patch0 -p1 # alpha patch from year 2000 - drop it
+#%patch1 -p1 # flags list has been nuked (thank god!)
+#%patch2 -p1 # openssl include subdir. check this
+#%patch3 -p1 # patched Makefile.org no longer exists
+#%patch4 -p1 # patched Makefile.org no longer exists
+#%patch5 -p1 # check
+#%patch6 -p1 # patched Makefile.org no longer exists
 %patch7 -p1
 %patch8 -p1
+%ifarch x32
 %patch10 -p1
-
-sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
-
-# fix packaging error
-# https://github.com/openssl/openssl/issues/491
-ln -s . test/openssl-1.0.2e
-
-# also pod2man missing
-# https://github.com/openssl/openssl/issues/490
-install -p %{SOURCE1} util
-
-# https://github.com/openssl/openssl/issues/493
-install -p %{SOURCE11} test
+%endif
+%patch11 -p1
 
 %build
 touch Makefile.*
 
-%{__perl} util/perlpath.pl %{__perl}
+# util/perlpath.pl no longer exists
+#%{__perl} util/perlpath.pl %{__perl}
 
 OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
 PERL="%{__perl}" \
 %{__perl} ./Configure \
+       --prefix=%{_prefix} \
        --openssldir=%{_sysconfdir}/%{name} \
        --libdir=%{_lib} \
        shared \
        threads \
-       %{!?with_sslv2:no-ssl2} \
-       %{!?with_sslv3:no-ssl3} \
+       %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
+       %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
        %{!?with_zlib:no-}zlib \
-       enable-camelia \
        enable-cms \
        enable-idea \
        enable-md2 \
@@ -306,7 +307,6 @@ PERL="%{__perl}" \
        enable-rc5 \
        enable-rfc3779 \
        enable-seed \
-       enable-tlsext \
 %ifarch %{x8664}
        enable-ec_nistp_64_gcc_128 \
 %endif
@@ -349,6 +349,9 @@ PERL="%{__perl}" \
        linux-armv4
 %endif
 
+v=$(awk -F= '/^VERSION/{print $2}' Makefile)
+test "$v" = %{version}%{?subver:-%{subver}}%{?with_snap:-dev}
+
 %{__make} -j1 all rehash %{?with_tests:tests} \
        CC="%{__cc}" \
        ASFLAG='$(CFLAG) -Wa,--noexecstack' \
@@ -426,12 +429,11 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
-#%doc doc/openssl_button.gif doc/openssl_button.html
 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
 %dir %{_sysconfdir}/%{name}
 %dir %{_sysconfdir}/%{name}/certs
-%dir %{_sysconfdir}/%{name}/private
+%dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
 %dir %{_datadir}/ssl
 
 %files engines
This page took 0.083711 seconds and 4 git commands to generate.