]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
add --prefix and install engines to /lib
[packages/openssl.git] / openssl.spec
index 39274c21375df55c25caa366ecf5827904e02fb2..619881b51877c1710471e7882d5f6bbaefffb7ef 100644 (file)
@@ -11,6 +11,8 @@
                        # use valgrind debugger against openssl-linked programs
 %bcond_with    snap    # use GitHub snapshot to build branch release
 
+%define                subver  pre6
+%define                rel             0.1
 %include       /usr/lib/rpm/macros.perl
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
 Summary(de.UTF-8):     Secure Sockets Layer (SSL)-Kommunikationslibrary
@@ -24,13 +26,14 @@ Name:               openssl
 # 1.0.2 will be LTS release
 # Version 1.0.2 will be supported until 2019-12-31.
 # https://www.openssl.org/about/releasestrat.html
-Version:       1.0.2g
-Release:       1
+Version:       1.1.0
+Release:       0.1
 License:       Apache-like
 Group:         Libraries
 %if %{without snap}
-Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: b3bf73f507172be9292ea2a8c28b659d
+#Source0:      ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
+Source0:       https://www.openssl.org/source/%{name}-%{version}-%{subver}.tar.gz
+# Source0-md5: 5073f45b5922992234396c7d8247196f
 %else
 Source1:       https://github.com/openssl/openssl/archive/OpenSSL_1_0_2-stable/%{name}-%{version}-dev.tar.gz
 %endif
@@ -47,9 +50,10 @@ Patch6:              %{name}-ldflags.patch
 Patch7:                %{name}-find.patch
 Patch8:                pic.patch
 Patch10:       %{name}_fix_for_x32.patch
+Patch11:       engines-dir.patch
 URL:           http://www.openssl.org/
 BuildRequires: bc
-BuildRequires: perl-devel >= 1:5.6.1
+BuildRequires: perl-devel >= 1:5.10.0
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpmbuild(macros) >= 1.213
 BuildRequires: sed >= 4.0
@@ -263,39 +267,39 @@ RC4, RSA и SSL. Включает статические библиотеки д
 %setup -qcT -a1
 mv %{name}-OpenSSL_1_0_2-stable/* .
 %else
-%setup -q
+%setup -q %{?subver:-n %{name}-%{version}-%{subver}}
 %endif
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
-%patch6 -p1
+#%patch0 -p1 # alpha patch from year 2000 - drop it
+#%patch1 -p1 # flags list has been nuked (thank god!)
+#%patch2 -p1 # openssl include subdir. check this
+#%patch3 -p1 # patched Makefile.org no longer exists
+#%patch4 -p1 # patched Makefile.org no longer exists
+#%patch5 -p1 # check
+#%patch6 -p1 # patched Makefile.org no longer exists
 %patch7 -p1
 %patch8 -p1
 %ifarch x32
-%endif
 %patch10 -p1
-
-sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
+%endif
+%patch11 -p1
 
 %build
 touch Makefile.*
 
-%{__perl} util/perlpath.pl %{__perl}
+# util/perlpath.pl no longer exists
+#%{__perl} util/perlpath.pl %{__perl}
 
 OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
 PERL="%{__perl}" \
 %{__perl} ./Configure \
+       --prefix=%{_prefix} \
        --openssldir=%{_sysconfdir}/%{name} \
        --libdir=%{_lib} \
        shared \
        threads \
-       %{!?with_sslv2:no-ssl2} \
-       %{!?with_sslv3:no-ssl3} \
+       %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
+       %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
        %{!?with_zlib:no-}zlib \
-       enable-camelia \
        enable-cms \
        enable-idea \
        enable-md2 \
@@ -303,7 +307,6 @@ PERL="%{__perl}" \
        enable-rc5 \
        enable-rfc3779 \
        enable-seed \
-       enable-tlsext \
 %ifarch %{x8664}
        enable-ec_nistp_64_gcc_128 \
 %endif
@@ -347,7 +350,7 @@ PERL="%{__perl}" \
 %endif
 
 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
-test "$v" = %{version}%{?with_snap:-dev}
+test "$v" = %{version}%{?subver:-%{subver}}%{?with_snap:-dev}
 
 %{__make} -j1 all rehash %{?with_tests:tests} \
        CC="%{__cc}" \
This page took 0.049695 seconds and 4 git commands to generate.