]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- prereq: sed, fileutils (c_rehash requires this)
[packages/openssl.git] / openssl.spec
index 49fb8fb08701f13559c2f559569f5f092d5d09bd..58e78b0a3ae1d2115413e089e03ae20eaa6aa3cf 100644 (file)
@@ -1,23 +1,27 @@
-%define                date    19990520
-%define                time    2130
-Summary:       Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
-Name:          openssl
-Version:       0.9.3
-Release:       0.%{date}
-Group:                 Libraries
+%include       /usr/lib/rpm/macros.perl
+Summary:       Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
+Summary(de):   Secure Sockets Layer (SSL)-Kommunikationslibrary & Utilities
+Summary(fr):   Utilitaires et librairies de communication SSL (Secure Sockets Layer)
+Name:          openssl
+Version:       0.9.5a
+Release:       1
+Group:         Libraries
+Group(fr):     Librairies
 Group(pl):     Biblioteki
-Source:        ftp://ftp.openssl.org/source/%{name}-SNAP-%{date}-%{time}.tar.gz
-Patch0:                openssl-sslcrypto.patch
-Patch1:                openssl-perl.patch
-Vendor:        The OpenSSL Project
-License:       Apache-style License
-BuildPrereq:   perl
-BuildRoot:     /tmp/%{name}-%{version}-root
+Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
+Patch0:                openssl-perl.patch
+Vendor:                The OpenSSL Project
+License:       Apache-style License
+BuildRequires: symlinks
+BuildRequires: perl
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Prereq:                fileutils
+Prereq:                sed
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
 Obsoletes:     SSLeay-perl
 
-%define                openssldir      /var/state/openssl
+%define                openssldir      /var/lib/openssl
 %define                _sysconfdir     /etc/%{name}
 %define                _pkglibdir      %{_libdir}/%{name}
 %define                _pkgincludedir  %{_includedir}/%{name}
@@ -30,18 +34,32 @@ v1) protocols with full-strength cryptography world-wide. The project
 is managed by a worldwide community of volunteers that use the
 Internet to communicate, plan, and develop the OpenSSL tookit and its
 related documentation.
-   
+
 OpenSSL is based on the excellent SSLeay library developed by Eric A.
 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
 Apache-style licence, which basically means that you are free to get
 and use it for commercial and non-commercial purposes subject to some
 simple license conditions.
 
+%description -l de
+Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
+libraries, die verschiedene Verschlüsselungs- und
+Entschlüsselungsalgorithmen und
+- -protokolle, wie DES, RC4, RSA und SSL zur Verfügung stellen.
+
+%description -l fr
+OpenSSL est un outiil de gestion des certificats et les librairies
+partagees qui fournit plusieurs protocoles et algorithmes de
+codage/decodage, incluant DES, RC4, RSA et SSL.
+
 %package devel
 Summary:       Development part of OpenSSL library
+Summary(de):   Secure Sockets Layer Kommunikationslibrary: statische libraries+header                           
+Summary(fr):   Librairies statiques, headers et utilitaires pour communication SSL (Secure Sockets Layer)
 Summary(pl):   Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
-Group:         Development/Library
-Group(pl):     Programownie/Biblioteki
+Group:         Development/Libraries
+Group(fr):     Development/Librairies
+Group(pl):     Programowanie/Biblioteki
 Requires:      %{name} = %{version}
 
 %description devel
@@ -53,7 +71,8 @@ Cz
 %package static
 Summary:       Static OpenSSL library
 Summary(pl):   Statyczna wersja biblioteki OpenSSL
-Group:         Development/Library
+Group:         Development/Libraries
+Group(fr):     Development/Librairies
 Group(pl):     Programowanie/Biblioteki
 Requires:      %{name}-devel = %{version}
 
@@ -64,27 +83,25 @@ Static OpenSSL library.
 Statyczna wersja biblioteki OpenSSL.
 
 %prep
-%setup  -q -n %{name}-SNAP-%{date}-%{time}
-%patch0 -p1
-%patch1 -p1
+%setup -q 
+%patch -p1
 
 %build
-for i in ` echo Configure Makefile.org `; do
-        sed -e 's#-m486##g' \
-               -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' \
-               <$i >$i.work
-        mv $i.work $i
+for i in Configure Makefile.org ; do
+        perl -pi -e 's#-m486##g' $i
+       perl -pi -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' $i
 done
 
 perl util/perlpath.pl %{_bindir}
 
-ln -s crypto sslcrypto
-
 ./config --openssldir=%{openssldir}
 
 make OPT_FLAGS="$RPM_OPT_FLAGS" linux-shared
 make INSTALLTOP=%{_prefix} OPT_FLAGS="$RPM_OPT_FLAGS"
 make rehash
+#cd perl
+#perl Makefile.PL
+#make
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -97,11 +114,14 @@ make install \
 
 install libRSAglue.a   $RPM_BUILD_ROOT%{_libdir}
 install lib*.so.*.*    $RPM_BUILD_ROOT%{_libdir}
-mv     lib*.so         $RPM_BUILD_ROOT%{_libdir}
+cp -d  lib*.so         $RPM_BUILD_ROOT%{_libdir}
 
+#cd perl
+#make install DESTDIR=$RPM_BUILD_ROOT
+#cd ..
 
 mv $RPM_BUILD_ROOT%{openssldir}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}
-ln -s $RPM_BUILD_ROOT%{_sysconfdir}/openssl.cnf \
+ln -s %{_sysconfdir}/openssl.cnf \
        $RPM_BUILD_ROOT%{openssldir}/openssl.cnf
 symlinks -cs $RPM_BUILD_ROOT%{openssldir}
 
@@ -109,10 +129,10 @@ mv $RPM_BUILD_ROOT%{openssldir}/misc/*    $RPM_BUILD_ROOT%{_pkglibdir}
 rm -rf $RPM_BUILD_ROOT%{openssldir}/misc
 
 strip $RPM_BUILD_ROOT%{_bindir}/* || :
-strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* || :
+strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
 
-gzip -9fn CHANGES CHANGES.SSLeay LICENSE NEWS README \
-       doc/*.pod doc/*.txt
+gzip -9nf CHANGES CHANGES.SSLeay LICENSE NEWS README \
+       doc/*.txt doc/*/*pod
 
 %post
 %{_bindir}/c_rehash certs
@@ -126,7 +146,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
-%doc doc/*.pod.gz doc/*.txt.gz
+%doc doc/*.txt.gz doc/apps 
 %doc doc/openssl_button.gif doc/openssl_button.html
 
 %attr(755,root,root) %{_bindir}/*
@@ -140,15 +160,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
+%doc doc/ssl doc/crypto
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_pkgincludedir}
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
-
-%changelog
-* Wed Apr 14 1999 Artur Frysiak <wiget@pld.org.pl>
-  [0.9.2c-2]
-- rewrite for PLD
-TODO: make shared libs and perl subpackage
This page took 0.032794 seconds and 4 git commands to generate.