]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- strict internal deps, removed redundant BR textutils
[packages/openssl.git] / openssl.spec
index 61c2c9b0921a6bd0a04c25fd56f085ace848e8ce..5885217ec1541e8106205f2fa0646d8517b44c62 100644 (file)
@@ -1,5 +1,4 @@
 %include       /usr/lib/rpm/macros.perl
-%define                _beta   beta6
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
 Summary(de):   Secure Sockets Layer (SSL)-Kommunikationslibrary
 Summary(es):   Biblioteca C que suministra algoritmos y protocolos criptográficos
@@ -9,18 +8,23 @@ Summary(pt_BR):       Uma biblioteca C que fornece v
 Summary(ru):   âÉÂÌÉÏÔÅËÉ É ÕÔÉÌÉÔÙ ÄÌÑ ÓÏÅÄÉÎÅÎÉÊ ÞÅÒÅÚ Secure Sockets Layer
 Summary(uk):   â¦Â̦ÏÔÅËÉ ÔÁ ÕÔÉ̦ÔÉ ÄÌÑ Ú'¤ÄÎÁÎØ ÞÅÒÅÚ Secure Sockets Layer
 Name:          openssl
-Version:       0.9.7
-Release:       0.%{_beta}.1
+Version:       0.9.7c
+Release:       3
 License:       Apache-style License
 Group:         Libraries
-Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}-%{_beta}.tar.gz
+Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
+# Source0-md5: c54fb36218adaaaba01ef733cd88c8ec
 Source1:       %{name}-ca-bundle.crt
 Source2:       %{name}.1.pl
+Source3:       %{name}-ssl-certificate.sh
 Patch0:                %{name}-alpha-ccc.patch
 Patch1:                %{name}-optflags.patch
 Patch2:                %{name}-globalCA.diff
+Patch3:                %{name}-parallel_make.patch
+Patch4:                %{name}-include.patch
+Patch5:         %{name}-makefile.patch
+URL:           http://www.openssl.org/
 BuildRequires: perl-devel >= 5.6.1
-BuildRequires: textutils
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
@@ -82,7 +86,7 @@ RC4, RSA 
 Summary:       OpenSSL command line tool and utilities
 Summary(pl):   Zestaw narzêdzi i skryptów
 Group:         Applications/Communications
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description tools
 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
@@ -94,7 +98,7 @@ Zestaw narz
 Summary:       OpenSSL utilities written in Perl
 Summary(pl):   Narzêdzia OpenSSL napisane w perlu
 Group:         Applications/Communications
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description tools-perl
 OpenSSL Toolkit tools written in Perl.
@@ -112,7 +116,7 @@ Summary(pt_BR):     Bibliotecas e arquivos de inclus
 Summary(ru):   âÉÂÌÉÏÔÅËÉ, ÈÅÄÅÒÙ É ÕÔÉÌÉÔÙ ÄÌÑ Secure Sockets Layer
 Summary(uk):   â¦Â̦ÏÔÅËÉ, ÈÅÄÅÒÉ ÔÁ ÕÔÉ̦ÔÉ ÄÌÑ Secure Sockets Layer
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Obsoletes:     libopenssl0-devel
 
 %description devel
@@ -148,7 +152,7 @@ Summary(pt_BR):     Bibliotecas est
 Summary(ru):   óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ ÄÌÑ OpenSSL
 Summary(uk):   óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ ÄÌÑ OpenSSL
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static OpenSSL Toolkit libraries.
@@ -172,28 +176,34 @@ RC4, RSA 
 Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ Ú ×ÉËÏÒÉÓÔÁÎÎÑÍ SSL.
 
 %prep
-%setup -q -n %{name}-%{version}-%{_beta}
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
-for f in ` grep -r "%{_prefix}/local/bin/perl" . | cut -d":" -f1`; do
-perl -pi -e 's#%{_prefix}/local/bin/perl#%{_bindir}/perl#g' $f
-done
+%{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' \
+       `grep -l -r "%{_prefix}/local/bin/perl"`
 
 touch Makefile.*
 
-perl util/perlpath.pl %{_bindir}/perl
+%{__perl} util/perlpath.pl %{__perl}
 
 OPTFLAGS="%{rpmcflags}"
 export OPTFLAGS
+%ifarch %{ix86}
 %ifarch i386 i486
 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared 386
-%endif
-%ifarch i586 i686 athlon
+%else
 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared
 %endif
+%endif
+%ifarch amd64
+./Configure --openssldir=%{_var}/lib/%{name} linux-x86_64 shared
+%endif
 %ifarch ppc
 ./Configure --openssldir=%{_var}/lib/%{name} linux-ppc shared
 %endif
@@ -204,16 +214,21 @@ export OPTFLAGS
 ./Configure --openssldir=%{_var}/lib/%{name} threads linux-sparcv8 shared
 %endif
 
-%{__make} CC="%{__cc}"
-%{__make} rehash CC="%{__cc}"
+%{__make} \
+       CC="%{__cc}" \
+       INSTALLTOP=%{_prefix}
+
+%{__make} rehash \
+       CC="%{__cc}" \
+       INSTALLTOP=%{_prefix}
 
 # Conv PODs to man pages. "openssl_" prefix is added to each manpage
 # to avoid potential conflicts with others packages.
-center="OpenSSL 0.9.6"
-rel="OpenSSL 0.9.6"
+center="OpenSSL 0.9.7"
+rel="OpenSSL 0.9.7"
 
 cd doc/apps || exit 1
-perl -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
+%{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
 
 for pod in *.pod; do
        if [ $pod != "openssl.pod" ]; then
@@ -242,7 +257,7 @@ for dir in ssl crypto; do
                rel="OpenSSL cryptographic library"
        fi
 
-       perl -p -i -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
+       %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
 
        for pod in *.pod; do
                sec=`[ "$pod" = "des_modes.pod" ] && echo 7 || echo 3`;
@@ -256,20 +271,28 @@ for dir in ssl crypto; do
 done
 
 #cd perl
-#perl Makefile.PL
-#make
+#%%{__perl} Makefile.PL \
+#      INSTALLDIRS=vendor
+#%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
-       $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl}
+       $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
+       $RPM_BUILD_ROOT%{_pkgconfigdir}
 
 %{__make} install \
        INSTALLTOP=%{_prefix} \
-       INSTALL_PREFIX=$RPM_BUILD_ROOT
+       INSTALL_PREFIX=$RPM_BUILD_ROOT \
+       MANDIR=%{_mandir}
+
+if [ "%{_prefix}/lib/pkgconfig" != "%{_pkgconfigdir}" ] ; then
+       mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* \
+               $RPM_BUILD_ROOT%{_pkgconfigdir}
+fi
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/ssl/ca-bundle.crt
-install libRSAglue.a libcrypto.a libssl.a $RPM_BUILD_ROOT%{_libdir}
+install libcrypto.a libssl.a $RPM_BUILD_ROOT%{_libdir}
 install lib*.so.*.* $RPM_BUILD_ROOT%{_libdir}
 ln -sf libcrypto.so.*.* $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
 ln -sf libssl.so.*.* $RPM_BUILD_ROOT%{_libdir}/libssl.so
@@ -289,6 +312,7 @@ install doc/apps/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
 install doc/ssl/*.3 doc/crypto/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
 install doc/crypto/*.7 $RPM_BUILD_ROOT%{_mandir}/man7
 install %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
+install %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -312,9 +336,10 @@ rm -rf $RPM_BUILD_ROOT
 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/%{name}/openssl.cnf
 %verify(not md5 size mtime) %config(noreplace) %{_var}/lib/%{name}/openssl.cnf
 %dir %{_datadir}/ssl
-%verify(not md5 size mtime) %config(noreplace)%{_datadir}/ssl/ca-bundle.crt
+%verify(not md5 size mtime) %config(noreplace) %{_datadir}/ssl/ca-bundle.crt
 
 %attr(755,root,root) %{_bindir}/%{name}
+%attr(754,root,root) %{_bindir}/ssl-certificate
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
 %attr(755,root,root) %{_libdir}/%{name}/c_hash
@@ -336,6 +361,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/openssl_gendsa.1*
 %{_mandir}/man1/openssl_genrsa.1*
 %{_mandir}/man1/openssl_nseq.1*
+%{_mandir}/man1/openssl_ocsp.1*
 %{_mandir}/man1/openssl_passwd.1*
 %{_mandir}/man1/openssl_pkcs12.1*
 %{_mandir}/man1/openssl_pkcs7.1*
@@ -367,7 +393,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_includedir}/%{name}
-%{_mandir}/man3/*.3*
+%{_pkgconfigdir}/openssl.pc
+%{_mandir}/man3/openssl*.3*
 %{_mandir}/man7/*.7*
 
 %files static
This page took 0.040363 seconds and 4 git commands to generate.