]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
up to 3.3.0 (fixes CVE-2024-2511)
[packages/openssl.git] / openssl.spec
index a5a96386ca47bc6c7da2942372bc2a2d8ee39f44..424e865990ccf98e7f894d954b11c5af4df0705f 100644 (file)
@@ -1,17 +1,9 @@
-# TODO
-# - consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
-# - find a way to simplify (drop) openssl-optflags.patch, it's pain to update here in pld
 #
 # Conditional build:
 %bcond_without tests   # don't perform "make tests"
 %bcond_without zlib    # zlib: note - enables CVE-2012-4929 vulnerability
-%bcond_without sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
-%bcond_without sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
-%bcond_with    purify  # Compile openssl with "-DPURIFY", useful when one wants to
-                       # use valgrind debugger against openssl-linked programs
-%bcond_with    snap    # use GitHub snapshot to build branch release
+%bcond_with    sslv3   # SSLv3: note - enables CVE-2014-3566 vulnerability
 
-%include       /usr/lib/rpm/macros.perl
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
 Summary(de.UTF-8):     Secure Sockets Layer (SSL)-Kommunikationslibrary
 Summary(es.UTF-8):     Biblioteca C que suministra algoritmos y protocolos criptográficos
@@ -21,47 +13,41 @@ Summary(pt_BR.UTF-8):       Uma biblioteca C que fornece vários algoritmos e protocol
 Summary(ru.UTF-8):     Библиотеки и утилиты для соединений через Secure Sockets Layer
 Summary(uk.UTF-8):     Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
 Name:          openssl
-# 1.0.2 will be LTS release
-# Version 1.0.2 will be supported until 2019-12-31.
-# https://www.openssl.org/about/releasestrat.html
-Version:       1.0.2m
+Version:       3.3.0
 Release:       1
-License:       Apache-like
+License:       Apache v2.0
 Group:         Libraries
-%if %{without snap}
 Source0:       https://www.openssl.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: 10e9e37f492094b9ef296f68f24a7666
-%else
-Source1:       https://github.com/openssl/openssl/archive/OpenSSL_1_0_2-stable/%{name}-%{version}-dev.tar.gz
-# Source1-md5: 6b846f8a4f55f5ddfa1e0d335241840a
-%endif
+# Source0-md5: c8b063afbea85d867e161ecb8816cfa9
 Source2:       %{name}.1.pl
 Source3:       %{name}-ssl-certificate.sh
 Source4:       %{name}-c_rehash.sh
-Patch0:                %{name}-alpha-ccc.patch
-Patch1:                %{name}-optflags.patch
-Patch2:                %{name}-include.patch
-Patch3:                %{name}-man-namespace.patch
-Patch4:                %{name}-asflag.patch
-Patch5:                %{name}-ca-certificates.patch
-Patch6:                %{name}-ldflags.patch
-Patch7:                %{name}-find.patch
-Patch8:                pic.patch
-Patch10:       %{name}_fix_for_x32.patch
+Patch0:                %{name}-optflags.patch
+Patch1:                %{name}-ca-certificates.patch
+Patch2:                %{name}-find.patch
+Patch3:                pic.patch
+Patch4:                engines-dir.patch
 URL:           http://www.openssl.org/
-BuildRequires: bc
-BuildRequires: perl-devel >= 1:5.6.1
+%ifarch %{arm} ppc mips sparc sparcv9
+BuildRequires: libatomic-devel
+%endif
+BuildRequires: libbrotli-devel
+BuildRequires: libsctp-devel
+BuildRequires: linux-libc-headers >= 7:4.13
+BuildRequires: perl-devel >= 1:5.10.0
 BuildRequires: pkgconfig
 BuildRequires: rpm-perlprov >= 4.1-13
-BuildRequires: rpmbuild(macros) >= 1.213
+BuildRequires: rpmbuild(macros) >= 1.745
 BuildRequires: sed >= 4.0
 BuildRequires: zlib-devel
-Requires:      ca-certificates >= 20120623-1.1
+BuildRequires: zstd-devel
+Requires:      ca-certificates >= 20141019-3
 Requires:      rpm-whiteout >= 1.7
-Obsoletes:     SSLeay
-Obsoletes:     SSLeay-devel
-Obsoletes:     SSLeay-perl
-Obsoletes:     libopenssl0
+Obsoletes:     SSLeay < 0.9.3
+Obsoletes:     SSLeay-devel < 0.9.3
+Obsoletes:     SSLeay-perl < 0.9.3
+Obsoletes:     libopenssl0 < 1
+Obsoletes:     openssl-engines < 3.0.0-2
 %if "%{pld_release}" == "ac"
 Conflicts:     neon < 0.26.3-3
 Conflicts:     ntpd < 4.2.4p8-10
@@ -125,53 +111,11 @@ RC4, RSA и SSL.
 користування, що реалізують велику кількість криптографічних
 алгоритмів, включаючи DES, RC4, RSA та SSL.
 
-%package engines
-Summary:       OpenSSL optional crypto engines
-Summary(pl.UTF-8):     Opcjonalne silniki kryptograficzne dla OpenSSL-a
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description engines
-With OpenSSL 0.9.6, a new component was added to support alternative
-cryptography implementations, most commonly for interfacing with
-external crypto devices (eg. accelerator cards). This component is
-called ENGINE.
-
-There are currently built-in ENGINE implementations for the following
-crypto devices:
-
-- CryptoSwift
-- Compaq Atalla
-- nCipher CHIL
-- Nuron
-- Broadcom uBSec
-
-In addition, dynamic binding to external ENGINE implementations is now
-provided by a special ENGINE called "dynamic".
-
-%description engines -l pl.UTF-8
-Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
-wspierać alternatywne implementacje kryptografii, przeważnie
-współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
-kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
-ENGINE).
-
-Obecnie istnieją wbudowane implementacje silników dla następujących
-urządzeń kryptograficznych:
-- CryptoSwift
-- Compaq Atalla
-- nCipher CHIL
-- Nuron
-- Broadcom uBSec
-
-Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
-implementacji silników poprzez specjalny silnik o nazwie "dynamic".
-
 %package tools
 Summary:       OpenSSL command line tool and utilities
 Summary(pl.UTF-8):     Zestaw narzędzi i skryptów
 Group:         Applications/Communications
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}%{?_isa} = %{version}-%{release}
 Requires:      which
 
 %description tools
@@ -202,8 +146,8 @@ Summary(pt_BR.UTF-8):       Bibliotecas e arquivos de inclusão para desenvolvimento O
 Summary(ru.UTF-8):     Библиотеки, хедеры и утилиты для Secure Sockets Layer
 Summary(uk.UTF-8):     Бібліотеки, хедери та утиліти для Secure Sockets Layer
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-Obsoletes:     libopenssl0-devel
+Requires:      %{name}%{?_isa} = %{version}-%{release}
+Obsoletes:     libopenssl0-devel < 1
 
 %description devel
 Development part of OpenSSL library.
@@ -262,51 +206,42 @@ RC4, RSA и SSL. Включает статические библиотеки д
 бібліотеки для розробки програм з використанням SSL.
 
 %prep
-%if %{with snap}
-%setup -qcT -a1
-mv %{name}-OpenSSL_1_0_2-stable/* .
-%else
 %setup -q
-%endif
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
-%patch6 -p1
-%patch7 -p1
-%patch8 -p1
-%ifarch x32
-%patch10 -p1
-%endif
 
-sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
+# fails with enable-sctp as of 1.1.1
+%{__rm} test/recipes/80-test_ssl_new.t
 
 %build
 touch Makefile.*
 
-PERL5LIB=$(pwd) %{__perl} util/perlpath.pl %{__perl}
-
-OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
 PERL="%{__perl}" \
 %{__perl} ./Configure \
+       --prefix=%{_prefix} \
        --openssldir=%{_sysconfdir}/%{name} \
        --libdir=%{_lib} \
+       -Wa,--noexecstack \
        shared \
        threads \
-       %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
        %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
        %{!?with_zlib:no-}zlib \
-       enable-camelia \
+       enable-brotli \
        enable-cms \
        enable-idea \
        enable-md2 \
        enable-mdc2 \
        enable-rc5 \
        enable-rfc3779 \
+       enable-sctp \
        enable-seed \
-       enable-tlsext \
+       enable-camellia \
+       enable-ktls \
+       enable-fips \
+       enable-zstd \
 %ifarch %{x8664}
        enable-ec_nistp_64_gcc_128 \
 %endif
@@ -319,7 +254,7 @@ PERL="%{__perl}" \
 %endif
 %endif
 %ifarch alpha
-       linux-alpha+bwx-gcc
+       linux-alpha-gcc
 %endif
 %ifarch %{x8664}
        linux-x86_64
@@ -345,53 +280,47 @@ PERL="%{__perl}" \
 %ifarch sparc64
        linux64-sparcv9
 %endif
-%ifarch armv4 armv5 armv5t armv5te armv5tel
+%ifarch %{arm}
        linux-armv4
 %endif
+%ifarch aarch64
+       linux-aarch64
+%endif
 
-v=$(awk -F= '/^VERSION/{print $2}' Makefile)
-test "$v" = %{version}%{?with_snap:-dev}
+v=$(awk -F= '/^VERSION=/{print $2}' Makefile)
+test "$v" = %{version}
 
-%{__make} -j1 all rehash %{?with_tests:tests} \
+%{__make} all \
        CC="%{__cc}" \
-       ASFLAG='$(CFLAG) -Wa,--noexecstack' \
+       OPTFLAGS="%{rpmcflags} %{rpmcppflags}" \
        INSTALLTOP=%{_prefix}
 
-# Rename POD sources of man pages. "openssl_" prefix is added to each
-# manpage to avoid potential conflicts with other packages.
-
-for dir in doc/{apps,ssl,crypto}; do
-       cd $dir || exit 1;
-       %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
-
-       for pod in !(openssl*).pod; do
-               mv -f $pod openssl_$pod;
-       done
-       cd ../..
-done
+%if %{with tests}
+%{__make} -j1 tests \
+       CC="%{__cc}" \
+       OPTFLAGS="%{rpmcflags} %{rpmcppflags}" \
+       INSTALLTOP=%{_prefix}
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
        $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
-       $RPM_BUILD_ROOT/%{_lib}/engines \
        $RPM_BUILD_ROOT%{_pkgconfigdir}
 
-%{__make} -j1 install \
-       INSTALLTOP=%{_prefix} \
-       INSTALL_PREFIX=$RPM_BUILD_ROOT \
-       MANDIR=%{_mandir}
+%{__make} install \
+       CC="%{__cc}" \
+       DESTDIR=$RPM_BUILD_ROOT
 
-mv -f $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
-mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
-ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
-ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
+ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
+ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
 
-mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
-rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
+%{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
+%{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
 
-# not installed as individual utilities (see openssl dgst instead)
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dss1,md2,md4,md5,mdc2,ripemd160,sha,sha1,sha224,sha256,sha384,sha512}.1
+# html version of man pages - not packaged
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/html/man[1357]
 
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
@@ -428,98 +357,106 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
-%attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
-%attr(755,root,root) /%{_lib}/libssl.so.*.*.*
+%doc CHANGES.md NEWS.md README.md doc/*.txt
+%attr(755,root,root) /%{_lib}/libcrypto.so.*
+%attr(755,root,root) /%{_lib}/libssl.so.*
+%dir /%{_lib}/engines-3
+%attr(755,root,root) /%{_lib}/engines-3/*.so
+%dir /%{_lib}/ossl-modules
+%attr(755,root,root) /%{_lib}/ossl-modules/fips.so
+%attr(755,root,root) /%{_lib}/ossl-modules/legacy.so
 %dir %{_sysconfdir}/%{name}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ct_log_list.cnf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/fipsmodule.cnf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
 %dir %{_sysconfdir}/%{name}/certs
 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
 %dir %{_datadir}/ssl
-
-%files engines
-%defattr(644,root,root,755)
-%dir /%{_lib}/engines
-%attr(755,root,root) /%{_lib}/engines/*.so
+%{_mandir}/man5/config.5ossl*
 
 %files tools
 %defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
 %attr(755,root,root) %{_bindir}/c_rehash.sh
 %attr(755,root,root) %{_bindir}/openssl
 %attr(754,root,root) %{_bindir}/ssl-certificate
-
-%dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/CA.sh
-%attr(755,root,root) %{_libdir}/%{name}/c_hash
-%attr(755,root,root) %{_libdir}/%{name}/c_info
-%attr(755,root,root) %{_libdir}/%{name}/c_issuer
-%attr(755,root,root) %{_libdir}/%{name}/c_name
-
+%{_mandir}/man1/asn1parse.1ossl*
+%{_mandir}/man1/ca.1ossl*
+%{_mandir}/man1/ciphers.1ossl*
+%{_mandir}/man1/cmp.1ossl*
+%{_mandir}/man1/cms.1ossl*
+%{_mandir}/man1/crl.1ossl*
+%{_mandir}/man1/crl2pkcs7.1ossl*
+%{_mandir}/man1/dgst.1ossl*
+%{_mandir}/man1/dhparam.1ossl*
+%{_mandir}/man1/dsa.1ossl*
+%{_mandir}/man1/dsaparam.1ossl*
+%{_mandir}/man1/ec.1ossl*
+%{_mandir}/man1/ecparam.1ossl*
+%{_mandir}/man1/enc.1ossl*
+%{_mandir}/man1/engine.1ossl*
+%{_mandir}/man1/errstr.1ossl*
+%{_mandir}/man1/gendsa.1ossl*
+%{_mandir}/man1/genpkey.1ossl*
+%{_mandir}/man1/genrsa.1ossl*
+%{_mandir}/man1/info.1ossl*
+%{_mandir}/man1/kdf.1ossl*
+%{_mandir}/man1/mac.1ossl*
+%{_mandir}/man1/nseq.1ossl*
+%{_mandir}/man1/ocsp.1ossl*
 %{_mandir}/man1/openssl.1*
-%{_mandir}/man1/openssl_asn1parse.1*
-%{_mandir}/man1/openssl_ca.1*
-%{_mandir}/man1/openssl_ciphers.1*
-%{_mandir}/man1/openssl_cms.1*
-%{_mandir}/man1/openssl_crl.1*
-%{_mandir}/man1/openssl_crl2pkcs7.1*
-%{_mandir}/man1/openssl_dgst.1*
-%{_mandir}/man1/openssl_dhparam.1*
-%{_mandir}/man1/openssl_dsa.1*
-%{_mandir}/man1/openssl_dsaparam.1*
-%{_mandir}/man1/openssl_ec.1*
-%{_mandir}/man1/openssl_ecparam.1*
-%{_mandir}/man1/openssl_enc.1*
-%{_mandir}/man1/openssl_errstr.1*
-%{_mandir}/man1/openssl_gendsa.1*
-%{_mandir}/man1/openssl_genpkey.1*
-%{_mandir}/man1/openssl_genrsa.1*
-%{_mandir}/man1/openssl_nseq.1*
-%{_mandir}/man1/openssl_ocsp.1*
-%{_mandir}/man1/openssl_passwd.1*
-%{_mandir}/man1/openssl_pkcs12.1*
-%{_mandir}/man1/openssl_pkcs7.1*
-%{_mandir}/man1/openssl_pkcs8.1*
-%{_mandir}/man1/openssl_pkey.1*
-%{_mandir}/man1/openssl_pkeyparam.1*
-%{_mandir}/man1/openssl_pkeyutl.1*
-%{_mandir}/man1/openssl_rand.1*
-%{_mandir}/man1/openssl_req.1*
-%{_mandir}/man1/openssl_rsa.1*
-%{_mandir}/man1/openssl_rsautl.1*
-%{_mandir}/man1/openssl_s_client.1*
-%{_mandir}/man1/openssl_s_server.1*
-%{_mandir}/man1/openssl_s_time.1*
-%{_mandir}/man1/openssl_sess_id.1*
-%{_mandir}/man1/openssl_smime.1*
-%{_mandir}/man1/openssl_speed.1*
-%{_mandir}/man1/openssl_spkac.1*
-%{_mandir}/man1/openssl_ts.1*
-%{_mandir}/man1/openssl_tsget.1*
-%{_mandir}/man1/openssl_verify.1*
-%{_mandir}/man1/openssl_version.1*
-%{_mandir}/man1/openssl_x509.1*
-%{_mandir}/man5/openssl_config.5*
-%{_mandir}/man5/openssl_x509v3_config.5*
+%{_mandir}/man1/openssl-*.1*
+%{_mandir}/man1/passwd.1ossl*
+%{_mandir}/man1/pkcs12.1ossl*
+%{_mandir}/man1/pkcs7.1ossl*
+%{_mandir}/man1/pkcs8.1ossl*
+%{_mandir}/man1/pkey.1ossl*
+%{_mandir}/man1/pkeyparam.1ossl*
+%{_mandir}/man1/pkeyutl.1ossl*
+%{_mandir}/man1/prime.1ossl*
+%{_mandir}/man1/rand.1ossl*
+%{_mandir}/man1/rehash.1ossl*
+%{_mandir}/man1/req.1ossl*
+%{_mandir}/man1/rsa.1ossl*
+%{_mandir}/man1/rsautl.1ossl*
+%{_mandir}/man1/s_client.1ossl*
+%{_mandir}/man1/sess_id.1ossl*
+%{_mandir}/man1/smime.1ossl*
+%{_mandir}/man1/speed.1ossl*
+%{_mandir}/man1/spkac.1ossl*
+%{_mandir}/man1/srp.1ossl*
+%{_mandir}/man1/s_server.1ossl*
+%{_mandir}/man1/s_time.1ossl*
+%{_mandir}/man1/storeutl.1ossl*
+%{_mandir}/man1/ts.1ossl*
+%{_mandir}/man1/verify.1ossl*
+%{_mandir}/man1/version.1ossl*
+%{_mandir}/man1/x509.1ossl*
+%{_mandir}/man5/fips_config.5ossl*
+%{_mandir}/man5/x509v3_config.5ossl*
 %lang(pl) %{_mandir}/pl/man1/openssl.1*
 
 %files tools-perl
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/c_rehash
+%dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
 %attr(755,root,root) %{_libdir}/%{name}/tsget
-%{_mandir}/man1/openssl_CA.pl.1*
-%{_mandir}/man1/openssl_c_rehash.1*
+%attr(755,root,root) %{_libdir}/%{name}/tsget.pl
+%{_mandir}/man1/CA.pl.1ossl*
+%{_mandir}/man1/c_rehash.1ossl*
+%{_mandir}/man1/tsget.1ossl*
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libcrypto.so
 %attr(755,root,root) %{_libdir}/libssl.so
 %{_includedir}/%{name}
+%{_libdir}/cmake/OpenSSL
 %{_pkgconfigdir}/libcrypto.pc
 %{_pkgconfigdir}/libssl.pc
 %{_pkgconfigdir}/openssl.pc
-%{_mandir}/man3/openssl*.3*
-%{_mandir}/man7/openssl_des_modes.7*
+%{_mandir}/man3/*.3ossl*
+%{_mandir}/man7/*.7ossl*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.038957 seconds and 4 git commands to generate.