]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
up to 1.0.2i-snap
[packages/openssl.git] / openssl.spec
index 8b24a2de5553117ce278a0bcc25d2e6d916b7a72..23ccce135194e2c5398e82aa409480251c103833 100644 (file)
@@ -1,13 +1,15 @@
 # TODO
 # - consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
+# - find a way to simplify (drop) openssl-optflags.patch, it's pain to update here in pld
 #
 # Conditional build:
 %bcond_without tests   # don't perform "make tests"
 %bcond_without zlib    # zlib: note - enables CVE-2012-4929 vulnerability
 %bcond_without sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
 %bcond_without sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
-%bcond_with    purify  # Compile openssl with \-DPURIFY, useful when one wants to
+%bcond_with    purify  # Compile openssl with "-DPURIFY", useful when one wants to
                        # use valgrind debugger against openssl-linked programs
+%bcond_with    snap    # use GitHub snapshot to build branch release
 
 %include       /usr/lib/rpm/macros.perl
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
@@ -19,12 +21,19 @@ Summary(pt_BR.UTF-8):       Uma biblioteca C que fornece vários algoritmos e protocol
 Summary(ru.UTF-8):     Библиотеки и утилиты для соединений через Secure Sockets Layer
 Summary(uk.UTF-8):     Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
 Name:          openssl
-Version:       1.0.2b
+# 1.0.2 will be LTS release
+# Version 1.0.2 will be supported until 2019-12-31.
+# https://www.openssl.org/about/releasestrat.html
+Version:       1.0.2i
 Release:       1
 License:       Apache-like
 Group:         Libraries
-Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: 7729b259e2dea7d60b32fc3934d6984b
+%if %{without snap}
+Source0:       https://www.openssl.org/source/%{name}-%{version}.tar.gz
+# Source0-md5: 9392e65072ce4b614c1392eefc1f23d0
+%else
+Source1:       https://github.com/openssl/openssl/archive/OpenSSL_1_0_2-stable/%{name}-%{version}-dev.tar.gz
+%endif
 Source2:       %{name}.1.pl
 Source3:       %{name}-ssl-certificate.sh
 Source4:       %{name}-c_rehash.sh
@@ -44,13 +53,18 @@ BuildRequires:      perl-devel >= 1:5.6.1
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpmbuild(macros) >= 1.213
 BuildRequires: sed >= 4.0
-Requires:      ca-certificates >= 20080809-4
+Requires:      ca-certificates >= 20120623-1.1
 Requires:      rpm-whiteout >= 1.7
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
 Obsoletes:     SSLeay-perl
 Obsoletes:     libopenssl0
-%if "%{pld_release}" != "ac"
+%if "%{pld_release}" == "ac"
+Conflicts:     neon < 0.26.3-3
+Conflicts:     ntpd < 4.2.4p8-10
+Conflicts:     openssh-clients < 2:5.8p1-9
+Conflicts:     openssh-server < 2:5.8p1-9
+%else
 Conflicts:     neon < 0.29.6-8
 Conflicts:     openssh-clients < 2:6.2p2-3
 Conflicts:     openssh-server < 2:6.2p2-3
@@ -245,7 +259,12 @@ RC4, RSA и SSL. Включает статические библиотеки д
 бібліотеки для розробки програм з використанням SSL.
 
 %prep
+%if %{with snap}
+%setup -qcT -a1
+mv %{name}-OpenSSL_1_0_2-stable/* .
+%else
 %setup -q
+%endif
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -255,7 +274,9 @@ RC4, RSA и SSL. Включает статические библиотеки д
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%ifarch x32
 %patch10 -p1
+%endif
 
 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
 
@@ -271,8 +292,8 @@ PERL="%{__perl}" \
        --libdir=%{_lib} \
        shared \
        threads \
-       %{!?with_sslv2:no-ssl2} \
-       %{!?with_sslv3:no-ssl3} \
+       %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
+       %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
        %{!?with_zlib:no-}zlib \
        enable-camelia \
        enable-cms \
@@ -325,6 +346,9 @@ PERL="%{__perl}" \
        linux-armv4
 %endif
 
+v=$(awk -F= '/^VERSION/{print $2}' Makefile)
+test "$v" = %{version}%{?with_snap:-dev}
+
 %{__make} -j1 all rehash %{?with_tests:tests} \
        CC="%{__cc}" \
        ASFLAG='$(CFLAG) -Wa,--noexecstack' \
@@ -402,12 +426,11 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
-%doc doc/openssl_button.gif doc/openssl_button.html
 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
 %dir %{_sysconfdir}/%{name}
 %dir %{_sysconfdir}/%{name}/certs
-%dir %{_sysconfdir}/%{name}/private
+%dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
 %dir %{_datadir}/ssl
 
 %files engines
This page took 0.077029 seconds and 4 git commands to generate.