]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
up to 1.0.2i-snap
[packages/openssl.git] / openssl.spec
index 40a65e9ccc384f7e6ac7cfd9e048f698fdf95de1..23ccce135194e2c5398e82aa409480251c103833 100644 (file)
@@ -1,10 +1,15 @@
-#
-# TODO: consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
+# TODO
+# - consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
+# - find a way to simplify (drop) openssl-optflags.patch, it's pain to update here in pld
 #
 # Conditional build:
 %bcond_without tests   # don't perform "make tests"
-%bcond_with    purify  # Compile openssl with \-DPURIFY, useful when one wants to
+%bcond_without zlib    # zlib: note - enables CVE-2012-4929 vulnerability
+%bcond_without sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
+%bcond_without sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
+%bcond_with    purify  # Compile openssl with "-DPURIFY", useful when one wants to
                        # use valgrind debugger against openssl-linked programs
+%bcond_with    snap    # use GitHub snapshot to build branch release
 
 %include       /usr/lib/rpm/macros.perl
 Summary:       OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
@@ -16,45 +21,54 @@ Summary(pt_BR.UTF-8):       Uma biblioteca C que fornece vários algoritmos e protocol
 Summary(ru.UTF-8):     Библиотеки и утилиты для соединений через Secure Sockets Layer
 Summary(uk.UTF-8):     Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
 Name:          openssl
-Version:       1.0.1e
-Release:       2
+# 1.0.2 will be LTS release
+# Version 1.0.2 will be supported until 2019-12-31.
+# https://www.openssl.org/about/releasestrat.html
+Version:       1.0.2i
+Release:       1
 License:       Apache-like
 Group:         Libraries
-Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: 66bf6f10f060d561929de96f9dfe5b8c
+%if %{without snap}
+Source0:       https://www.openssl.org/source/%{name}-%{version}.tar.gz
+# Source0-md5: 9392e65072ce4b614c1392eefc1f23d0
+%else
+Source1:       https://github.com/openssl/openssl/archive/OpenSSL_1_0_2-stable/%{name}-%{version}-dev.tar.gz
+%endif
 Source2:       %{name}.1.pl
 Source3:       %{name}-ssl-certificate.sh
 Source4:       %{name}-c_rehash.sh
 Patch0:                %{name}-alpha-ccc.patch
 Patch1:                %{name}-optflags.patch
-Patch2:                %{name}-globalCA.diff
-Patch3:                %{name}-include.patch
-Patch4:                %{name}-man-namespace.patch
-Patch5:                %{name}-asflag.patch
-Patch6:                %{name}-ca-certificates.patch
-Patch7:                %{name}-ldflags.patch
-
-# from debian
-Patch10:       aesni-mac.patch
-Patch11:       cpuid.patch
-Patch12:       default_bits.patch
-Patch13:       dtls_version.patch
-Patch14:       get_certificate.patch
-Patch15:       pic.patch
-Patch16:       stddef.patch
-
+Patch2:                %{name}-include.patch
+Patch3:                %{name}-man-namespace.patch
+Patch4:                %{name}-asflag.patch
+Patch5:                %{name}-ca-certificates.patch
+Patch6:                %{name}-ldflags.patch
+Patch7:                %{name}-find.patch
+Patch8:                pic.patch
+Patch10:       %{name}_fix_for_x32.patch
 URL:           http://www.openssl.org/
 BuildRequires: bc
 BuildRequires: perl-devel >= 1:5.6.1
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpmbuild(macros) >= 1.213
 BuildRequires: sed >= 4.0
-Requires:      ca-certificates >= 20080809-4
+Requires:      ca-certificates >= 20120623-1.1
 Requires:      rpm-whiteout >= 1.7
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
 Obsoletes:     SSLeay-perl
 Obsoletes:     libopenssl0
+%if "%{pld_release}" == "ac"
+Conflicts:     neon < 0.26.3-3
+Conflicts:     ntpd < 4.2.4p8-10
+Conflicts:     openssh-clients < 2:5.8p1-9
+Conflicts:     openssh-server < 2:5.8p1-9
+%else
+Conflicts:     neon < 0.29.6-8
+Conflicts:     openssh-clients < 2:6.2p2-3
+Conflicts:     openssh-server < 2:6.2p2-3
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -130,14 +144,14 @@ crypto devices:
 - Broadcom uBSec
 
 In addition, dynamic binding to external ENGINE implementations is now
-provided by a special ENGINE called "dynamic". 
+provided by a special ENGINE called "dynamic".
 
 %description engines -l pl.UTF-8
 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
 wspierać alternatywne implementacje kryptografii, przeważnie
 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
-kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM
-(ang. ENGINE).
+kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
+ENGINE).
 
 Obecnie istnieją wbudowane implementacje silników dla następujących
 urządzeń kryptograficznych:
@@ -245,7 +259,12 @@ RC4, RSA и SSL. Включает статические библиотеки д
 бібліотеки для розробки програм з використанням SSL.
 
 %prep
+%if %{with snap}
+%setup -qcT -a1
+mv %{name}-OpenSSL_1_0_2-stable/* .
+%else
 %setup -q
+%endif
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -254,14 +273,10 @@ RC4, RSA и SSL. Включает статические библиотеки д
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-
+%patch8 -p1
+%ifarch x32
 %patch10 -p1
-%patch11 -p1
-%patch12 -p1
-%patch13 -p1
-%patch14 -p1
-%patch15 -p1
-%patch16 -p1
+%endif
 
 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
 
@@ -277,16 +292,21 @@ PERL="%{__perl}" \
        --libdir=%{_lib} \
        shared \
        threads \
-       zlib \
-       enable-tlsext \
-       enable-seed \
-       enable-rfc3779 \
+       %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
+       %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
+       %{!?with_zlib:no-}zlib \
        enable-camelia \
        enable-cms \
        enable-idea \
-       enable-mdc2 \
        enable-md2 \
+       enable-mdc2 \
        enable-rc5 \
+       enable-rfc3779 \
+       enable-seed \
+       enable-tlsext \
+%ifarch %{x8664}
+       enable-ec_nistp_64_gcc_128 \
+%endif
 %ifarch %{ix86}
 %ifarch i386
        386 linux-elf
@@ -301,6 +321,9 @@ PERL="%{__perl}" \
 %ifarch %{x8664}
        linux-x86_64
 %endif
+%ifarch x32
+       linux-x32
+%endif
 %ifarch ia64
        linux-ia64
 %endif
@@ -323,6 +346,9 @@ PERL="%{__perl}" \
        linux-armv4
 %endif
 
+v=$(awk -F= '/^VERSION/{print $2}' Makefile)
+test "$v" = %{version}%{?with_snap:-dev}
+
 %{__make} -j1 all rehash %{?with_tests:tests} \
        CC="%{__cc}" \
        ASFLAG='$(CFLAG) -Wa,--noexecstack' \
@@ -362,7 +388,7 @@ mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{n
 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
 
 # not installed as individual utilities (see openssl dgst instead)
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{md2,md4,md5,mdc2,ripemd160,sha,sha1}.1
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dss1,md2,md4,md5,mdc2,ripemd160,sha,sha1,sha224,sha256,sha384,sha512}.1
 
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
@@ -400,15 +426,15 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
-%doc doc/openssl_button.gif doc/openssl_button.html
 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
 %dir %{_sysconfdir}/%{name}
 %dir %{_sysconfdir}/%{name}/certs
-%dir %{_sysconfdir}/%{name}/private
+%dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
 %dir %{_datadir}/ssl
 
 %files engines
+%defattr(644,root,root,755)
 %dir /%{_lib}/engines
 %attr(755,root,root) /%{_lib}/engines/*.so
 
@@ -479,6 +505,7 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
 %attr(755,root,root) %{_libdir}/%{name}/tsget
 %{_mandir}/man1/openssl_CA.pl.1*
+%{_mandir}/man1/openssl_c_rehash.1*
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.030871 seconds and 4 git commands to generate.