]> git.pld-linux.org Git - packages/openssl.git/blobdiff - openssl.spec
- hack to fix build on i386
[packages/openssl.git] / openssl.spec
index 080ea47630d395051a1e0122bba61aed4cabf402..0c8e8119d4377705b4c64feaddfa002dfb665e58 100644 (file)
@@ -8,26 +8,27 @@ Summary(pt_BR):       Uma biblioteca C que fornece v
 Summary(ru):   âÉÂÌÉÏÔÅËÉ É ÕÔÉÌÉÔÙ ÄÌÑ ÓÏÅÄÉÎÅÎÉÊ ÞÅÒÅÚ Secure Sockets Layer
 Summary(uk):   â¦Â̦ÏÔÅËÉ ÔÁ ÕÔÉ̦ÔÉ ÄÌÑ Ú'¤ÄÎÁÎØ ÞÅÒÅÚ Secure Sockets Layer
 Name:          openssl
-Version:       0.9.7b
-Release:       0.1
+Version:       0.9.7e
+Release:       1
 License:       Apache-style License
 Group:         Libraries
 Source0:       ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
+# Source0-md5: a8777164bca38d84e5eb2b1535223474
 Source1:       %{name}-ca-bundle.crt
 Source2:       %{name}.1.pl
+Source3:       %{name}-ssl-certificate.sh
 Patch0:                %{name}-alpha-ccc.patch
 Patch1:                %{name}-optflags.patch
 Patch2:                %{name}-globalCA.diff
-Patch3:                %{name}-parallel_make.patch
+Patch3:                %{name}-include.patch
 URL:           http://www.openssl.org/
-BuildRequires: perl-devel >= 5.6.1
-BuildRequires: textutils
-BuildRequires: perl-tools-pod
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+BuildRequires: perl-devel >= 1:5.6.1
+BuildRequires: rpm-perlprov >= 4.1-13
 Obsoletes:     SSLeay
 Obsoletes:     SSLeay-devel
 Obsoletes:     SSLeay-perl
 Obsoletes:     libopenssl0
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 The OpenSSL Project is a collaborative effort to develop a robust,
@@ -84,7 +85,7 @@ RC4, RSA 
 Summary:       OpenSSL command line tool and utilities
 Summary(pl):   Zestaw narzêdzi i skryptów
 Group:         Applications/Communications
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description tools
 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
@@ -96,7 +97,7 @@ Zestaw narz
 Summary:       OpenSSL utilities written in Perl
 Summary(pl):   Narzêdzia OpenSSL napisane w perlu
 Group:         Applications/Communications
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description tools-perl
 OpenSSL Toolkit tools written in Perl.
@@ -114,7 +115,7 @@ Summary(pt_BR):     Bibliotecas e arquivos de inclus
 Summary(ru):   âÉÂÌÉÏÔÅËÉ, ÈÅÄÅÒÙ É ÕÔÉÌÉÔÙ ÄÌÑ Secure Sockets Layer
 Summary(uk):   â¦Â̦ÏÔÅËÉ, ÈÅÄÅÒÉ ÔÁ ÕÔÉ̦ÔÉ ÄÌÑ Secure Sockets Layer
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Obsoletes:     libopenssl0-devel
 
 %description devel
@@ -124,7 +125,7 @@ Development part of OpenSSL library.
 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
 
 %description devel -l pl
-Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
+Czê¶æ biblioteki OpenSSL przeznaczona dla programistów.
 
 %description devel -l pt_BR
 Uma biblioteca C que fornece vários algoritmos e protocolos
@@ -150,7 +151,7 @@ Summary(pt_BR):     Bibliotecas est
 Summary(ru):   óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ ÄÌÑ OpenSSL
 Summary(uk):   óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ ÄÌÑ OpenSSL
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static OpenSSL Toolkit libraries.
@@ -180,10 +181,13 @@ RC4, RSA 
 %patch2 -p1
 %patch3 -p1
 
+# conflicts with i386-only DES implementation
+# (missing #ifdef OPENSSL_FIPS  ...  #endif)
+:> fips/des/asm/fips-dx86-elf.s
+
 %build
-for f in ` grep -r "%{_prefix}/local/bin/perl" . | cut -d":" -f1`; do
-%{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' $f
-done
+%{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' \
+       `grep -l -r "%{_prefix}/local/bin/perl" *`
 
 touch Makefile.*
 
@@ -191,24 +195,43 @@ touch Makefile.*
 
 OPTFLAGS="%{rpmcflags}"
 export OPTFLAGS
-%ifarch i386 i486
+%ifarch %{ix86}
+%ifarch i386
+# allow running on 80386 (default code uses bswapl available on i486+)
 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared 386
-%endif
-%ifarch i586 i686 athlon
+%else
 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared
 %endif
-%ifarch ppc
-./Configure --openssldir=%{_var}/lib/%{name} linux-ppc shared
 %endif
 %ifarch alpha
 ./Configure --openssldir=%{_var}/lib/%{name} threads linux-alpha+bwx-gcc shared
 %endif
+%ifarch amd64
+./Configure --openssldir=%{_var}/lib/%{name} linux-x86_64 shared
+%endif
+%ifarch ia64
+./Configure --openssldir=%{_var}/lib/%{name} linux-ia64 shared
+%endif
+%ifarch ppc
+./Configure --openssldir=%{_var}/lib/%{name} linux-ppc shared
+%endif
 %ifarch sparc
 ./Configure --openssldir=%{_var}/lib/%{name} threads linux-sparcv8 shared
 %endif
+%ifarch sparcv9
+./Configure --openssldir=%{_var}/lib/%{name} threads linux-sparcv9 shared
+%endif
+%ifarch sparc64
+./Configure --openssldir=%{_var}/lib/%{name} threads linux64-sparcv9 shared
+%endif
+
+%{__make} \
+       CC="%{__cc}" \
+       INSTALLTOP=%{_prefix}
 
-%{__make} CC="%{__cc}"
-%{__make} rehash CC="%{__cc}"
+%{__make} rehash \
+       CC="%{__cc}" \
+       INSTALLTOP=%{_prefix}
 
 # Conv PODs to man pages. "openssl_" prefix is added to each manpage
 # to avoid potential conflicts with others packages.
@@ -261,18 +284,25 @@ done
 #cd perl
 #%%{__perl} Makefile.PL \
 #      INSTALLDIRS=vendor
-#make
+#%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
-       $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl}
+       $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
+       $RPM_BUILD_ROOT%{_pkgconfigdir}
 
 %{__make} install \
+       CC="%{__cc}" \
        INSTALLTOP=%{_prefix} \
        INSTALL_PREFIX=$RPM_BUILD_ROOT \
        MANDIR=%{_mandir}
 
+if [ "%{_prefix}/lib/pkgconfig" != "%{_pkgconfigdir}" ] ; then
+       mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* \
+               $RPM_BUILD_ROOT%{_pkgconfigdir}
+fi
+
 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/ssl/ca-bundle.crt
 install libcrypto.a libssl.a $RPM_BUILD_ROOT%{_libdir}
 install lib*.so.*.* $RPM_BUILD_ROOT%{_libdir}
@@ -294,7 +324,8 @@ install doc/apps/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
 install doc/ssl/*.3 doc/crypto/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
 install doc/crypto/*.7 $RPM_BUILD_ROOT%{_mandir}/man7
 install %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
-
+install %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
+install fips/openssl_fips_fingerprint $RPM_BUILD_ROOT%{_bindir}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -306,20 +337,23 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
 %doc doc/openssl_button.gif doc/openssl_button.html
+%dir %{_var}/lib/%{name}
+%dir %{_var}/lib/%{name}/certs
+%dir %{_var}/lib/%{name}/private
 
 %files tools
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/%{name}
-%dir %{_var}/lib/%{name}
-%dir %{_var}/lib/%{name}/private
-%dir %{_var}/lib/%{name}/certs
 
 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/%{name}/openssl.cnf
 %verify(not md5 size mtime) %config(noreplace) %{_var}/lib/%{name}/openssl.cnf
 %dir %{_datadir}/ssl
-%verify(not md5 size mtime) %config(noreplace)%{_datadir}/ssl/ca-bundle.crt
+%verify(not md5 size mtime) %config(noreplace) %{_datadir}/ssl/ca-bundle.crt
 
 %attr(755,root,root) %{_bindir}/%{name}
+%attr(755,root,root) %{_bindir}/openssl_fips_fingerprint
+%attr(754,root,root) %{_bindir}/ssl-certificate
+
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
 %attr(755,root,root) %{_libdir}/%{name}/c_hash
@@ -352,6 +386,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/openssl_rsautl.1*
 %{_mandir}/man1/openssl_s_client.1*
 %{_mandir}/man1/openssl_s_server.1*
+%{_mandir}/man1/openssl_s_time.1*
 %{_mandir}/man1/openssl_sess_id.1*
 %{_mandir}/man1/openssl_smime.1*
 %{_mandir}/man1/openssl_speed.1*
@@ -373,7 +408,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_includedir}/%{name}
-%{_libdir}/pkgconfig/openssl.pc
+%{_pkgconfigdir}/openssl.pc
 %{_mandir}/man3/openssl*.3*
 %{_mandir}/man7/*.7*
 
This page took 0.051898 seconds and 4 git commands to generate.