]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- added using %%{__make} macro.
[packages/openssl.git] / openssl.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
3 Summary(de):    Secure Sockets Layer (SSL)-Kommunikationslibrary & Utilities
4 Summary(fr):    Utilitaires et librairies de communication SSL (Secure Sockets Layer)
5 Name:           openssl
6 Version:        0.9.5a
7 Release:        3
8 Group:          Libraries
9 Group(fr):      Librairies
10 Group(pl):      Biblioteki
11 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
12 Patch0:         openssl-perl.patch
13 Vendor:         The OpenSSL Project
14 License:        Apache-style License
15 BuildRequires:  symlinks
16 BuildRequires:  perl
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18 Prereq:         fileutils
19 Prereq:         sed
20 Obsoletes:      SSLeay
21 Obsoletes:      SSLeay-devel
22 Obsoletes:      SSLeay-perl
23
24 %define         openssldir      /var/lib/openssl
25 %define         _sysconfdir     /etc/%{name}
26 %define         _pkglibdir      %{_libdir}/%{name}
27 %define         _pkgincludedir  %{_includedir}/%{name}
28
29 %description
30 The OpenSSL Project is a collaborative effort to develop a robust,
31 commercial-grade, full-featured, and Open Source toolkit implementing
32 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
33 v1) protocols with full-strength cryptography world-wide. The project
34 is managed by a worldwide community of volunteers that use the
35 Internet to communicate, plan, and develop the OpenSSL tookit and its
36 related documentation.
37
38 OpenSSL is based on the excellent SSLeay library developed by Eric A.
39 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
40 Apache-style licence, which basically means that you are free to get
41 and use it for commercial and non-commercial purposes subject to some
42 simple license conditions.
43
44 %description -l de
45 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
46 libraries, die verschiedene Verschlüsselungs- und
47 Entschlüsselungsalgorithmen und
48 - -protokolle, wie DES, RC4, RSA und SSL zur Verfügung stellen.
49
50 %description -l fr
51 OpenSSL est un outiil de gestion des certificats et les librairies
52 partagees qui fournit plusieurs protocoles et algorithmes de
53 codage/decodage, incluant DES, RC4, RSA et SSL.
54
55 %package devel
56 Summary:        Development part of OpenSSL library
57 Summary(de):    Secure Sockets Layer Kommunikationslibrary: statische libraries+header                           
58 Summary(fr):    Librairies statiques, headers et utilitaires pour communication SSL (Secure Sockets Layer)
59 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
60 Group:          Development/Libraries
61 Group(fr):      Development/Librairies
62 Group(pl):      Programowanie/Biblioteki
63 Requires:       %{name} = %{version}
64
65 %description devel
66 Development part of OpenSSL library.
67
68 %description devel -l pl
69 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
70
71 %package static
72 Summary:        Static OpenSSL library
73 Summary(pl):    Statyczna wersja biblioteki OpenSSL
74 Group:          Development/Libraries
75 Group(fr):      Development/Librairies
76 Group(pl):      Programowanie/Biblioteki
77 Requires:       %{name}-devel = %{version}
78
79 %description static
80 Static OpenSSL library.
81
82 %description static -l pl
83 Statyczna wersja biblioteki OpenSSL.
84
85 %prep
86 %setup -q 
87 %patch -p1
88
89 %build
90 for i in Configure Makefile.org ; do
91         perl -pi -e 's#-m486##g' $i
92         perl -pi -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' $i
93 done
94
95 perl util/perlpath.pl %{_bindir}
96
97 ./config --openssldir=%{openssldir}
98
99 %{__make} OPT_FLAGS="$RPM_OPT_FLAGS" linux-shared
100 %{__make} INSTALLTOP=%{_prefix} OPT_FLAGS="$RPM_OPT_FLAGS"
101 %{__make} rehash
102 #cd perl
103 #perl Makefile.PL
104 #make
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
110
111 %{__make} install \
112         INSTALLTOP=%{_prefix} \
113         INSTALL_PREFIX=$RPM_BUILD_ROOT
114
115 install libRSAglue.a    $RPM_BUILD_ROOT%{_libdir}
116 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
117 cp -d   lib*.so         $RPM_BUILD_ROOT%{_libdir}
118
119 #cd perl
120 #make install DESTDIR=$RPM_BUILD_ROOT
121 #cd ..
122
123 mv $RPM_BUILD_ROOT%{openssldir}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}
124 ln -s %{_sysconfdir}/openssl.cnf \
125         $RPM_BUILD_ROOT%{openssldir}/openssl.cnf
126 symlinks -cs $RPM_BUILD_ROOT%{openssldir}
127
128 mv $RPM_BUILD_ROOT%{openssldir}/misc/*  $RPM_BUILD_ROOT%{_pkglibdir}
129 rm -rf $RPM_BUILD_ROOT%{openssldir}/misc
130
131 strip $RPM_BUILD_ROOT%{_bindir}/* || :
132 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
133
134 gzip -9nf CHANGES CHANGES.SSLeay LICENSE NEWS README \
135         doc/*.txt doc/*/*pod
136
137 %post
138 %{_bindir}/c_rehash certs
139 /sbin/ldconfig
140
141 %postun -p /sbin/ldconfig
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 %defattr(644,root,root,755)
148 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
149 %doc doc/*.txt.gz doc/apps 
150 %doc doc/openssl_button.gif doc/openssl_button.html
151
152 %attr(755,root,root) %{_bindir}/*
153 %dir %{_sysconfdir}
154 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/openssl.cnf
155 %verify(not md5 size mtime) %config(noreplace) %{openssldir}/openssl.cnf
156 %{openssldir}/certs
157 %{openssldir}/private
158 %dir %{_pkglibdir}
159 %attr(755,root,root) %{_pkglibdir}/*
160 %attr(755,root,root) %{_libdir}/lib*.so.*.*
161
162 %files devel
163 %defattr(644,root,root,755)
164 %doc doc/ssl doc/crypto
165 %attr(755,root,root) %{_libdir}/lib*.so
166 %{_pkgincludedir}
167
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/lib*.a
This page took 0.044159 seconds and 4 git commands to generate.