]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- release++
[packages/openssl.git] / openssl.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
3 Summary(de):    Secure Sockets Layer (SSL)-Kommunikationslibrary & Utilities
4 Summary(fr):    Utilitaires et librairies de communication SSL (Secure Sockets Layer)
5 Name:           openssl
6 Version:        0.9.5
7 Release:        2
8 Group:          Libraries
9 Group(pl):      Biblioteki
10 Source:         ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
11 Patch:          openssl-perl.patch
12 Vendor:         The OpenSSL Project
13 License:        Apache-style License
14 BuildRequires:  symlinks
15 BuildRequires:  perl
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17 Obsoletes:      SSLeay
18 Obsoletes:      SSLeay-devel
19 Obsoletes:      SSLeay-perl
20
21 %define         openssldir      /var/lib/openssl
22 %define         _sysconfdir     /etc/%{name}
23 %define         _pkglibdir      %{_libdir}/%{name}
24 %define         _pkgincludedir  %{_includedir}/%{name}
25
26 %description
27 The OpenSSL Project is a collaborative effort to develop a robust,
28 commercial-grade, full-featured, and Open Source toolkit implementing
29 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
30 v1) protocols with full-strength cryptography world-wide. The project
31 is managed by a worldwide community of volunteers that use the
32 Internet to communicate, plan, and develop the OpenSSL tookit and its
33 related documentation.
34    
35 OpenSSL is based on the excellent SSLeay library developed by Eric A.
36 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
37 Apache-style licence, which basically means that you are free to get
38 and use it for commercial and non-commercial purposes subject to some
39 simple license conditions.
40
41 %description -l de
42 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared libraries,
43 die verschiedene Verschlüsselungs- und Entschlüsselungsalgorithmen und
44 -protokolle, wie DES, RC4, RSA und SSL zur Verfügung stellen.                                                 
45
46 %description -l fr
47 OpenSSL est un outiil de gestion des certificats et les librairies partagees
48 qui fournit plusieurs protocoles et algorithmes de codage/decodage, incluant
49 DES, RC4, RSA et SSL.
50
51 %package devel
52 Summary:        Development part of OpenSSL library
53 Summary(de):    Secure Sockets Layer Kommunikationslibrary: statische libraries+header                           
54 Summary(fr):    Librairies statiques, headers et utilitaires pour communication SSL (Secure Sockets Layer)
55 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
56 Group:          Development/Libraries
57 Group(pl):      Programowanie/Biblioteki
58 Requires:       %{name} = %{version}
59
60 %description devel
61 Development part of OpenSSL library.
62
63 %description devel -l pl
64 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
65
66 %package static
67 Summary:        Static OpenSSL library
68 Summary(pl):    Statyczna wersja biblioteki OpenSSL
69 Group:          Development/Libraries
70 Group(pl):      Programowanie/Biblioteki
71 Requires:       %{name}-devel = %{version}
72
73 %description static
74 Static OpenSSL library.
75
76 %description static -l pl
77 Statyczna wersja biblioteki OpenSSL.
78
79 %prep
80 %setup -q 
81 %patch -p1 
82
83 %build
84 for i in Configure Makefile.org ; do
85         perl -pi -e 's#-m486##g' $i
86         perl -pi -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' $i
87 done
88
89 perl util/perlpath.pl %{_bindir}
90
91 ./config --openssldir=%{openssldir}
92
93 make OPT_FLAGS="$RPM_OPT_FLAGS" linux-shared
94 make INSTALLTOP=%{_prefix} OPT_FLAGS="$RPM_OPT_FLAGS"
95 make rehash
96 #cd perl
97 #perl Makefile.PL
98 #make
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
104
105 make install \
106         INSTALLTOP=%{_prefix} \
107         INSTALL_PREFIX=$RPM_BUILD_ROOT
108
109 install libRSAglue.a    $RPM_BUILD_ROOT%{_libdir}
110 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
111 cp -d   lib*.so         $RPM_BUILD_ROOT%{_libdir}
112
113 #cd perl
114 #make install DESTDIR=$RPM_BUILD_ROOT
115 #cd ..
116
117 mv $RPM_BUILD_ROOT%{openssldir}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}
118 ln -s %{_sysconfdir}/openssl.cnf \
119         $RPM_BUILD_ROOT%{openssldir}/openssl.cnf
120 symlinks -cs $RPM_BUILD_ROOT%{openssldir}
121
122 mv $RPM_BUILD_ROOT%{openssldir}/misc/*  $RPM_BUILD_ROOT%{_pkglibdir}
123 rm -rf $RPM_BUILD_ROOT%{openssldir}/misc
124
125 strip $RPM_BUILD_ROOT%{_bindir}/* || :
126 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* || :
127
128 gzip -9fn CHANGES CHANGES.SSLeay LICENSE NEWS README \
129         doc/*.txt doc/*/*pod
130
131 %post
132 %{_bindir}/c_rehash certs
133 /sbin/ldconfig
134
135 %postun -p /sbin/ldconfig
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %files
141 %defattr(644,root,root,755)
142 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
143 %doc doc/*.txt.gz doc/apps 
144 %doc doc/openssl_button.gif doc/openssl_button.html
145
146 %attr(755,root,root) %{_bindir}/*
147 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/openssl.cnf
148 %verify(not md5 size mtime) %config(noreplace) %{openssldir}/openssl.cnf
149 %{openssldir}/certs
150 %{openssldir}/private
151 %dir %{_pkglibdir}
152 %attr(755,root,root) %{_pkglibdir}/*
153 %attr(755,root,root) %{_libdir}/lib*.so.*.*
154
155 %files devel
156 %defattr(644,root,root,755)
157 %doc doc/ssl doc/crypto
158 %attr(755,root,root) %{_libdir}/lib*.so
159 %{_pkgincludedir}
160
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/lib*.a
This page took 0.061593 seconds and 4 git commands to generate.