]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- switch to rpm 3.0.2
[packages/openssl.git] / openssl.spec
1 Summary:        Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
2 Summary(de):    Secure Sockets Layer (SSL)-Kommunikationslibrary & Utilities
3 Name:           openssl
4 Version:        0.9.3a
5 Release:        1
6 Group:          Libraries
7 Group(pl):      Biblioteki
8 Source:         ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
9 Patch0:         openssl-sslcrypto.patch
10 Patch1:         openssl-perl.patch
11 Vendor:         The OpenSSL Project
12 License:        Apache-style License
13 BuildRequires:  perl
14 BuildRoot:      /tmp/%{name}-%{version}-root
15 Obsoletes:      SSLeay
16 Obsoletes:      SSLeay-devel
17 Obsoletes:      SSLeay-perl
18
19 %define         openssldir      /var/state/openssl
20 %define         _sysconfdir     /etc/%{name}
21 %define         _pkglibdir      %{_libdir}/%{name}
22 %define         _pkgincludedir  %{_includedir}/%{name}
23
24 %description
25 The OpenSSL Project is a collaborative effort to develop a robust,
26 commercial-grade, full-featured, and Open Source toolkit implementing
27 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
28 v1) protocols with full-strength cryptography world-wide. The project
29 is managed by a worldwide community of volunteers that use the
30 Internet to communicate, plan, and develop the OpenSSL tookit and its
31 related documentation.
32    
33 OpenSSL is based on the excellent SSLeay library developed by Eric A.
34 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
35 Apache-style licence, which basically means that you are free to get
36 and use it for commercial and non-commercial purposes subject to some
37 simple license conditions.
38
39 %description -l de
40 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared libraries,
41 die verschiedene Verschlüsselungs- und Entschlüsselungsalgorithmen und
42 -protokolle, wie DES, RC4, RSA und SSL zur Verfügung stellen.                                                 
43
44 %description -l fr
45 OpenSSL est un outiil de gestion des certificats et les librairies partagees
46 qui fournit plusieurs protocoles et algorithmes de codage/decodage, incluant
47 DES, RC4, RSA et SSL.
48
49 %package devel
50 Summary:        Development part of OpenSSL library
51 Summary(fr):    Librairies statiques, headers et utilitaires pour communication SSL (Secure Sockets Layer)
52 Summary(de):    Secure Sockets Layer Kommunikationslibrary: statische libraries+header                           
53 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
54 Group:          Development/Libraries
55 Group(pl):      Programowanie/Biblioteki
56 Requires:       %{name} = %{version}
57
58 %description devel
59 Development part of OpenSSL library.
60
61 %description devel -l pl
62 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
63
64 %package static
65 Summary:        Static OpenSSL library
66 Summary(pl):    Statyczna wersja biblioteki OpenSSL
67 Group:          Development/Libraries
68 Group(pl):      Programowanie/Biblioteki
69 Requires:       %{name}-devel = %{version}
70
71 %description static
72 Static OpenSSL library.
73
74 %description static -l pl
75 Statyczna wersja biblioteki OpenSSL.
76
77 %prep
78 %setup  -q 
79 %patch0 -p1
80 %patch1 -p1
81
82 %build
83 for i in ` echo Configure Makefile.org `; do
84         sed -e 's#-m486##g' \
85                 -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' \
86                 <$i >$i.work
87         mv $i.work $i
88 done
89
90 perl util/perlpath.pl %{_bindir}
91
92 ln -s crypto sslcrypto
93
94 ./config --openssldir=%{openssldir}
95
96 make OPT_FLAGS="$RPM_OPT_FLAGS" linux-shared
97 make INSTALLTOP=%{_prefix} OPT_FLAGS="$RPM_OPT_FLAGS"
98 make rehash
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
104
105 make install \
106         INSTALLTOP=%{_prefix} \
107         INSTALL_PREFIX=$RPM_BUILD_ROOT
108
109 install libRSAglue.a    $RPM_BUILD_ROOT%{_libdir}
110 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
111 mv      lib*.so         $RPM_BUILD_ROOT%{_libdir}
112
113
114 mv $RPM_BUILD_ROOT%{openssldir}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}
115 ln -s $RPM_BUILD_ROOT%{_sysconfdir}/openssl.cnf \
116         $RPM_BUILD_ROOT%{openssldir}/openssl.cnf
117 symlinks -cs $RPM_BUILD_ROOT%{openssldir}
118
119 mv $RPM_BUILD_ROOT%{openssldir}/misc/*  $RPM_BUILD_ROOT%{_pkglibdir}
120 rm -rf $RPM_BUILD_ROOT%{openssldir}/misc
121
122 strip $RPM_BUILD_ROOT%{_bindir}/* || :
123 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* || :
124
125 gzip -9fn CHANGES CHANGES.SSLeay LICENSE NEWS README \
126         doc/*.pod doc/*.txt
127
128 %post
129 %{_bindir}/c_rehash certs
130 /sbin/ldconfig
131
132 %postun -p /sbin/ldconfig
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
140 %doc doc/*.pod.gz doc/*.txt.gz
141 %doc doc/openssl_button.gif doc/openssl_button.html
142
143 %attr(755,root,root) %{_bindir}/*
144 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/openssl.cnf
145 %verify(not md5 size mtime) %config(noreplace) %{openssldir}/openssl.cnf
146 %{openssldir}/certs
147 %{openssldir}/private
148 %dir %{_pkglibdir}
149 %attr(755,root,root) %{_pkglibdir}/*
150 %attr(755,root,root) %{_libdir}/lib*.so.*.*
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/lib*.so
155 %{_pkgincludedir}
156
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/lib*.a
This page took 0.039362 seconds and 4 git commands to generate.