]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- added fr Summary (from MDK).
[packages/openssl.git] / openssl.spec
1 Summary:        Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
2 Summary(de):    Secure Sockets Layer (SSL)-Kommunikationslibrary & Utilities
3 Summary(fr):    Utilitaires et librairies de communication SSL (Secure Sockets Layer)
4 Name:           openssl
5 Version:        0.9.4
6 Release:        2
7 Group:          Libraries
8 Group(pl):      Biblioteki
9 Source:         ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
10 Patch:          openssl-perl.patch
11 Vendor:         The OpenSSL Project
12 License:        Apache-style License
13 BuildRequires:  symlinks
14 BuildRequires:  perl
15 BuildRoot:      /tmp/%{name}-%{version}-root
16 Obsoletes:      SSLeay
17 Obsoletes:      SSLeay-devel
18 Obsoletes:      SSLeay-perl
19
20 %define         openssldir      /var/state/openssl
21 %define         _sysconfdir     /etc/%{name}
22 %define         _pkglibdir      %{_libdir}/%{name}
23 %define         _pkgincludedir  %{_includedir}/%{name}
24
25 %description
26 The OpenSSL Project is a collaborative effort to develop a robust,
27 commercial-grade, full-featured, and Open Source toolkit implementing
28 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
29 v1) protocols with full-strength cryptography world-wide. The project
30 is managed by a worldwide community of volunteers that use the
31 Internet to communicate, plan, and develop the OpenSSL tookit and its
32 related documentation.
33    
34 OpenSSL is based on the excellent SSLeay library developed by Eric A.
35 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
36 Apache-style licence, which basically means that you are free to get
37 and use it for commercial and non-commercial purposes subject to some
38 simple license conditions.
39
40 %description -l de
41 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared libraries,
42 die verschiedene Verschlüsselungs- und Entschlüsselungsalgorithmen und
43 -protokolle, wie DES, RC4, RSA und SSL zur Verfügung stellen.                                                 
44
45 %description -l fr
46 OpenSSL est un outiil de gestion des certificats et les librairies partagees
47 qui fournit plusieurs protocoles et algorithmes de codage/decodage, incluant
48 DES, RC4, RSA et SSL.
49
50 %package devel
51 Summary:        Development part of OpenSSL library
52 Summary(de):    Secure Sockets Layer Kommunikationslibrary: statische libraries+header                           
53 Summary(fr):    Librairies statiques, headers et utilitaires pour communication SSL (Secure Sockets Layer)
54 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
55 Group:          Development/Libraries
56 Group(pl):      Programowanie/Biblioteki
57 Requires:       %{name} = %{version}
58
59 %description devel
60 Development part of OpenSSL library.
61
62 %description devel -l pl
63 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
64
65 %package static
66 Summary:        Static OpenSSL library
67 Summary(pl):    Statyczna wersja biblioteki OpenSSL
68 Group:          Development/Libraries
69 Group(pl):      Programowanie/Biblioteki
70 Requires:       %{name}-devel = %{version}
71
72 %description static
73 Static OpenSSL library.
74
75 %description static -l pl
76 Statyczna wersja biblioteki OpenSSL.
77
78 %prep
79 %setup -q 
80 %patch -p1
81
82 %build
83 for i in ` echo Configure Makefile.org `; do
84         sed -e 's#-m486##g' \
85                 -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' \
86                 <$i >$i.work
87         mv $i.work $i
88 done
89
90 perl util/perlpath.pl %{_bindir}
91
92 ln -s crypto sslcrypto
93
94 ./config --openssldir=%{openssldir}
95
96 make OPT_FLAGS="$RPM_OPT_FLAGS" linux-shared
97 make INSTALLTOP=%{_prefix} OPT_FLAGS="$RPM_OPT_FLAGS"
98 make rehash
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
104
105 make install \
106         INSTALLTOP=%{_prefix} \
107         INSTALL_PREFIX=$RPM_BUILD_ROOT
108
109 install libRSAglue.a    $RPM_BUILD_ROOT%{_libdir}
110 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
111 cp -d   lib*.so         $RPM_BUILD_ROOT%{_libdir}
112
113
114 mv $RPM_BUILD_ROOT%{openssldir}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}
115 ln -s %{_sysconfdir}/openssl.cnf \
116         $RPM_BUILD_ROOT%{openssldir}/openssl.cnf
117 symlinks -cs $RPM_BUILD_ROOT%{openssldir}
118
119 mv $RPM_BUILD_ROOT%{openssldir}/misc/*  $RPM_BUILD_ROOT%{_pkglibdir}
120 rm -rf $RPM_BUILD_ROOT%{openssldir}/misc
121
122 strip $RPM_BUILD_ROOT%{_bindir}/* || :
123 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* || :
124
125 gzip -9fn CHANGES CHANGES.SSLeay LICENSE NEWS README \
126         doc/*.pod doc/*.txt
127
128 %post
129 %{_bindir}/c_rehash certs
130 /sbin/ldconfig
131
132 %postun -p /sbin/ldconfig
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
140 %doc doc/*.pod.gz doc/*.txt.gz
141 %doc doc/openssl_button.gif doc/openssl_button.html
142
143 %attr(755,root,root) %{_bindir}/*
144 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/openssl.cnf
145 %verify(not md5 size mtime) %config(noreplace) %{openssldir}/openssl.cnf
146 %{openssldir}/certs
147 %{openssldir}/private
148 %dir %{_pkglibdir}
149 %attr(755,root,root) %{_pkglibdir}/*
150 %attr(755,root,root) %{_libdir}/lib*.so.*.*
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/lib*.so
155 %{_pkgincludedir}
156
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/lib*.a
This page took 0.039657 seconds and 4 git commands to generate.